]> git.pld-linux.org Git - packages/dvdrip.git/blobdiff - dvdrip.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dvdrip.git] / dvdrip.spec
index 3932ab61e8700dbcab1b36c65778899272d1b92e..8edb2df4bb129b1e135c24321a3e2c26530fcac4 100644 (file)
@@ -1,47 +1,96 @@
-%include        /usr/lib/rpm/macros.perl
-Summary:       Video-DVDRip module for perl
-Name:          perl-Video-DVDRip
-Version:       0.44
-Release:       0.1
-Copyright:     distributable
+# Conditional build:
+%bcond_with    tests   # perform "make test" (needs working, not busy /dev/audio!)
+#
+Summary:       Video::DVDRip Perl module
+Summary(cs.UTF-8):     Modul Video::DVDRip pro Perl
+Summary(da.UTF-8):     Perlmodul Video::DVDRip
+Summary(de.UTF-8):     Video::DVDRip Perl Modul
+Summary(es.UTF-8):     Módulo de Perl Video::DVDRip
+Summary(fr.UTF-8):     Module Perl Video::DVDRip
+Summary(it.UTF-8):     Modulo di Perl Video::DVDRip
+Summary(ja.UTF-8):     Video::DVDRip Perl モジュール
+Summary(ko.UTF-8):     Video::DVDRip 펄 모줄
+Summary(nb.UTF-8):     Perlmodul Video::DVDRip
+Summary(pl.UTF-8):     Moduł Perla Video::DVDRip
+Summary(pt.UTF-8):     Módulo de Perl Video::DVDRip
+Summary(pt_BR.UTF-8):  Módulo Perl Video::DVDRip
+Summary(ru.UTF-8):     Модуль для Perl Video::DVDRip
+Summary(sv.UTF-8):     Video::DVDRip Perlmodul
+Summary(uk.UTF-8):     Модуль для Perl Video::DVDRip
+Summary(zh_CN.UTF-8):  Video::DVDRip Perl 模块
+Name:          dvdrip
+Version:       0.98.11
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.exit1.org/dvdrip/dist/Video-DVDRip-%{version}.tar.gz
+Source0:       http://www.exit1.org/dvdrip/dist/%{name}-%{version}.tar.gz
+# Source0-md5: 6dfa4199d451757a37eea233a07da4c0
+Patch0:                %{name}-locale_path.patch
 URL:           http://www.exit1.org/dvdrip/
-BuildRequires: perl >= 5.6
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl-gtk
-BuildRequires: gdk-pixbuf-devel
+BuildRequires: perl-AnyEvent
+BuildRequires: perl-Event
+BuildRequires: perl-Event-RPC
+BuildRequires: perl-Event-ExecFlow
+BuildRequires: perl-Gtk2-Ex-FormFactory
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: perl-libintl >= 1.16
+BuildRequires: rpm-perlprov >= 4.1-13
+Requires:      ImageMagick
+Requires:      perl-libintl >= 1.16
 Requires:      transcode
+Suggests:      ffmpeg
+Suggests:      mplayer
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _noautoreq      'perl(Video::DVDRip::Task)'
+
 %description
-dvd::rip is a Perl Gtk+ based DVD copy program build on top of a low
+dvd::rip is a Perl GTK+ based DVD copy program build on top of a low
+level DVD Ripping API, which uses the Linux Video Stream Processing
+Tool transcode, written by Thomas Oestreich.
+
+%description -l en.UTF-8
+dvd::rip is a Perl GTK+ based DVD copy program build on top of a low
 level DVD Ripping API, which uses the Linux Video Stream Processing
-Tool transcode, written by Thomas Östreich.
+Tool transcode, written by Thomas Östreich.
+
+%description -l pl.UTF-8
+dvd::rip jest opartym na GTK+ programem w Perlu do kopiowania DVD,
+zbudowanym w oparciu o niskopoziomowe API DVD Ripping, które z kolei
+korzysta z transcode - linuksowego narzędzia do obróbki strumieni
+obrazu, napisanego przez Thomasa Östreicha.
 
 %prep
-%setup -q -n Video-DVDRip-%{version}
+%setup -q
+%patch0 -p1
 
 %build
-CFLAGS="%{rpmcflags}" perl Makefile.PL
-%{__make}
-%{__make} test
+export SKIP_UNPACK_REQUIRED_MODULES=1
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make} -j1 \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags}"
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-eval `perl '-V:installarchlib'`
-install -d $RPM_BUILD_ROOT/$installarchlib
-%{__make} PREFIX=$RPM_BUILD_ROOT%{_prefix} install
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+mv $RPM_BUILD_ROOT%{perl_vendorlib}/LocaleData $RPM_BUILD_ROOT%{_datadir}/locale
+
+%find_lang video.%{name}
 
-find $RPM_BUILD_ROOT%{_prefix} -type f -print |
-       sed "s@^$RPM_BUILD_ROOT@@g" |
-       grep -v perllocal.pod |
-       grep -v "\.packlist" > Video-DVDRip-%{version}-filelist
-if [ "$(cat Video-DVDRip-%{version}-filelist)X" = "X" ] ; then
-    echo "ERROR: EMPTY FILE LIST"
-    exit -1
-fi
+%clean
+rm -rf $RPM_BUILD_ROOT
 
-%files -f Video-DVDRip-%{version}-filelist
+%files -f video.%{name}.lang
 %defattr(644,root,root,755)
+%doc Changes Credits README TODO
+%attr(755,root,root) %{_bindir}/*
+%{perl_vendorlib}/Video
+%{_mandir}/man1/*
+%{_mandir}/man3/Video*
This page took 0.096365 seconds and 4 git commands to generate.