]> git.pld-linux.org Git - packages/duplicati.git/commitdiff
Version: 2.0.4.10
authorJacek Konieczny <jajcus@jajcus.net>
Thu, 3 Jan 2019 17:55:17 +0000 (18:55 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Thu, 3 Jan 2019 17:55:17 +0000 (18:55 +0100)
Scripts, icons and desktop files copied from Installer/debian in the
source repository.

Package built from a 'binary' ZIP, as building it from sources would
bring mono dependency hell.

duplicati-cli.sh [new file with mode: 0644]
duplicati-server.sh [new file with mode: 0644]
duplicati.desktop [new file with mode: 0644]
duplicati.png [new file with mode: 0644]
duplicati.service [new file with mode: 0644]
duplicati.sh [new file with mode: 0644]
duplicati.spec
duplicati.svg [new file with mode: 0644]

diff --git a/duplicati-cli.sh b/duplicati-cli.sh
new file mode 100644 (file)
index 0000000..e69ec9d
--- /dev/null
@@ -0,0 +1,9 @@
+#!/bin/bash
+INSTALLDIR=/usr/share/duplicati
+export LD_LIBRARY_PATH="${INSTALLDIR}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
+export MONO_PATH=$MONO_PATH:${INSTALLDIR}
+
+EXE_FILE=${INSTALLDIR}/Duplicati.CommandLine.exe
+APP_NAME=Duplicati.CommandLine
+
+exec -a "$APP_NAME" mono "$EXE_FILE" "$@"
diff --git a/duplicati-server.sh b/duplicati-server.sh
new file mode 100644 (file)
index 0000000..af2160d
--- /dev/null
@@ -0,0 +1,9 @@
+#!/bin/bash
+INSTALLDIR=/usr/share/duplicati
+export LD_LIBRARY_PATH="${INSTALLDIR}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
+export MONO_PATH=$MONO_PATH:${INSTALLDIR}
+
+EXE_FILE=${INSTALLDIR}/Duplicati.Server.exe
+APP_NAME=DuplicatiServer
+
+exec -a "$APP_NAME" mono "$EXE_FILE" "$@"
diff --git a/duplicati.desktop b/duplicati.desktop
new file mode 100644 (file)
index 0000000..ba42760
--- /dev/null
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Categories=System;Archiving;FileTools;Filesystem;
+Type=Application
+Name=Duplicati
+GenericName= Backup tool
+GenericName[es]= Copias de respaldo
+Comment= Create and maintain local and remote backup copies of your data
+Comment[es]= Cree y mantenga copias de seguridad locales y remotas
+Exec=duplicati
+Icon=duplicati
+Terminal=false
+StartupNotify=true
diff --git a/duplicati.png b/duplicati.png
new file mode 100644 (file)
index 0000000..5184f62
Binary files /dev/null and b/duplicati.png differ
diff --git a/duplicati.service b/duplicati.service
new file mode 100644 (file)
index 0000000..dd4cf3a
--- /dev/null
@@ -0,0 +1,12 @@
+[Unit]
+Description=Duplicati web-server
+After=network.target
+
+[Service]
+Nice=19
+IOSchedulingClass=idle
+EnvironmentFile=-/etc/sysconfig/duplicati
+ExecStart=/usr/bin/duplicati-server $DAEMON_OPTS
+
+[Install]
+WantedBy=multi-user.target
diff --git a/duplicati.sh b/duplicati.sh
new file mode 100644 (file)
index 0000000..f6bde74
--- /dev/null
@@ -0,0 +1,9 @@
+#!/bin/bash
+INSTALLDIR=/usr/share/duplicati
+export LD_LIBRARY_PATH="${INSTALLDIR}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
+export MONO_PATH=$MONO_PATH:${INSTALLDIR}
+
+EXE_FILE=${INSTALLDIR}/Duplicati.GUI.TrayIcon.exe
+APP_NAME=Duplicati
+
+exec -a "$APP_NAME" mono "$EXE_FILE" "$@"
index a70fd01845113010c1624e3211de6fd4ad124d87..9ade8a4105ff7fc6f3da28359a5705b31b7a4dbd 100644 (file)
@@ -1,14 +1,23 @@
-# TODO
-# - mono packages can be noarch?
-# - remove non-linux binaries
 %include /usr/lib/rpm/macros.mono
 %include /usr/lib/rpm/macros.mono
+
+# the names of the tags (used in source filenames) are insane
+%define tag_code       canary
+%define tag_date       2018-12-29
+
 Summary:       Backup client for encrypted online backups
 Name:          duplicati
 Summary:       Backup client for encrypted online backups
 Name:          duplicati
-Version:       1.3.4
-Release:       0.1
+Version:       2.0.4.10
+Release:       1
 License:       LGPL v2+
 License:       LGPL v2+
-Source0:       http://duplicati.googlecode.com/files/Duplicati%20%{version}.tgz?/Duplicati-%{version}.tgz
-# Source0-md5: 4980c4f6c373387e4452a983b235f7f3
+Source0:       https://github.com/duplicati/duplicati/releases/download/v%{version}-%{version}_%{tag_code}_%{tag_date}/duplicati-%{version}_%{tag_code}_%{tag_date}.zip
+# Source0-md5: 5d5443e04a4a4fe462f24fb2f989ac08
+Source1:       duplicati.sh
+Source2:       duplicati-cli.sh
+Source3:       duplicati-server.sh
+Source4:       duplicati.svg
+Source5:       duplicati.png
+Source6:       duplicati.desktop
+Source7:       duplicati.service
 Group:         Applications
 URL:           http://www.duplicati.com/
 BuildRequires: desktop-file-utils
 Group:         Applications
 URL:           http://www.duplicati.com/
 BuildRequires: desktop-file-utils
@@ -19,60 +28,41 @@ Requires:   bash
 Requires:      desktop-file-utils
 Requires:      gtk-update-icon-cache
 Requires:      hicolor-icon-theme
 Requires:      desktop-file-utils
 Requires:      gtk-update-icon-cache
 Requires:      hicolor-icon-theme
+Requires:      libappindicator-gtk2
+Requires:      mono-addins-gui
+Requires:      sqlite3
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _appdir %{_prefix}/lib/%{name}
-
 %description
 %description
-Duplicati is a free backup client that securely stores encrypted,
-incremental, compressed backups on cloud storage services and remote
-file servers. It supports targets like Amazon S3, Windows Live
-SkyDrive, Rackspace Cloud Files or WebDAV, SSH, FTP (and many more).
-
-Duplicati has built-in AES-256 encryption and backups be can signed
-using GNU Privacy Guard. A built-in scheduler makes sure that backups
-are always up-to-date. Last but not least, Duplicati provides various
-options and tweaks like filters, deletion rules, transfer and
-bandwidth options to run backups for specific purposes.
+Duplicati is a free, open source, backup client that securely stores encrypted,
+incremental, compressed backups on cloud storage services and remote file
+servers. It works with: Amazon S3, OneDrive, Google Drive, Rackspace Cloud
+Files, HubiC, Backblaze (B2), Amazon Cloud Drive (AmzCD), Swift / OpenStack,
+WebDAV, SSH (SFTP), FTP, and more!
 
 %prep
 
 %prep
-%setup -q -c
+%setup -qc
 
 
-# for files/doc declaration:
-mv usr/share/doc/duplicati/README .
-rm usr/share/doc/duplicati/changelog.Debian.gz
-mv usr/share/doc/duplicati/copyright .
-mv usr/share/doc/duplicati/changelog.gz .
-rmdir usr/share/doc/duplicati usr/share/doc
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_bindir},%{_iconsdir}/hicolor/{48x48,scalable}/apps,%{_desktopdir},%{systemdunitdir}}
 
 
-rm -r install
-rm usr/share/pixmaps/duplicati.xpm
+%{__cp} -a * $RPM_BUILD_ROOT%{_datadir}/%{name}
 
 
-gzip -d changelog.gz
+install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/duplicati
+install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/duplicati-cli
+install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/duplicati-server
 
 
-%install
-rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT
-cp -a usr $RPM_BUILD_ROOT
+install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps
+install -m644 %{SOURCE5} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps
+install -m644 %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}
 
 
-# refined desktop file
-install -d $RPM_BUILD_ROOT%{_desktopdir}
-cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
-[Desktop Entry]
-Categories=System;Archiving;FileTools;Filesystem;
-Type=Application
-Name=Duplicati
-GenericName= Backup tool
-GenericName[es]= Copias de respaldo
-Comment= Create and maintain local and remote backup copies of your data
-Comment[es]= Cree y mantenga copias de seguridad locales y remotas
-Exec=duplicati
-Icon=duplicati
-Terminal=false
-StartupNotify=true
-EOF
+#install -m644 %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}
 
 
-desktop-file-install $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/OSX*
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/win-tools
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/run-script-example.*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -87,31 +77,25 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 
 %files
 %defattr(644,root,root,755)
-%doc README copyright changelog
+%doc *.txt run-script-example.sh
 %attr(755,root,root) %{_bindir}/duplicati
 %attr(755,root,root) %{_bindir}/duplicati
-%attr(755,root,root) %{_bindir}/duplicati-commandline
+%attr(755,root,root) %{_bindir}/duplicati-cli
+%attr(755,root,root) %{_bindir}/duplicati-server
 %{_desktopdir}/duplicati.desktop
 %{_desktopdir}/duplicati.desktop
-%{_pixmapsdir}/duplicati.png
-%dir %{_appdir}
-%{_appdir}/*.txt
-%{_appdir}/*.dll
-%{_appdir}/*.exe
-%{_appdir}/*.exe.config
-%{_appdir}/*.xml
-%{_appdir}/SQLite
-%{_appdir}/Tools
-%{_appdir}/alphavss
-%{_appdir}/licenses
-%dir %{_appdir}/lvm-scripts
-%attr(755,root,root) %{_appdir}/lvm-scripts/*.sh
-
-%lang(de) %{_appdir}/de-DE
-%lang(es) %{_appdir}/es-ES
-%lang(fr) %{_appdir}/fr-FR
-%lang(it) %{_appdir}/it-IT
-%lang(pt_BR) %{_appdir}/pt-BR
-%lang(ru) %{_appdir}/ru-RU
-%lang(tr_TR) %{_appdir}/tr-TR
-%lang(zh_CN) %{_appdir}/zh-CN
-%lang(zh_HK) %{_appdir}/zh-HK
-%lang(da_DK) %{_appdir}/da-DK
+%{_iconsdir}/hicolor/48x48/apps/duplicati.png
+%{_iconsdir}/hicolor/scalable/apps/duplicati.svg
+%dir %{_datadir}/%{name}
+%{_datadir}/%{name}/*.dll
+%{_datadir}/%{name}/*.dll.config
+%{_datadir}/%{name}/*.exe
+%{_datadir}/%{name}/*.exe.config
+%{_datadir}/%{name}/*.txt
+%{_datadir}/%{name}/autoupdate.manifest
+%{_datadir}/%{name}/SQLite
+%{_datadir}/%{name}/SVGIcons
+%{_datadir}/%{name}/alphavss
+%{_datadir}/%{name}/licenses
+%{_datadir}/%{name}/utility-scripts
+%{_datadir}/%{name}/webroot
+%dir %{_datadir}/%{name}/lvm-scripts
+%attr(755,root,root) %{_datadir}/%{name}/lvm-scripts/*.sh
diff --git a/duplicati.svg b/duplicati.svg
new file mode 100644 (file)
index 0000000..bbb6486
--- /dev/null
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!-- Generator: Adobe Illustrator 19.2.1, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
+<svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
+        viewBox="0 0 32 32" style="enable-background:new 0 0 32 32;" xml:space="preserve">
+<style type="text/css">
+       .st0{display:none;}
+       .st1{fill:#D0CDC6;}
+       .st2{fill:#FFFFFF;}
+       .st3{fill:#1D4775;}
+       .st4{fill:#8194A9;}
+       .st5{fill:#EBF1F5;}
+       .st6{fill:#65B1DD;}
+       .st7{fill:#336697;}
+</style>
+<g id="backgrounds" class="st0">
+       <rect id="black" x="-16" y="-16" width="64" height="64"/>
+       <rect id="win2k" x="-16" y="-16" class="st1" width="64" height="64"/>
+       <rect id="white" x="-16" y="-16" class="st2" width="64" height="64"/>
+       <rect id="win7_aero" x="-16" y="-16" class="st3" width="64" height="64"/>
+       <rect id="win7_1_" x="-16" y="-16" class="st4" width="64" height="64"/>
+       <rect id="macosx" x="-16" y="-16" class="st5" width="64" height="64"/>
+</g>
+<g id="icon">
+       <g id="small_8_">
+               <path class="st6" d="M15,28c-1.7,0-3-1.3-3-3v-5c0-1.7,1.3-3,3-3h8c1.7,0,3,1.3,3,3v5c0,1.7-1.3,3-3,3H15z"/>
+               <path class="st2" d="M23,18c1.1,0,2,0.9,2,2v5c0,1.1-0.9,2-2,2h-8c-1.1,0-2-0.9-2-2v-5c0-1.1,0.9-2,2-2H23 M23,16h-8
+                       c-2.2,0-4,1.8-4,4v5c0,2.2,1.8,4,4,4h8c2.2,0,4-1.8,4-4v-5C27,17.8,25.2,16,23,16L23,16z"/>
+       </g>
+       <g id="middle_8_">
+               <path class="st7" d="M4,30c-1.7,0-3-1.3-3-3v-7c0-1.7,1.3-3,3-3h10c1.7,0,3,1.3,3,3v7c0,1.7-1.3,3-3,3H4z"/>
+               <path class="st2" d="M14,18c1.1,0,2,0.9,2,2v7c0,1.1-0.9,2-2,2H4c-1.1,0-2-0.9-2-2v-7c0-1.1,0.9-2,2-2H14 M14,16H4
+                       c-2.2,0-4,1.8-4,4v7c0,2.2,1.8,4,4,4h10c2.2,0,4-1.8,4-4v-7C18,17.8,16.2,16,14,16L14,16z"/>
+       </g>
+       <g id="big_10_">
+               <path class="st3" d="M12,21c-1.7,0-3-1.3-3-3V6c0-1.7,1.3-3,3-3h16c1.7,0,3,1.3,3,3v12c0,1.7-1.3,3-3,3H12z"/>
+               <path class="st2" d="M28,4c1.1,0,2,0.9,2,2v12c0,1.1-0.9,2-2,2H12c-1.1,0-2-0.9-2-2V6c0-1.1,0.9-2,2-2H28 M28,2H12
+                       C9.8,2,8,3.8,8,6v12c0,2.2,1.8,4,4,4h16c2.2,0,4-1.8,4-4V6C32,3.8,30.2,2,28,2L28,2z"/>
+       </g>
+</g>
+</svg>
This page took 0.110811 seconds and 4 git commands to generate.