]> git.pld-linux.org Git - packages/dump.git/commitdiff
- fixed usage of macros
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Jul 1999 11:04:33 +0000 (11:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added/removed neccesary/obsolete patches
- FHS 2.0 compliance where needed
- gzipping docs where needed

Changed files:
    dump.spec -> 1.7

dump.spec

index 8a4e45ce979152bd3b2661c7edd8fbe6a7cc960a..941f510a3980edc8b8bb9030ddfb7146ba075adc 100644 (file)
--- a/dump.spec
+++ b/dump.spec
@@ -1,20 +1,18 @@
-Summary:     dump/restore backup system
-Summary(de): Dump/Restore-Backup-System 
-Summary(fr): système de sauvegarde dump/restore
-Summary(pl): System kopii bezpieczeñstwa dump/restore
-Summary(tr): dump/restore yedekleme sistemi
-Name:        dump
-Version:     0.3
-Release:     14
-Copyright:   UCB
-Group:       Utilities/System
-Source:      ftp://tsx-11.mit.edu:/pub/linux/packages/ext2fs/%{name}-%{version}.tar.gz
-Patch:       dump-config.patch
-Patch1:      dump-0.3-types.patch
-Patch2:      dump-0.3-glibc.patch
-Patch3:      dump-0.3-sparc.patch
-Patch4:      dump-0.3-kernel.patch
-Requires:    rmt
+Summary:       dump/restore backup system
+Summary(de):   Dump/Restore-Backup-System 
+Summary(fr):   système de sauvegarde dump/restore
+Summary(pl):   System kopii bezpieczeñstwa dump/restore
+Summary(tr):   dump/restore yedekleme sistemi
+Name:          dump
+Version:       0.4b4
+Release:       1
+Copyright:     UCB
+Group:         Utilities/System
+Source:                ftp://tsx-11.mit.edu:/pub/linux/packages/ext2fs/%{name}-%{version}.tar.gz
+Patch0:                dump-glibc.patch
+Patch1:                dump-sparc.patch
+Patch2:                dump-kernel.patch
+Requires:      rmt
 BuildRoot:     /tmp/%{name}-%{version}-root
 
 %description
@@ -38,12 +36,12 @@ dump, ext2 b
 restore ise dump ile alýnan yedekleri geri yükleyen programdýr.
 
 %package -n rmt
-Summary:     Remote (network) tape device access
-Summary(de): Entfernter Zugriff (Netzwerk) auf Magnetbandgeräte
-Summary(fr): Accès distant (réseau) à un périphérique bande
-Summary(pl): Zdalny dostêp do napêdów ta¶m magnetycznych
-Summary(tr): Uzak teyp sürücülerine eriþim aracý
-Group:       Utilities/System
+Summary:       Remote (network) tape device access
+Summary(de):   Entfernter Zugriff (Netzwerk) auf Magnetbandgeräte
+Summary(fr):   Accès distant (réseau) à un périphérique bande
+Summary(pl):   Zdalny dostêp do napêdów ta¶m magnetycznych
+Summary(tr):   Uzak teyp sürücülerine eriþim aracý
+Group:         Utilities/System
 
 %description -n rmt
 rmt provides remote access to tape devices for programs like dump,
@@ -67,48 +65,61 @@ uzaktan eri
 
 %prep
 %setup -q
-%patch0 -p0 -b .config 
-%patch1 -p1 -b .types
-%patch2 -p1 -b .glibc
-#%patch3 -p1 -b .sparc
-%patch4 -p1 -b .kernel
+%patch0 -p1
+#%patch1 -p1
+%patch2 -p1
 
 %build
-make OPT="$RPM_OPT_FLAGS"
+MYNAME=`id -ru` \
+MYGRP=`id -rg` \
+%configure \
+       --enable-rmt \
+       --with-ccopts="$RPM_OPT_FLAGS" \
+       --with-ldopts="-s" \
+       --with-binowner=$MYNAME \
+       --with-bingrp=$MYGRP \
+       --with-binmode=6755 \
+       --with-manowner=$MYNAME \
+       --with-mangrp=$MYGRP \
+       --with-manmode=644
+make
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/{etc,sbin,usr/man/man8}
+install -d $RPM_BUILD_ROOT/{etc,sbin,%{_mandir}/man8}
 
-MYNAME=`id -u`
-MYGRP=`id -g`
-make BINDIR=$RPM_BUILD_ROOT/sbin MANDIR=$RPM_BUILD_ROOT%{_mandir}/man8 \
-BINOWN=$MYNAME BINGRP=$MYGRP MANOWN=$MYNAME MANGRP=$MYGRP install
+make BINDIR=$RPM_BUILD_ROOT/sbin MANDIR=$RPM_BUILD_ROOT%{_mandir}/man8 install
 
 > $RPM_BUILD_ROOT/etc/dumpdates
 
 ln -sf dump $RPM_BUILD_ROOT/sbin/rdump
 ln -sf restore $RPM_BUILD_ROOT/sbin/rrestore
 
+rm -f $RPM_BUILD_ROOT%{_mandir}/man8/{rdump,rrestore}.8
+
 echo ".so dump.8" > $RPM_BUILD_ROOT%{_mandir}/man8/rdump.8
 echo ".so restore.8" > $RPM_BUILD_ROOT%{_mandir}/man8/rrestore.8
 
+gzip -9nf COPYRIGHT KNOWNBUGS THANKS CHANGES dump-0.3.announce \
+       $RPM_BUILD_ROOT%{_mandir}/man8/*
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(0644,root,root, 0755)
-%doc COPYRIGHT KNOWNBUGS THANKS CHANGES dump-0.3.announce
-%attr(0664,root, disk) %verify(not md5 mtime size) %config(noreplace) /etc/dumpdates
+%defattr(644,root,root,755)
+%doc {COPYRIGHT,KNOWNBUGS,THANKS,CHANGES,dump-0.3.announce}.gz
+%attr(664,root, disk) %verify(not md5 mtime size) %config(noreplace) /etc/dumpdates
 %attr(6755,root,root) /sbin/dump
-%attr(0755,root,root) /sbin/rdump
+%attr(755,root,root) /sbin/rdump
 %attr(6755,root,root) /sbin/restore
-%attr(0755,root,root) /sbin/rrestore
-%attr(0755,root,  man) %{_mandir}/man8/dump.8
-%attr(0755,root,  man) %{_mandir}/man8/rdump.8
-%attr(0755,root,  man) %{_mandir}/man8/restore.8
-%attr(0755,root,  man) %{_mandir}/man8/rrestore.8
+%attr(755,root,root) /sbin/rrestore
+%{_mandir}/man8/dump.8.gz
+%{_mandir}/man8/rdump.8.gz
+%{_mandir}/man8/restore.8.gz
+%{_mandir}/man8/rrestore.8.gz
 
 %files -n rmt
-%attr(0755,root,root) /sbin/rmt
-%attr(0755,root,  man) %{_mandir}/man8/rmt.8 
+%defattr(644,root,root,755)
+%attr(755,root,root) /sbin/rmt
+%{_mandir}/man8/rmt.8.gz
This page took 0.044256 seconds and 4 git commands to generate.