]> git.pld-linux.org Git - packages/dssim2.git/commitdiff
- disable debugsource packages, updated archs list
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 28 Dec 2021 20:17:31 +0000 (21:17 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 28 Dec 2021 20:17:31 +0000 (21:17 +0100)
dssim2.spec

index 70ef0ad19a7068860ebba94a259dd01480f93e53..ddf20a10e3efcc9b3d4a8dd0c68106e6fb1791c6 100644 (file)
@@ -18,9 +18,16 @@ URL:         https://kornel.ski/dssim
 BuildRequires: cargo
 BuildRequires: rust
 Obsoletes:     dssim < 2
-ExclusiveArch: %{x8664} %{ix86}
+ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _debugsource_packages   0
+%ifarch        x32
+%define                target_opt      --target x86_64-unknown-linux-gnux32
+%else
+%define                target_opt      %{nil}
+%endif
+
 %description
 This tool computes (dis)similarity between two or more PNG images
 using an algorithm approximating human vision.
@@ -54,14 +61,16 @@ EOF
 %build
 export CARGO_HOME="$(pwd)/.cargo"
 
-cargo -v build --release --frozen
+cargo -v build --release --frozen %{target_opt}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 export CARGO_HOME="$(pwd)/.cargo"
 
-cargo -v install --frozen --path . --root $RPM_BUILD_ROOT%{_prefix}
+cargo -v install --frozen %{target_opt} \
+       --path . \
+       --root $RPM_BUILD_ROOT%{_prefix}
 
 %{__rm} $RPM_BUILD_ROOT%{_prefix}/.crates.toml
 %{__rm} $RPM_BUILD_ROOT%{_prefix}/.crates2.json
This page took 0.19833 seconds and 4 git commands to generate.