]> git.pld-linux.org Git - packages/dssim2.git/commitdiff
- updated to 2.9.4
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Dec 2017 09:32:29 +0000 (10:32 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Dec 2017 09:32:29 +0000 (10:32 +0100)
- packaging as dssim2 because of rust rewrite regressions (archs limited to x86* and no x32 ABI; no C library)

dssim-meson.patch [deleted file]
dssim.spec [deleted file]
dssim2.spec [new file with mode: 0644]

diff --git a/dssim-meson.patch b/dssim-meson.patch
deleted file mode 100644 (file)
index 67c099c..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
---- dssim-1.3.2/meson.build.orig       2016-05-05 14:02:11.000000000 +0200
-+++ dssim-1.3.2/meson.build    2017-07-28 20:57:02.888208491 +0200
-@@ -5,18 +5,17 @@
- dssim_sources = ['src/main.c',
-                'src/rwpng.c']
-+cc = meson.get_compiler('c')
- c_args = ['-DNDEBUG',
--        '-O3',
-         '-fstrict-aliasing',
-         '-ffast-math',
--        '-funroll-loops',
-         '-fomit-frame-pointer',
-         '-ffinite-math-only',
-         '-Wall',
-         '-std=c99']
--mathlib = find_library('m', required : true)
--zlib = find_library('z', required : true)
-+mathlib = cc.find_library('m', required : true)
-+zlib = cc.find_library('z', required : true)
- libdssim = shared_library('dssim-lib',
-                         dssim_lib_sources,
-@@ -27,7 +26,8 @@
- h = install_headers ('src/dssim.h')
--pkgconfig_gen(libraries : libdssim,
-+pkg = import('pkgconfig')
-+pkg.generate( libraries : libdssim,
-             subdirs : '.',
-             name : 'libdssim',
-             filebase : 'dssim',
diff --git a/dssim.spec b/dssim.spec
deleted file mode 100644 (file)
index dc5ed76..0000000
+++ /dev/null
@@ -1,100 +0,0 @@
-Summary:       Tool to compute (dis)similarity between two or more images
-Summary(pl.UTF-8):     Narzędzie do obliczania (nie)podobieństwa dwóch lub większej liczby obrazów
-Name:          dssim
-Version:       1.3.2
-Release:       1
-License:       AGPL v3+
-Group:         Applications/Graphics
-#Source0Download: https://github.com/pornel/dssim/releases
-Source0:       https://github.com/pornel/dssim/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 20072b430c94edb8c665ba87be00af3e
-Patch0:                %{name}-meson.patch
-URL:           https://kornel.ski/dssim
-BuildRequires: libpng-devel
-BuildRequires: meson
-BuildRequires: ninja
-BuildRequires: zlib-devel
-Requires:      %{name}-libs = %{version}-%{release}
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-
-%description
-This tool computes (dis)similarity between two or more PNG images
-using an algorithm approximating human vision.
-
-Comparison is done using the SSIM algorithm at multiple weighed
-resolutions.
-
-%description -l pl.UTF-8
-To narzędzie oblicza (nie)podobieństwo dwóch lub większej liczby
-obrazów PNG przy użyciu algorytmu przybliżającego ludzkie widzenie.
-
-Porównywanie jest wykonywane algorytmem SSIM z wieloma ważonymi
-rozdzielczościami.
-
-%package libs
-Summary:       DSSIM shared library
-Summary(pl.UTF-8):     Biblioteka współdzielona DSSIM
-Group:         Libraries
-
-%description libs
-DSSIM shared library to compute (dis)similarity between two or more
-images.
-
-%description libs -l pl.UTF-8
-Biblioteka współdzielona DSSIM do obliczania (nie)podobieństwa dwóch
-lub większej liczby obrazów.
-
-%package devel
-Summary:       Header file for DSSIM library
-Summary(pl.UTF-8):     Plik nagłówkowy biblioteki DSSIM
-Group:         Development/Libraries
-Requires:      %{name}-libs = %{version}-%{release}
-
-%description devel
-Header file for DSSIM library.
-
-%description devel -l pl.UTF-8
-Plik nagłówkowy biblioteki DSSIM.
-
-%prep
-%setup -q
-%patch0 -p1
-
-%build
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags} %{rpmcppflags}" \
-LDFLAGS="%{rpmldflags}" \
-meson build \
-       --buildtype=plain \
-       --prefix=%{_prefix} \
-       --libdir=%{_libdir}
-
-ninja -C build -v
-
-%install
-rm -rf $RPM_BUILD_ROOT
-
-DESTDIR=$RPM_BUILD_ROOT \
-ninja -C build -v install
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%post  libs -p /sbin/ldconfig
-%postun        libs -p /sbin/ldconfig
-
-%files
-%defattr(644,root,root,755)
-%doc README.md
-%attr(755,root,root) %{_bindir}/dssim
-
-%files libs
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libdssim-lib.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libdssim-lib.so.1
-
-%files devel
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libdssim-lib.so
-%{_includedir}/dssim.h
-%{_pkgconfigdir}/dssim.pc
diff --git a/dssim2.spec b/dssim2.spec
new file mode 100644 (file)
index 0000000..09361a9
--- /dev/null
@@ -0,0 +1,52 @@
+# TODO: build without network (crates downloading)
+Summary:       Tool to compute (dis)similarity between two or more images
+Summary(pl.UTF-8):     Narzędzie do obliczania (nie)podobieństwa dwóch lub większej liczby obrazów
+Name:          dssim2
+Version:       2.9.4
+Release:       1
+License:       AGPL v3+ or commercial
+Group:         Applications/Graphics
+#Source0Download: https://github.com/pornel/dssim/releases
+Source0:       https://github.com/pornel/dssim/archive/%{version}/dssim-%{version}.tar.gz
+# Source0-md5: 54394c0c4e145434aec6c2f683b1e120
+URL:           https://kornel.ski/dssim
+BuildRequires: cargo
+BuildRequires: rust
+Obsoletes:     dssim < 2
+ExclusiveArch: %{x8664} %{ix86}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This tool computes (dis)similarity between two or more PNG images
+using an algorithm approximating human vision.
+
+Comparison is done using the SSIM algorithm at multiple weighed
+resolutions.
+
+%description -l pl.UTF-8
+To narzędzie oblicza (nie)podobieństwo dwóch lub większej liczby
+obrazów PNG przy użyciu algorytmu przybliżającego ludzkie widzenie.
+
+Porównywanie jest wykonywane algorytmem SSIM z wieloma ważonymi
+rozdzielczościami.
+
+%prep
+%setup -q -n dssim-%{version}
+
+%build
+cargo build -v --release
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+cargo install --root $RPM_BUILD_ROOT%{_prefix}
+
+%{__rm} $RPM_BUILD_ROOT%{_prefix}/.crates.toml
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README.md
+%attr(755,root,root) %{_bindir}/dssim
This page took 0.165539 seconds and 4 git commands to generate.