]> git.pld-linux.org Git - packages/dssi.git/blame - dssi.spec
- default DSSI_PATH fixed for the jack host on 64-bit systems
[packages/dssi.git] / dssi.spec
CommitLineData
65b645a5 1Summary: Disposable Soft Synth Interface specification
57458f0e 2Summary(pl.UTF-8): Specyfikacja Disposable Soft Synth Interface
65b645a5 3Name: dssi
4f4c1293 4Version: 1.0.0
74eb3d40 5Release: 2
65b645a5
PS
6License: LGPL v2.1
7Group: Development/Libraries
8Source0: http://dl.sourceforge.net/dssi/%{name}-%{version}.tar.gz
4f4c1293 9# Source0-md5: bc4c50f9f9b3cd13019718266f8f15af
a72f4010 10Patch0: %{name}-qt_test.patch
74eb3d40 11Patch1: %{name}-lib64.patch
65b645a5 12URL: http://dssi.sourceforge.net/
0ae4bdb5 13BuildRequires: alsa-lib-devel >= 0.9
dbae6881
JK
14BuildRequires: autoconf
15BuildRequires: automake
65b645a5 16BuildRequires: jack-audio-connection-kit-devel
0ae4bdb5
JB
17BuildRequires: ladspa-devel >= 1.0
18BuildRequires: liblo-devel >= 0.12
4f4c1293
JK
19BuildRequires: libsamplerate-devel
20BuildRequires: libsndfile-devel
21BuildRequires: libsndfile-devel
dbae6881 22BuildRequires: libtool
29a653bf 23BuildRequires: pkgconfig
dbae6881 24BuildRequires: qt-devel >= 3.3
65b645a5
PS
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28DSSI (pronounced "dizzy") is an API for audio plugins, with particular
29application for software synthesis plugins with native user
30interfaces. DSSI is an open specification developed for use in Linux
31audio applications, although portable to other platforms. It may be
32thought of as LADSPA-for-instruments, or something comparable to VSTi.
33
34DSSI consists of a C language API for use by plugins and hosts, based
35on the LADSPA API, and an OSC (Open Sound Control) API for use in user
36interface to host communications. The DSSI specification consists of
37an RFC which describes the background for the proposal and defines the
38OSC part of the specification, and a documented header file which
39defines the C API.
40
dab913f7
JR
41%description -l pl.UTF-8
42DSSI (wymawiane "dizzy") to API dla wtyczek dźwiękowych z
43zastosowaniem szczególnie dla wtyczek syntezy programowej z natywnymi
44interfejsami użytkownika. DSSI to otwarta specyfikacja stworzona do
45używania w linuksowych aplikacjach dźwiękowych, ale przenośna na inne
46platformy. Można ją określić jako LADSPA dla instrumentów lub coś
47porównywalnego do VSTi.
c3db29b9 48
dab913f7
JR
49DSSI składa się z API języka C do użytku przez wtyczki i hosty, oparte
50o API LADSPA oraz API OSC (Open Sound Control) do użytku w
51interfejsach użytkownika do komunikacji z hostem. Specyfikacja DSSI
52składa się z RFC opisującego tło propozycji i definiującego część OSC
53specyfikacji oraz udokumentowanego pliku nagłówkowego definiującego
c3db29b9
JB
54API C.
55
4f4c1293
JK
56%package devel
57Summary: DSSI development files
58Summary(pl.UTF-8): Pliki nagłówkowe DSSI
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61Requires: alsa-lib-devel >= 0.9
62Requires: ladspa-devel >= 1.0
63Obsoletes: dssi < 1.0.0
64
65%description devel
66DSSI development files.
67
68%description devel -l pl.UTF-8
69Pliki nagłówkowe DSSI.
70
0ae4bdb5
JB
71%package host-jack
72Summary: A simple JACK/ALSA-sequencer plugin host
57458f0e 73Summary(pl.UTF-8): Prosty host wtyczek sekwencera JACK/ALSA
0ae4bdb5 74Group: Applications/Sound
4f4c1293 75Requires: %{name} = %{version}-%{release}
0ae4bdb5
JB
76Requires: liblo >= 0.12
77
78%description host-jack
79A simple JACK/ALSA-sequencer plugin host.
80
dab913f7 81%description host-jack -l pl.UTF-8
0ae4bdb5
JB
82Prosty host wtyczek sekwencera JACK/ALSA.
83
4f4c1293
JK
84%package examples
85Summary: Example DSSI plugins
86Summary(pl.UTF-8): Przykładowe wtyczki DSSI
87Group: Applications/Sound
88Requires: %{name} = %{version}-%{release}
89
90%description examples
91Example DSSI plugins.
92
93%description examples -l pl.UTF-8
94Przykładowe wtyczki DSSI
95
65b645a5
PS
96%prep
97%setup -q
a72f4010 98%patch0 -p1
74eb3d40
JK
99%if "%{_lib}" == "lib64"
100%patch1 -p1
101%endif
65b645a5
PS
102
103%build
a72f4010
JK
104%{__libtoolize}
105%{__aclocal}
106%{__autoconf}
107%{__autoheader}
108%{__automake}
109
4f4c1293
JK
110CFLAGS="$CFLAGS -I%{_includedir}/qt"
111CPPFLAGS="$CPPFLAGS -I%{_includedir}/qt"
112export QTDIR=%{_prefix}
65b645a5
PS
113%configure
114%{__make}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119%{__make} install \
120 DESTDIR=$RPM_BUILD_ROOT
121
4f4c1293
JK
122rm -f $RPM_BUILD_ROOT%{_libdir}/dssi/*.la
123
65b645a5
PS
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%files
128%defattr(644,root,root,755)
129%doc ChangeLog README doc/TODO doc/*.txt
4f4c1293
JK
130%attr(755,root,root) %{_bindir}/dssi_osc_send
131%attr(755,root,root) %{_bindir}/dssi_osc_update
132%dir %{_libdir}/dssi
133%{_mandir}/man1/dssi*
134
135%files devel
136%defattr(644,root,root,755)
65b645a5
PS
137%{_includedir}/dssi.h
138%{_pkgconfigdir}/dssi.pc
0ae4bdb5
JB
139
140%files host-jack
141%defattr(644,root,root,755)
142%attr(755,root,root) %{_bindir}/jack-dssi-host
4f4c1293
JK
143%{_mandir}/man1/jack-dssi-host.*
144
145%files examples
146%defattr(644,root,root,755)
147%attr(755,root,root) %{_bindir}/karplong
148%attr(755,root,root) %{_bindir}/less_trivial_synth
149%attr(755,root,root) %{_bindir}/trivial_sampler
150%attr(755,root,root) %{_bindir}/trivial_synth
151%attr(755,root,root) %{_libdir}/dssi/*.so
152%dir %{_libdir}/dssi/less_trivial_synth
153%attr(755,root,root) %{_libdir}/dssi/less_trivial_synth/*_qt
154%dir %{_libdir}/dssi/trivial_sampler
155%attr(755,root,root) %{_libdir}/dssi/trivial_sampler/*_qt
This page took 0.075921 seconds and 4 git commands to generate.