]> git.pld-linux.org Git - packages/dss.git/commitdiff
add gcc43.patch master
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 24 Dec 2013 20:39:45 +0000 (22:39 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Sun, 27 Feb 2022 20:32:29 +0000 (22:32 +0200)
dss.spec
gcc43.patch [new file with mode: 0644]

index 97386f3eb87c7e0eca26c539b6e4dcea54079805..dce6c24bae6fed3e064c1f9a38e3c599377138a8 100644 (file)
--- a/dss.spec
+++ b/dss.spec
@@ -16,6 +16,7 @@ Patch0:               %{name}.patch
 Patch1:                %{name}-x86_64.patch
 Patch2:                optflags.patch
 Patch3:                compile.patch
+Patch4:                gcc43.patch
 URL:           http://dss.macosforge.org/
 BuildRequires: libstdc++-devel
 BuildRequires: rpm-perlprov >= 4.1-13
@@ -35,6 +36,8 @@ Obsoletes:    dstreamserv
 Obsoletes:     dstreamsrv
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+#define                specflags       -Werror -Wno-write-strings
+
 %description
 Darwin Streaming Server lets you stream digital video on the Internet
 using industry-standard Internet protocols RTP and RTSP.
@@ -100,6 +103,7 @@ Przykładowe pliki do Darwin Streaming Servera.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+#%patch4 -p1
 cp -p %{SOURCE3} .
 
 # patch streamingadminserver.pl
@@ -139,6 +143,9 @@ cat > defaultPaths.h << 'EOF'
 #define DEFAULTPATHS_MOVIES_DIR                        "/var/lib/%{name}/movies/"
 EOF
 
+#%undos -f cpp
+#find -name '*.cpp' | xargs sed -i -re 's/char\s*\*\s*(\w+)\s*= "/const char* \1 = "/g'
+
 %build
 export ARCH="%{_target_cpu}"
 export CC="%{__cc}"
diff --git a/gcc43.patch b/gcc43.patch
new file mode 100644 (file)
index 0000000..0beb7f5
--- /dev/null
@@ -0,0 +1,13 @@
+--- DarwinStreamingSrvr6.0.3-Source/CommonUtilitiesLib/StringFormatter.h~      2008-05-06 02:28:59.000000000 +0300
++++ DarwinStreamingSrvr6.0.3-Source/CommonUtilitiesLib/StringFormatter.h       2010-08-09 16:45:23.066298834 +0300
+@@ -71,8 +71,8 @@
+         //Object does no bounds checking on the buffer. That is your responsibility!
+         //Put truncates to the buffer size
+         void        Put(const SInt32 num);
+-        void        Put(char* buffer, UInt32 bufferSize);
+-        void        Put(char* str)      { Put(str, strlen(str)); }
++        void        Put(const char* buffer, UInt32 bufferSize);
++        void        Put(const char* str)      { Put(str, strlen(str)); }
+         void        Put(const StrPtrLen &str) { Put(str.Ptr, str.Len); }
+         void        PutSpace()          { PutChar(' '); }
+         void        PutEOL()            {  Put(sEOL, sEOLLen); }
This page took 0.081001 seconds and 4 git commands to generate.