]> git.pld-linux.org Git - packages/dspam.git/blobdiff - dspam.spec
- disable default mysql when expicite enabled pgsql/sqlite
[packages/dspam.git] / dspam.spec
index e5f9c277f06a84492c2345e4fa4e0c18b116fc19..59cb36e3f27745e185e540f0fe4eb1937fe7cc25 100644 (file)
@@ -1,29 +1,64 @@
+# NOTE about versioning:
+#  Stable Releases: 3.4.x, Development Releases: 3.5.x
+#  All odd-versioned minor releases are considered development
+#  releases, and all even-versioned minor releases are stable releases
+# - from http://www.nuclearelephant.com/projects/dspam/download.shtml
 #
-# Conditional build:
-%bcond_with    mysql   # enable MySQL storage driver (disable db4 driver)
-%bcond_with    pgsql   # enable PostgreSQL storage driver (disable db4 driver)
+# TODO:
+# - everything
+# - oracle driver
+# - missing /etc/dspam.conf for cron:
+#   /etc/cron.daily/dspam:
+#    2430: [6/28/2005 1:2:1] Unable to open file for reading: /etc/dspam.conf: No such file or directory
+#    2430: [6/28/2005 1:2:1] Unable to read dspam.conf
 #
+# Conditional build:
+%bcond_without mysql   # enable MySQL storage driver (disable sqlite/pgsql driver)
+%bcond_with    pgsql   # enable PostgreSQL storage driver (disable sqlite/mysql driver)
+%bcond_with    sqlite  # enable SQLite3 storage driver
+%bcond_with    daemon
+
+%if %{with mysql} && %{with pgsql}
+%undefine with_mysql
+%{warn:disabled mysql as mysql and pgsql aren't supported together (yet)
+}#'vim
+%endif
+
+%if %{with mysql} && %{with sqlite}
+%undefine with_mysql
+%{warn:disabled mysql as mysql and sqlite aren't supported together (yet)
+}#'vim
+%endif
+
+%if %{with pgsql} && %{with sqlite}
+%undefine with_sqlite
+%{warn:disabled sqlite as pgsql and sqlite aren't supported together (yet)
+}#'vim
+%endif
+
+
+%if %{with mysql} || %{with pgsql}
+%define        with_daemon 1
+%endif
+
 Summary:       A library and Mail Delivery Agent for Bayesian spam filtering
 Summary(pl):   Biblioteka i MDA do bayesowskiego filtrowania spamu
 Name:          dspam
-Version:       3.2.5
-Release:       1
+Version:       3.4.9
+Release:       0.2
 License:       GPL
 Group:         Applications/Mail
 Source0:       http://www.nuclearelephant.com/projects/dspam/sources/%{name}-%{version}.tar.gz
-# Source0-md5: c89b246f42b62bf5d1e24d1f57877aed
-Patch0:                %{name}-Makefile.patch
+# Source0-md5: ef7ceba47e63edb02a59be3c36cf0f6f
+Source1:       %{name}.init
 URL:           http://www.nuclearelephant.com/projects/dspam/
-BuildRequires: db-static
-%if %{with mysql}
-BuildRequires: mysql-devel
-%else 
-%if %{with pgsql}
-BuildRequires: postgresql-devel
-%else
-BuildRequires: db-devel
-%endif
-%endif
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libtool
+%{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_pgsql:BuildRequires:   postgresql-devel}
+%{?with_sqlite:BuildRequires:  sqlite3-devel}
+BuildRequires: sed >= 4.0
 Buildroot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -64,6 +99,20 @@ DSPAM dzia
 z ka¿dym innym MTA obs³uguj±cym zewnêtrznego agenta MDA (postfiksem,
 qmailem itd.).
 
+%package client
+Summary:        dspam client
+Summary(pl):    Klient dspam
+Group:          Applications/Mail
+# to get the same dspam.conf when both installed
+Conflicts:     dspam > %{version}-%{release}
+Conflicts:     dspam < %{version}-%{release}
+
+%description client
+dspam client.
+
+%description -l pl client
+Klient dspam.
+
 %package libs
 Summary:       A library for Bayesian spam filtering
 Summary(pl):   Biblioteka do bayesowskiego filtrowania spamu
@@ -120,18 +169,19 @@ Statyczna biblioteka DSPAM.
 
 %prep
 %setup -q
-%patch0 -p1
+sed -i -e 's#\-static##g' src/Makefile* src/*/Makefile*
 
 %build
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__automake}
 %configure \
+       %{?debug: --enable-debug --enable-bnr-debug --enable-verbose-debug} \
        --enable-trusted-user-security \
-       --enable-bayesian-dobly \
-       --enable-chained-tokens \
-       --enable-experimental \
+       --enable-chi-square \
        --enable-bias \
        --enable-large-scale \
-       --enable-delivery-to-stdout \
-       --enable-virtual-users \
        --with-userdir=/var/lib/%{name} \
        --with-dspam-home=/var/lib/%{name} \
        --with-userdir-owner=none \
@@ -142,43 +192,45 @@ Statyczna biblioteka DSPAM.
        --disable-dependency-tracking \
 %if %{with mysql}
        --enable-neural-networking \
+       --enable-daemon \
        --enable-virtual-users \
        --with-storage-driver=mysql_drv \
        --with-mysql-includes=%{_includedir}/mysql \
        --with-mysql-libraries=%{_libdir}
-%else
+%endif
 %if %{with pgsql}
        --enable-neural-networking \
+       --enable-daemon \
        --enable-virtual-users \
        --with-storage-driver=pgsql_drv \
        --with-pgsql-includes=%{_includedir}/postgresql \
        --with-pgsql-libraries=%{_libdir}
-%else
-       --with-storage-driver=libdb4_drv \
-       --with-db4-includes=%{_includedir} \
-       --with-db4-libraries=%{_libdir}
 %endif
+%if %{with sqlite}
+       --with-storage-driver=sqlite3_drv \
+       --with-sqlite3-includes=%{_includedir} \
+       --with-sqlite3-libraries=%{_libdir}
 %endif
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-#%makeinstall_std
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dspam
 
 # install devel files
 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name},/var/lib/%{name}}
-install -m0644 libdspam.h $RPM_BUILD_ROOT%{_includedir}/%{name}
-install -m0644 libdspam_objects.h $RPM_BUILD_ROOT%{_includedir}/%{name}
-install -m0644 lht.h $RPM_BUILD_ROOT%{_includedir}/%{name}
-install -m0644 nodetree.h $RPM_BUILD_ROOT%{_includedir}/%{name}
+install src/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
 
 # provide maintenance scripts
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.weekly
+install -d $RPM_BUILD_ROOT/etc/cron.daily
+install -d $RPM_BUILD_ROOT/etc/cron.weekly
 
-cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/%{name} <<EOF
+cat > $RPM_BUILD_ROOT/etc/cron.daily/%{name} <<EOF
 #!/bin/sh
 exec %{_bindir}/%{name}_clean -s -p
 EOF
@@ -186,15 +238,13 @@ EOF
 chmod 755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/%{name}
 
 # fix prefix
-perl -pi -e "s|%{_prefix}/local|%{_prefix}|g" $RPM_BUILD_ROOT%{_bindir}/%{name}_corpus
-perl -pi -e "s|%{_prefix}/local|%{_prefix}|g" cgi/dspam.cgi
+sed -i -e "s|%{_prefix}/local|%{_prefix}|g" $RPM_BUILD_ROOT%{_bindir}/%{name}_corpus
+sed -i -e "s|%{_prefix}/local|%{_prefix}|g" cgi/dspam.cgi
 
 # fix purge stuff
-#install -m0755 dspam-cron.weekly $RPM_BUILD_ROOT%{_sysconfdir}/cron.weekly/%{name}
+#install dspam-cron.weekly $RPM_BUILD_ROOT%{_sysconfdir}/cron.weekly/%{name}
 
 %if %{with mysql}
-cp tools.mysql_drv/README README.mysql
-
 # fix missing file
 install -d $RPM_BUILD_ROOT/var/lib/%{name}
 cat > $RPM_BUILD_ROOT/var/lib/%{name}/mysql.data <<EOF
@@ -213,8 +263,6 @@ EOF
 %endif
 
 %if %{with pgsql}
-cp tools.pgsql_drv/README README.pgsql
-
 # fix missing file
 install -d $RPM_BUILD_ROOT/var/lib/%{name}
 cat > $RPM_BUILD_ROOT/var/lib/%{name}/pgsql.data <<EOF
@@ -232,6 +280,22 @@ DATABASE
 EOF
 %endif
 
+%post
+/sbin/chkconfig --add dspam
+if [ -f /var/lock/subsys/dspam ]; then
+       /etc/rc.d/init.d/dspam restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/dspam start\" to start dspam daemon."
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/dspam ]; then
+               /etc/rc.d/init.d/dspam stop 1>&2
+       fi
+       /sbin/chkconfig --del dspam
+fi
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -240,27 +304,26 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README CHANGELOG RELEASE.NOTES
+%doc README CHANGELOG RELEASE.NOTES UPGRADING
 %doc cgi/base.css cgi/dspam.cgi
 %if %{with mysql}
-%doc README.mysql
-%doc tools.mysql_drv/mysql_objects.sql.space.optimized
-%doc tools.mysql_drv/mysql_objects.sql.speed.optimized
-%doc tools.mysql_drv/purge.sql
-%doc tools.mysql_drv/virtual_users.sql
+%doc doc/mysql_drv.txt
+%doc src/tools.mysql_drv/*.sql
 %endif
 %if %{with pgsql}
-%doc README.pgsql
-%doc tools.pgsql_drv/virtual_users.sql
-%doc tools.pgsql_drv/pgsql_objects.sql
-%doc tools.pgsql_drv/purge.sql
+%doc doc/pgsql_drv.txt
+%doc src/tools.pgsql_drv/*.sql
 %endif
-%dir %attr(0750,root,mail) /var/lib/%{name}
+%if %{without mysql} && %{without pgsql}
+%doc doc/sqlite_drv.txt
+%endif
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dspam.conf
+%dir %attr(750,root,mail) /var/lib/%{name}
 %{?with_mysql:%attr(640,root,mail) %config(noreplace) /var/lib/%{name}/mysql.data}
 %{?with_pgsql:%attr(640,root,mail) %config(noreplace) /var/lib/%{name}/pgsql.data}
-%attr(755,root,root) %config(noreplace) %{_sysconfdir}/cron.daily/%{name}
-#%attr(755,root,root) %config(noreplace) %{_sysconfdir}/cron.weekly/%{name}
+%attr(755,root,root) %config(noreplace) /etc/cron.daily/%{name}
 %attr(755,root,mail) %{_bindir}/%{name}
+%attr(755,root,mail) %{_bindir}/%{name}_logrotate
 %attr(755,root,root) %{_bindir}/%{name}_clean
 %attr(755,root,root) %{_bindir}/%{name}_corpus
 %attr(755,root,root) %{_bindir}/%{name}_crc
@@ -269,9 +332,17 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/%{name}_stats
 %attr(755,root,root) %{_bindir}/%{name}_merge
 %attr(755,root,root) %{_bindir}/%{name}_2sql
-%attr(755,root,root) %{_bindir}/%{name}_stats
-#%attr(755,root,root) %{_bindir}/libdb4_purge
-%{_mandir}/man?/*
+%attr(755,root,root) %{_bindir}/%{name}_admin
+%{?with_pgsql:%attr(755,root,root) %{_bindir}/%{name}_pg2int8}
+%{_mandir}/man?/%{name}*
+
+%if %{with daemon}
+%attr(754,root,root) /etc/rc.d/init.d/dspam
+%files client
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dspam.conf
+%endif
+%attr(755,root,mail) %{_bindir}/%{name}c
 
 %files libs
 %defattr(644,root,root,755)
@@ -283,6 +354,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
 %{_includedir}/%{name}
+%{_mandir}/man3/libdspam*
+%{_pkgconfigdir}/*.pc
 
 %files static
 %defattr(644,root,root,755)
This page took 0.072719 seconds and 4 git commands to generate.