]> git.pld-linux.org Git - packages/dspam.git/blobdiff - dspam.spec
- bcond works (mysql40)
[packages/dspam.git] / dspam.spec
index 14f0942f206cca864530cfe30e355c46fe2f1f92..13b7b59846209b28303dac9415a0622ce18a7eac 100644 (file)
@@ -1,42 +1,40 @@
-# TODO: everything
+#
+# TODO:
+# - support for libdclassify
+# - oracle driver
+# - messages from default install of cron with mysql driver
+# Memory fault
 #
 # Conditional build:
-%bcond_without mysql   # enable MySQL storage driver (disable sqlite driver)
-%bcond_with    pgsql   # enable PostgreSQL storage driver (disable sqlite driver)
-%bcond_with    sqlite  # enable SQLite3 storage driver
-%bcond_with    daemon  
+%bcond_without mysql   # disable MySQL storage driver
+%bcond_without pgsql   # disable PostgreSQL storage driver
+%bcond_without sqlite  # disable SQLite3 storage driver
+%bcond_without db      # disable BerkeleyDB storage driver
+%bcond_without daemon  # disable daemon mode
+%bcond_with    mysql40 # use with mysql 4.0
 #
-
-%if %{with mysql} || %{with pgsql}
-%define        with_daemon 1
-%endif
-
 Summary:       A library and Mail Delivery Agent for Bayesian spam filtering
 Summary(pl):   Biblioteka i MDA do bayesowskiego filtrowania spamu
 Name:          dspam
-Version:       3.4.8
-Release:       0.1
+Version:       3.6.3
+Release:       0.4
 License:       GPL
 Group:         Applications/Mail
 Source0:       http://www.nuclearelephant.com/projects/dspam/sources/%{name}-%{version}.tar.gz
-# Source0-md5: b6930c31fe0940b8ad6d27324f8bab3e
+# Source0-md5: db1aedb9677e6bf5c7a47a72d4f130e5
 Source1:       %{name}.init
 URL:           http://www.nuclearelephant.com/projects/dspam/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libtool
-%if %{with mysql}
-BuildRequires: mysql-devel
-%else
-%if %{with pgsql}
-BuildRequires: postgresql-devel
-%else
-%if %{with sqlite}
-BuildRequires: sqlite3-devel
-%endif
-%endif
-%endif
+BuildRequires: clamav-devel
+%{?with_db:BuildRequires:      db-devel}
+%{?with_mysql:BuildRequires:   mysql-devel}
+BuildRequires: openldap-devel
+%{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: sed >= 4.0
+%{?with_sqlite:BuildRequires:  sqlite3-devel}
+BuildRequires: zlib-devel
 Buildroot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -78,9 +76,9 @@ z ka
 qmailem itd.).
 
 %package client
-Summary:        dspam client
-Summary(pl):    Klient dspam
-Group:          Applications/Mail
+Summary:       dspam client
+Summary(pl):   Klient dspam
+Group:         Applications/Mail
 # to get the same dspam.conf when both installed
 Conflicts:     dspam > %{version}-%{release}
 Conflicts:     dspam < %{version}-%{release}
@@ -88,13 +86,14 @@ Conflicts:  dspam < %{version}-%{release}
 %description client
 dspam client.
 
-%description -l pl client
+%description client -l pl
 Klient dspam.
 
 %package libs
 Summary:       A library for Bayesian spam filtering
 Summary(pl):   Biblioteka do bayesowskiego filtrowania spamu
 Group:         Libraries
+Requires:      %{name}-driver = %{version}-%{release}
 
 %description libs
 DSPAM (as in De-Spam) is an open-source project to create a new kind
@@ -145,52 +144,132 @@ Static DSPAM library.
 %description static -l pl
 Statyczna biblioteka DSPAM.
 
+%package driver-hash
+Summary:       HASH driver for DSPAM
+Summary(pl):   Sterownik HASH dla DSPAM-a
+Group:         Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+Requires(post):        sed >= 4.0
+Provides:      %{name}-driver = %{version}-%{release}
+
+%description driver-hash
+HASH driver for DSPAM.
+
+%description driver-hash -l pl
+Sterownik HASH dla DSPAM-a.
+
+%package driver-db
+Summary:       DB driver for DSPAM
+Summary(pl):   Sterownik DB dla DSPAM-a
+Group:         Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+Requires(post):        sed >= 4.0
+Provides:      %{name}-driver = %{version}-%{release}
+
+%description driver-db
+DB driver for DSPAM.
+
+%description driver-db -l pl
+Sterownik DB dla DSPAM-a.
+
+%package driver-mysql
+Summary:       MySQL driver for DSPAM
+Summary(pl):   Sterownik MySQL dla DSPAM-a
+Group:         Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+Requires(post):        sed >= 4.0
+Provides:      %{name}-driver = %{version}-%{release}
+
+%description driver-mysql
+MySQL driver for DSPAM.
+
+%description driver-mysql -l pl
+Sterownik MySQL dla DSPAM-a.
+
+%package driver-pgsql
+Summary:       PostgreSQL driver for DSPAM
+Summary(pl):   Sterownik PostgreSQL dla DSPAM-a
+Group:         Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+Requires(post):        sed >= 4.0
+Provides:      %{name}-driver = %{version}-%{release}
+
+%description driver-pgsql
+PostgreSQL driver for DSPAM.
+
+%description driver-pgsql -l pl
+Sterownik PostgreSQL dla DSPAM-a.
+
+%package driver-sqlite
+Summary:       SQLite driver for DSPAM
+Summary(pl):   Sterownik SQLite dla DSPAM-a
+Group:         Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+Requires(post):        sed >= 4.0
+Provides:      %{name}-driver = %{version}-%{release}
+
+%description driver-sqlite
+SQLite driver for DSPAM.
+
+%description driver-sqlite -l pl
+Sterownik SQLite dla DSPAM-a.
+
 %prep
 %setup -q
 sed -i -e 's#\-static##g' src/Makefile* src/*/Makefile*
+%{?with_mysql40:sed -i -e 's#40100#99999#g' src/mysql_drv.c}
 
 %build
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
 %{__automake}
+
+DRIVERS="
+hash_drv
+%{?with_db:libdb4_drv}
+%{?with_mysql:mysql_drv}
+%{?with_pgsql:pgsql_drv}
+%{?with_sqlite:sqlite_drv}
+"
 %configure \
+       %{?debug: --enable-debug --enable-bnr-debug --enable-verbose-debug} \
        --enable-trusted-user-security \
-       --enable-bayesian-dobly \
-       --enable-chained-tokens \
-       --enable-experimental \
        --enable-bias \
        --enable-large-scale \
-       --enable-delivery-to-stdout \
        --with-userdir=/var/lib/%{name} \
-       --with-dspam-home=/var/lib/%{name} \
        --with-userdir-owner=none \
        --with-userdir-group=none \
+       --with-dspam-home=/var/lib/%{name} \
+       --with-dspam-home-owner=none \
+       --with-dspam-home-group=none \
        --with-dspam-owner=none \
        --with-dspam-group=none \
        --with-signature-life=14 \
        --disable-dependency-tracking \
-%if %{with mysql}
-       --enable-daemon \
+       --enable-ldap \
+       --enable-clamav \
+       --enable-preferences-extension \
+       --enable-long-usernames \
+       --enable-neural-networking \
        --enable-virtual-users \
-       --with-storage-driver=mysql_drv \
+       --with-storage-driver=$(echo $DRIVERS | tr ' ' ',') \
+%if %{with mysql}
        --with-mysql-includes=%{_includedir}/mysql \
-       --with-mysql-libraries=%{_libdir}
-%else
+       --with-mysql-libraries=%{_libdir} \
+%endif
 %if %{with pgsql}
-       --enable-daemon \
-       --enable-virtual-users \
-       --with-storage-driver=pgsql_drv \
        --with-pgsql-includes=%{_includedir}/postgresql \
-       --with-pgsql-libraries=%{_libdir}
-%else
+       --with-pgsql-libraries=%{_libdir} \
+%endif
 %if %{with sqlite}
-       --with-storage-driver=sqlite3_drv \
        --with-sqlite3-includes=%{_includedir} \
-       --with-sqlite3-libraries=%{_libdir}
-%endif
-%endif
+       --with-sqlite3-libraries=%{_libdir} \
 %endif
+       --enable-daemon
+
+# --enable-dclassify-extension needs libdclassify
+
 %{__make}
 
 %install
@@ -199,7 +278,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-#
 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dspam
 
@@ -220,7 +298,7 @@ chmod 755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/%{name}
 
 # fix prefix
 sed -i -e "s|%{_prefix}/local|%{_prefix}|g" $RPM_BUILD_ROOT%{_bindir}/%{name}_corpus
-sed -i -e "s|%{_prefix}/local|%{_prefix}|g" cgi/dspam.cgi
+sed -i -e "s|%{_prefix}/local|%{_prefix}|g" webui/cgi-bin/dspam.cgi
 
 # fix purge stuff
 #install dspam-cron.weekly $RPM_BUILD_ROOT%{_sysconfdir}/cron.weekly/%{name}
@@ -264,45 +342,57 @@ EOF
 %post
 /sbin/chkconfig --add dspam
 if [ -f /var/lock/subsys/dspam ]; then
-        /etc/rc.d/init.d/dspam restart 1>&2
+       /etc/rc.d/init.d/dspam restart 1>&2
 else
-        echo "Run \"/etc/rc.d/init.d/dspam start\" to start dspam daemon."
+       echo "Run \"/etc/rc.d/init.d/dspam start\" to start dspam daemon."
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-        if [ -f /var/lock/subsys/dspam ]; then
-                /etc/rc.d/init.d/dspam stop 1>&2
-        fi
-        /sbin/chkconfig --del dspam
+       if [ -f /var/lock/subsys/dspam ]; then
+               /etc/rc.d/init.d/dspam stop 1>&2
+       fi
+       /sbin/chkconfig --del dspam
 fi
 
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
+%post driver-db
+if [ "$1" = "1" ]; then
+       sed -i -e '/^StorageDriver/s,/.*.so,%{_libdir}/libdb4_drv.so,' /etc/dspam.conf
+fi
+
+%post driver-hash
+if [ "$1" = "1" ]; then
+       sed -i -e '/^StorageDriver/s,/.*\.so,%{_libdir}/libhash_drv.so,' /etc/dspam.conf
+fi
+
+%post driver-mysql
+if [ "$1" = "1" ]; then
+       sed -i -e '/^StorageDriver/s,/.*\.so,%{_libdir}/libmysql_drv.so,' /etc/dspam.conf
+fi
+
+%post driver-pgsql
+if [ "$1" = "1" ]; then
+       sed -i -e '/^StorageDriver/s,/.*\.so,%{_libdir}/libpgsql_drv.so,' /etc/dspam.conf
+fi
+
+%post driver-sqlite
+if [ "$1" = "1" ]; then
+       sed -i -e '/^StorageDriver/s,/.*\.so,%{_libdir}/libsqlite_drv.so,' /etc/dspam.conf
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc README CHANGELOG RELEASE.NOTES UPGRADING
-%doc cgi/base.css cgi/dspam.cgi
-%if %{with mysql}
-%doc doc/mysql_drv.txt
-%doc src/tools.mysql_drv/*.sql
-%endif
-%if %{with pgsql}
-%doc doc/pgsql_drv.txt
-%doc src/tools.pgsql_drv/*.sql
-%endif
-%if %{!with mysql} && %{!with pgsql}
-%doc doc/sqlite_drv.txt
-%endif
+%doc webui/*/*.{cgi,prefs,txt} webui/*/*.txt webui/*/templates/*.html
+%doc doc/{courier,exim,markov,pop3filter,postfix,qmail,relay,sendmail}.txt
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dspam.conf
 %dir %attr(750,root,mail) /var/lib/%{name}
-%{?with_mysql:%attr(640,root,mail) %config(noreplace) /var/lib/%{name}/mysql.data}
-%{?with_pgsql:%attr(640,root,mail) %config(noreplace) /var/lib/%{name}/pgsql.data}
 %attr(755,root,root) %config(noreplace) /etc/cron.daily/%{name}
 %attr(755,root,mail) %{_bindir}/%{name}
 %attr(755,root,mail) %{_bindir}/%{name}_logrotate
@@ -315,13 +405,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/%{name}_merge
 %attr(755,root,root) %{_bindir}/%{name}_2sql
 %attr(755,root,root) %{_bindir}/%{name}_admin
-%{?with_pgsql:%attr(755,root,root) %{_bindir}/%{name}_pg2int8}
 %{_mandir}/man?/%{name}*
 
 %if %{with daemon}
+%attr(754,root,root) /etc/rc.d/init.d/dspam
 %files client
 %defattr(644,root,root,755)
-%attr(754,root,root) /etc/rc.d/init.d/dspam
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dspam.conf
 %endif
 %attr(755,root,mail) %{_bindir}/%{name}c
@@ -330,10 +419,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README CHANGELOG
 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%attr(755,root,root) %exclude %{_libdir}/lib*_drv*.so*
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/lib*.so
+%attr(755,root,root) %exclude %{_libdir}/lib*_drv*.so*
 %{_libdir}/lib*.la
 %{_includedir}/%{name}
 %{_mandir}/man3/libdspam*
@@ -342,3 +433,38 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
+
+%files driver-hash
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/css*
+%attr(755,root,root) %{_libdir}/libhash_drv*.so*
+
+%if %{with db}
+%files driver-db
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libdb4_drv*.so*
+%endif
+
+%if %{with mysql}
+%files driver-mysql
+%defattr(644,root,root,755)
+%doc doc/mysql_drv.txt src/tools.mysql_drv/*.sql
+%attr(640,root,mail) %config(noreplace) /var/lib/%{name}/mysql.data
+%attr(755,root,root) %{_libdir}/libmysql_drv*.so*
+%endif
+
+%if %{with pgsql}
+%files driver-pgsql
+%defattr(644,root,root,755)
+%doc doc/pgsql_drv.txt src/tools.pgsql_drv/*.sql
+%attr(640,root,mail) %config(noreplace) /var/lib/%{name}/pgsql.data
+%attr(755,root,root) %{_bindir}/%{name}_pg2int8
+%attr(755,root,root) %{_libdir}/libpgsql_drv*.so*
+%endif
+
+%if %{with sqlite}
+%files driver-sqlite
+%defattr(644,root,root,755)
+%doc doc/sqlite_drv.txt
+%attr(755,root,root) %{_libdir}/libsqlite_drv*.so*
+%endif
This page took 0.108501 seconds and 4 git commands to generate.