]> git.pld-linux.org Git - packages/dshowserver.git/commitdiff
- build 32bit binary in x8664 (using multilib)
authorsparky <sparky@pld-linux.org>
Mon, 3 Nov 2008 12:20:07 +0000 (12:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- forcing static on x8664 is pointless
- use config.mak file instead of command line

Changed files:
    dshowserver.spec -> 1.7

dshowserver.spec

index 8096c64a16734cf12122d0b31d9aa8a4048b63ec..1dd3d0e3ece039266db663944e0eedc9b41e3069 100644 (file)
@@ -2,10 +2,6 @@
 %bcond_with    static  # static package for use with x86_64 systems
 #
 
-%ifarch %{x8664}
-%define                with_static     1
-%endif
-
 %define                svn                     82
 %define                rel                     0.1
 Summary:       Win32 CoreAVC H.264 codec helper
@@ -20,11 +16,22 @@ Source0:    %{name}-0.svn%{svn}.tar.bz2
 Patch0:                %{name}-codecspath.patch
 Patch1:                %{name}-optflags.patch
 URL:           http://code.google.com/p/coreavc-for-linux/
+%ifarch %{x8664}
+BuildRequires: gcc-multilib
+%{?with_static:BuildRequires:     glibc-static(i686)}
+%else
 %{?with_static:BuildRequires:     glibc-static}
+%endif
 BuildRequires: rpmbuild(macros) >= 1.453
 BuildRequires: sed >= 4.0
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                x8664_flags     -m32
+%define                specflags_x86_64 %{x8664_flags}
+%define                specflags_amd64 %{x8664_flags}
+%define                specflags_ia32e %{x8664_flags}
+
 %description
 CoreAVC is a proprietary Windows codec for H.264 video decoding. It is
 much faster than any currently available open-source codecs. Being
@@ -69,10 +76,19 @@ H.264.
 %endif
 
 %build
-%{__make} -C dshowserver \
-       CC="%{__cc}" \
-       OPTFLAGS="%{rpmcflags}" \
-       %{?with_static:STATIC=1}
+cat << 'EOF' > config.mak
+override CC = %{__cc}
+override OPTFLAGS = %{rpmcflags}
+override LDFLAGS = %{rpmldflags}
+
+%{?with_static:STATIC = 1}
+
+AR = ar
+RANLIB = ranlib
+OBJDIR = ../objs
+EOF
+
+%{__make} -C dshowserver
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.080065 seconds and 4 git commands to generate.