]> git.pld-linux.org Git - packages/dshowserver.git/blame_incremental - dshowserver.spec
- alpha and numeric comparision is inconsistent with different rpm versions
[packages/dshowserver.git] / dshowserver.spec
... / ...
CommitLineData
1# TODO
2# - err, get rid of name mungling and create real -static package or some other subpackages
3# - static bcond and BR mismatches
4# - missing source0 (due lack of md5)
5
6# Conditional build:
7%bcond_with static # static package for use with x86_64 systems
8
9%define snap svn
10%define extraver 82
11%define pname dshowserver
12Summary: Win32 CoreAVC H.264 codec helper
13Summary(pl.UTF-8): Serwer windowsowego kodeka CoreAVC H.264.
14Name: %{pname}%{?with_static:-static}
15Version: 0.%{snap}%{extraver}
16Release: 0.1
17License: GPL
18Group: X11/Applications/Multimedia
19Source0: %{pname}-%{version}.tar.bz2
20# Source0-md5:
21Patch0: %{pname}-codecspath.patch
22URL: http://code.google.com/
23# XXX actual without static bcond too??
24BuildRequires: glibc-static
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28CoreAVC is a proprietary Windows codec for H.264 video decoding. It is
29much faster than any currently available open-source codecs. Being
30multi-threaded, and able to play PAFF streams, it can handle HD
31H.264/AVC streams that no freely available codecs can. CoreAVC is
32reasonably priced, but it is Windows only. Dshowserver serves CoreAVC
33for mythtv, mplayer and xine. Dshowserver can work under 32 or 64 bits
34linux system. For 64 bits use static binary compiled in 32 bits
35environement.
36
37%description -l pl.UTF-8
38CoreAVC to komercyjny kodek H.264 dla systemu Windows. Jest znacznie
39szybszy od dowolnego wolnego kodeka. Obsługujac wielowatkowosc moze
40odtwarzac strumienie zakodowane z uzyciem interlacingu PAFF. Odtwarza
41strumienie HD H.264/AVC. Kosztuje rozsadnie, ale dostepny jest tylko
42dla Windows. Dhowserevr implementuje obsluge tego kodeka przez mythtv,
43mplayer i xine. Dshowserver moze byc uzyty w architekturach x86 i
44x86_64. Jezeli twoj system jest 64 bitowy. Uzyj statycznych binariow
45zbudowanych w 32 bitowym srodowisku.
46
47
48%package -n registercodec%{?with_static:-static}
49Summary: Utility to register win32 CoreAVC H.264 codec
50Summary(pl.UTF-8): Narzedzie do rejestracji windowsowego kodeka CoreAVC H.264.
51Group: X11/Applications/Multimedia
52
53%description -n registercodec%{?with_static:-static}
54Utility to register win32 CoreAVC H.264 codec for usage with
55mythtv/mplayer/xine.
56
57%description -n registercodec%{?with_static:-static} -l pl.UTF-8
58Narzedzie do przeprowadzenia rejestracji komercyjnego kodeka CoreAVC
59H.264.
60
61%prep
62%setup -q -n %{pname}-%{version}
63%patch0 -p1
64
65%build
66%{__make} -C dshowserver %{?with_static:STATIC=1}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70install -d $RPM_BUILD_ROOT%{_bindir}
71install -d $RPM_BUILD_ROOT%{_mandir}/man1
72install dshowserver/dshowserver $RPM_BUILD_ROOT%{_bindir}/dshowserver
73install dshowserver/registercodec $RPM_BUILD_ROOT%{_bindir}/registercodec
74
75cp -a man/* $RPM_BUILD_ROOT%{_mandir}/man1
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%files
81%defattr(644,root,root,755)
82%attr(755,root,video) %{_bindir}/dshowserver
83%{_mandir}/man1/ds*
84
85%files -n registercodec%{?with_static:-static}
86%defattr(644,root,root,755)
87%attr(755,root,video) %{_bindir}/registercodec
88%{_mandir}/man1/re*
This page took 0.043742 seconds and 4 git commands to generate.