]> git.pld-linux.org Git - packages/drpython.git/blob - drpython.spec
- updated to 3.5.3
[packages/drpython.git] / drpython.spec
1 Summary:        DrPython - cross-platform IDE to aid programming in Python
2 Summary(pl):    DrPython - wieloplatformowe IDE pomagaj±ce w programowaniu w Pythonie
3 Name:           drpython
4 Version:        3.5.3
5 Release:        0.1
6 License:        GPL
7 Group:          Libraries/Python
8 Source0:        http://dl.sourceforge.net/drpython/%{name}-%{version}.zip
9 # Source0-md5:  709539784b044976c7f0b6adcf33e12b
10 URL:            http://drpython.sourceforge.net/
11 BuildRequires:  python-modules >= 2.3
12 %pyrequires_eq  python-modules
13 Requires:       python-wxPython >= 2.5.1.5
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 DrPython is a clean and simple yet powerful and highly customizable
19 editor/environment for developing programs written in the Python
20 programming Language. It is written in Python, and uses the wxWidgets
21 GUI Library through the use of wxPython.
22
23 %description -l pl
24 DrPython to przejrzysty i prosty, ale potê¿ny i wysoko konfigurowalny
25 edytor/¶rodowisko do tworzenia programów napisanych w jêzyku Python.
26 Jest napisany w Pythonie i u¿ywa biblioteki graficznej wxWidgets
27 poprzez interfejs wxPython.
28
29 %prep
30 %setup -q 
31
32 %build
33 chmod 0644 *.py
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/drpython}
38
39 install *.py $RPM_BUILD_ROOT%{_datadir}/drpython
40 cp -a examples bitmaps $RPM_BUILD_ROOT%{_datadir}/drpython
41
42 echo '#!/bin/sh' > $RPM_BUILD_ROOT%{_bindir}/drpython
43 echo 'cd %{_datadir}/drpython' >> $RPM_BUILD_ROOT%{_bindir}/drpython
44 echo 'exec python drpython.pyo' >> $RPM_BUILD_ROOT%{_bindir}/drpython
45 chmod 0755 $RPM_BUILD_ROOT%{_bindir}/drpython
46
47 %py_comp $RPM_BUILD_ROOT%{_datadir}/drpython
48 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/drpython
49
50 find $RPM_BUILD_ROOT%{_datadir} -name \*.py | xargs rm -f
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc ChangeLog.txt documentation/*
58 %attr(755,root,root) %{_bindir}/drpython
59 %{_datadir}/drpython
This page took 0.04567 seconds and 4 git commands to generate.