]> git.pld-linux.org Git - packages/drpython.git/blob - drpython.spec
- release 1 for rebuild with python 2.4
[packages/drpython.git] / drpython.spec
1 Summary:        DrPython - cross-platform IDE to aid programming in Python
2 Summary(pl):    DrPython - wieloplatformowe IDE wspomagaj±ce programowanie w Pythonie
3 Name:           drpython
4 Version:        3.7.9
5 Release:        1
6 License:        GPL
7 Group:          Libraries/Python
8 Source0:        http://heanet.dl.sourceforge.net/drpython/%{name}-%{version}.zip
9 # Source0-md5:  fc0dc7298195bf37e9294520ac053cb9
10 URL:            http://drpython.sourceforge.net/
11 BuildRequires:  python-modules >= 1:2.3
12 BuildRequires:  unzip
13 %pyrequires_eq  python-modules
14 Requires:       python-wxPython >= 2.5.1.5
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 DrPython is a clean and simple yet powerful and highly customizable
20 editor/environment for developing programs written in the Python
21 programming Language. It is written in Python, and uses the wxWidgets
22 GUI Library through the use of wxPython.
23
24 %description -l pl
25 DrPython to przejrzysty i prosty, ale potê¿ny i wysoko konfigurowalny
26 edytor/¶rodowisko do tworzenia programów napisanych w jêzyku Python.
27 Jest napisany w Pythonie i u¿ywa biblioteki graficznej wxWidgets
28 poprzez interfejs wxPython.
29
30 %prep
31 %setup -q 
32
33 %build
34 chmod 644 *.py
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/drpython}
39
40 install *.py $RPM_BUILD_ROOT%{_datadir}/drpython
41 cp -a examples bitmaps $RPM_BUILD_ROOT%{_datadir}/drpython
42
43 echo '#!/bin/sh' > $RPM_BUILD_ROOT%{_bindir}/drpython
44 echo 'cd %{_datadir}/drpython' >> $RPM_BUILD_ROOT%{_bindir}/drpython
45 echo 'exec python drpython.pyo' >> $RPM_BUILD_ROOT%{_bindir}/drpython
46 chmod 755 $RPM_BUILD_ROOT%{_bindir}/drpython
47
48 %py_comp $RPM_BUILD_ROOT%{_datadir}/drpython
49 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/drpython
50
51 find $RPM_BUILD_ROOT%{_datadir} -name \*.py | xargs rm -f
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc ChangeLog.txt documentation/*
59 %attr(755,root,root) %{_bindir}/drpython
60 %{_datadir}/drpython
This page took 0.053013 seconds and 3 git commands to generate.