]> git.pld-linux.org Git - packages/drpython.git/blob - drpython.spec
- updated to 3.6.9
[packages/drpython.git] / drpython.spec
1 Summary:        DrPython - cross-platform IDE to aid programming in Python
2 Summary(pl):    DrPython - wieloplatformowe IDE wspomagaj±ce programowanie w Pythonie
3 Name:           drpython
4 Version:        3.6.9
5 Release:        0.1
6 License:        GPL
7 Group:          Libraries/Python
8 Source0:        http://dl.sourceforge.net/drpython/%{name}-%{version}.zip
9 # Source0-md5:  7843bc060ad9d2d952b30a45f2574a3b
10 # Source0-size: 468343
11 URL:            http://drpython.sourceforge.net/
12 BuildRequires:  python-modules >= 2.3
13 BuildRequires:  unzip
14 %pyrequires_eq  python-modules
15 Requires:       python-wxPython >= 2.5.1.5
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 DrPython is a clean and simple yet powerful and highly customizable
21 editor/environment for developing programs written in the Python
22 programming Language. It is written in Python, and uses the wxWidgets
23 GUI Library through the use of wxPython.
24
25 %description -l pl
26 DrPython to przejrzysty i prosty, ale potê¿ny i wysoko konfigurowalny
27 edytor/¶rodowisko do tworzenia programów napisanych w jêzyku Python.
28 Jest napisany w Pythonie i u¿ywa biblioteki graficznej wxWidgets
29 poprzez interfejs wxPython.
30
31 %prep
32 %setup -q 
33
34 %build
35 chmod 0644 *.py
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/drpython}
40
41 install *.py $RPM_BUILD_ROOT%{_datadir}/drpython
42 cp -a examples bitmaps $RPM_BUILD_ROOT%{_datadir}/drpython
43
44 echo '#!/bin/sh' > $RPM_BUILD_ROOT%{_bindir}/drpython
45 echo 'cd %{_datadir}/drpython' >> $RPM_BUILD_ROOT%{_bindir}/drpython
46 echo 'exec python drpython.pyo' >> $RPM_BUILD_ROOT%{_bindir}/drpython
47 chmod 0755 $RPM_BUILD_ROOT%{_bindir}/drpython
48
49 %py_comp $RPM_BUILD_ROOT%{_datadir}/drpython
50 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/drpython
51
52 find $RPM_BUILD_ROOT%{_datadir} -name \*.py | xargs rm -f
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc ChangeLog.txt documentation/*
60 %attr(755,root,root) %{_bindir}/drpython
61 %{_datadir}/drpython
This page took 0.045254 seconds and 3 git commands to generate.