]> git.pld-linux.org Git - packages/dropbox.git/blob - dropbox.spec
de239f3595496a09f6be612af6ca3ae17bb03dd1
[packages/dropbox.git] / dropbox.spec
1 # TODO
2 # - avoid dropboxd relaunching itself with newer version if there's update available (disable auto updating):
3 #   glen     25034 19.9  1.5 1496132 81256 pts/46  Sl+  11:02   1:02 /home/glen/.dropbox-dist/dropbox /newerversion
4 # NOTES:
5 # - Upstream Dropbox Support (https://www.dropbox.com/ticket)
6 # - Release Notes (check new versions here): https://www.dropbox.com/release_notes
7 # - Download instructions (click the download link to find current version):
8 #   http://www.dropbox.com/downloading?os=lnx
9 #   http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
10 Summary:        Sync and backup files between computers
11 Name:           dropbox
12 Version:        2.6.33
13 Release:        1
14 License:        Proprietary
15 Group:          Daemons
16 Source0:        http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
17 # NoSource0-md5:        4155a85791150a40f97cff68ca2e0668
18 NoSource:       0
19 Source1:        http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
20 # NoSource1-md5:        72e52d33ab69f15be40247dd42c33d92
21 NoSource:       1
22 URL:            http://www.dropbox.com/
23 BuildRequires:  rpmbuild(macros) >= 1.566
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  tar >= 1:1.15.1
26 BuildRequires:  zip
27 Conflicts:      nautilus-dropbox < 0.6.3-2
28 ExclusiveArch:  %{ix86} %{x8664}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # generate no Provides from private modules
32 %define         _noautoprovfiles        %{_libdir}/%{name}
33
34 # provided by package itself, but autodeps disabled
35 %define         _noautoreq              libwx_.*.so librsync.so.1 libffi.so.6
36
37 # a zip and executable at the same time
38 %define         _noautostrip    .*/library.zip\\|.*/dropbox
39
40 # debuginfo wouldn't be useful
41 %define         _enable_debug_packages  0
42
43 # prelinked library, it is missing some cairo symbols
44 %define         skip_post_check_so      libwx_gtk2ud_core-2.8.so.0
45
46 %description
47 Dropbox is software that syncs your files online and across your
48 computers.
49
50 Put your files into your Dropbox on one computer, and they'll be
51 instantly available on any of your other computers that you've
52 installed Dropbox on (Windows, Mac, and Linux too!) Because a copy of
53 your files are stored on Dropbox's secure servers, you can also access
54 them from any computer or mobile device using the Dropbox website.
55
56 %package gui
57 Summary:        Gtk+2 GUI of Dropbox
58 Group:          X11/Applications
59 Requires:       %{name} = %{version}-%{release}
60
61 %description gui
62 Gtk+2 Systray of Dropbox Daemon status.
63
64 %prep
65 %setup -qcT
66 %ifarch %{ix86}
67 %{__tar} --strip-components=1 -xzf %{SOURCE0}
68 %endif
69 %ifarch %{x8664}
70 %{__tar} --strip-components=1 -xzf %{SOURCE1}
71 %endif
72
73 # no need to package this
74 # altho system python is also 2.7, don't know how to enforce using it system libs
75 #%{__rm} -r distribute-0.6.26-py2.7.egg
76
77 # libraries to be taken from system
78 # for a in *.so*; do ls -ld /lib/$a /usr/lib/$a; done 2>/dev/null
79 %{__rm} libpng12.so.0 libbz2.so.1.0 libpopt.so.0
80
81 # make into symlink, looks cleaner than hardlink:
82 # we can attach executable attrs to binary and leave no attrs for symlink in
83 # %files section.
84 ln -sf dropbox library.zip
85
86 # fun, let's delete non-linux files from archive
87 unzip -l library.zip | grep -E 'arch/(mac|win32)|pynt|ui/cocoa|unittest' | awk '{print $NF}' > lib.delete
88 # TODO: also pymac could be cleaned if pymac.constants is not imported
89 zip library.zip -d $(cat lib.delete)
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_bindir}
94 ln -s %{_libdir}/%{name}/dropboxd $RPM_BUILD_ROOT%{_bindir}/dropboxd
95
96 # install everything else
97 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
98 cp -a . $RPM_BUILD_ROOT%{_libdir}/%{name}
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib.delete
100
101 # in doc
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/{ACKNOWLEDGEMENTS,VERSION,README}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %doc ACKNOWLEDGEMENTS VERSION README
110 %attr(755,root,root) %{_bindir}/dropboxd
111 %dir %{_libdir}/%{name}
112 %attr(755,root,root) %{_libdir}/%{name}/*.so*
113 %attr(755,root,root) %{_libdir}/%{name}/dropbox
114 %attr(755,root,root) %{_libdir}/%{name}/dropboxd
115 %{_libdir}/%{name}/library.zip
116
117 %{_libdir}/%{name}/cffi-*-py*.egg
118 %{_libdir}/%{name}/distribute-*-py*.egg
119 %{_libdir}/%{name}/dropbox_sqlite_ext-*-py*.egg
120 %{_libdir}/%{name}/mock-*-py*.egg
121 %{_libdir}/%{name}/pycparser-*-py*.egg-info
122
123 %exclude %{_libdir}/%{name}/libwx_gtk2*.so.*
124
125 %files gui
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/%{name}/libwx_gtk2*.so.*
128 %dir %{_libdir}/%{name}/images
129 %{_libdir}/%{name}/images/emblems
130 %{_libdir}/%{name}/images/hicolor
This page took 0.022699 seconds and 2 git commands to generate.