]> git.pld-linux.org Git - packages/dropbox.git/blob - dropbox.spec
up to 2.10.3
[packages/dropbox.git] / dropbox.spec
1 # TODO
2 # - avoid dropboxd relaunching itself with newer version if there's update available (disable auto updating):
3 #   glen     25034 19.9  1.5 1496132 81256 pts/46  Sl+  11:02   1:02 /home/glen/.dropbox-dist/dropbox /newerversion
4 # NOTES:
5 # - Upstream Dropbox Support (https://www.dropbox.com/ticket)
6 # - Release Notes (check new versions here): https://www.dropbox.com/release_notes
7 # - Download instructions (click the download link to find current version):
8 #   http://www.dropbox.com/downloading?os=lnx
9 #   http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
10 Summary:        Sync and backup files between computers
11 Name:           dropbox
12 Version:        2.10.3
13 Release:        1
14 License:        Proprietary
15 Group:          Daemons
16 Source0:        http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
17 # NoSource0-md5:        4ab5cd2ba514e46eee6208af650ceb73
18 NoSource:       0
19 Source1:        http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
20 # NoSource1-md5:        2e44b9d1038768929425712cc0f448fd
21 NoSource:       1
22 URL:            http://www.dropbox.com/
23 BuildRequires:  rpmbuild(macros) >= 1.566
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  tar >= 1:1.15.1
26 BuildRequires:  unzip
27 BuildRequires:  zip
28 Conflicts:      nautilus-dropbox < 0.6.3-2
29 ExclusiveArch:  %{ix86} %{x8664}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 # generate no Provides from private modules
33 %define         _noautoprovfiles        %{_libdir}/%{name}
34
35 # provided by package itself, but autodeps disabled
36 %define         _noautoreq              libwx_.*.so librsync.so.1 libffi.so.6
37
38 # a zip and executable at the same time
39 %define         _noautostrip    .*/library.zip\\|.*/dropbox
40
41 # debuginfo wouldn't be useful
42 %define         _enable_debug_packages  0
43
44 # prelinked library, it is missing some cairo symbols
45 %define         skip_post_check_so      libwx_gtk2ud_core-2.8.so.0
46
47 %description
48 Dropbox is software that syncs your files online and across your
49 computers.
50
51 Put your files into your Dropbox on one computer, and they'll be
52 instantly available on any of your other computers that you've
53 installed Dropbox on (Windows, Mac, and Linux too!) Because a copy of
54 your files are stored on Dropbox's secure servers, you can also access
55 them from any computer or mobile device using the Dropbox website.
56
57 %package gui
58 Summary:        Gtk+2 GUI of Dropbox
59 Group:          X11/Applications
60 Requires:       %{name} = %{version}-%{release}
61
62 %description gui
63 Gtk+2 Systray of Dropbox Daemon status.
64
65 %prep
66 %setup -qcT
67 %ifarch %{ix86}
68 %{__tar} --strip-components=1 -xzf %{SOURCE0}
69 %endif
70 %ifarch %{x8664}
71 %{__tar} --strip-components=1 -xzf %{SOURCE1}
72 %endif
73 mv dropbox-lnx.*-%{version}/* .
74
75 # no need to package this
76 # altho system python is also 2.7, don't know how to enforce using it system libs
77 #%{__rm} -r distribute-0.6.26-py2.7.egg
78
79 # libraries to be taken from system
80 # for a in *.so*; do ls -ld /lib/$a /usr/lib/$a; done 2>/dev/null
81 %{__rm} libpng12.so.0 libbz2.so.1.0 libpopt.so.0
82
83 # make into symlink, looks cleaner than hardlink:
84 # we can attach executable attrs to binary and leave no attrs for symlink in
85 # %files section.
86 ln -sf dropbox library.zip
87
88 # fun, let's delete non-linux files from archive
89 unzip -l library.zip | \
90         grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac).py|pynt|pymac|ui/cocoa|unittest' | \
91         grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework).py' | \
92         awk '{print $NF}' > lib.delete
93 zip library.zip -d $(cat lib.delete)
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_bindir}
98 ln -s %{_libdir}/%{name}/dropboxd $RPM_BUILD_ROOT%{_bindir}/dropboxd
99
100 # install everything else
101 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
102 cp -a . $RPM_BUILD_ROOT%{_libdir}/%{name}
103 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib.delete
104
105 # in doc
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/{ACKNOWLEDGEMENTS,VERSION,README}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc ACKNOWLEDGEMENTS VERSION README
114 %attr(755,root,root) %{_bindir}/dropboxd
115 %dir %{_libdir}/%{name}
116 %attr(755,root,root) %{_libdir}/%{name}/*.so*
117 %attr(755,root,root) %{_libdir}/%{name}/dropbox
118 %attr(755,root,root) %{_libdir}/%{name}/dropboxd
119 %{_libdir}/%{name}/library.zip
120
121 %{_libdir}/%{name}/cffi-*-py*.egg
122 %{_libdir}/%{name}/distribute-*-py*.egg
123 %{_libdir}/%{name}/dropbox_sqlite_ext-*-py*.egg
124 %{_libdir}/%{name}/mock-*-py*.egg
125 %{_libdir}/%{name}/pycparser-*-py*.egg-info
126
127 %exclude %{_libdir}/%{name}/libwx_gtk2*.so.*
128
129 %files gui
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/%{name}/libwx_gtk2*.so.*
132 %dir %{_libdir}/%{name}/images
133 %{_libdir}/%{name}/images/emblems
134 %{_libdir}/%{name}/images/hicolor
This page took 0.074744 seconds and 3 git commands to generate.