]> git.pld-linux.org Git - packages/dropbox.git/blame - dropbox.spec
libffi.so.6 librsync.so.1 bundled, noautoreq
[packages/dropbox.git] / dropbox.spec
CommitLineData
eec680ba
ER
1# TODO
2# - avoid dropboxd relaunching itself with newer version if there's update available (disable auto updating):
3# glen 25034 19.9 1.5 1496132 81256 pts/46 Sl+ 11:02 1:02 /home/glen/.dropbox-dist/dropbox /newerversion
9dd470b7
ER
4# NOTES:
5# - Upstream Dropbox Support (https://www.dropbox.com/ticket)
77d2e1b5 6# - Release Notes (check new versions here): https://www.dropbox.com/release_notes
9dd470b7 7# - Download instructions (click the download link to find current version):
14bae0cf 8# http://www.dropbox.com/downloading?os=lnx
84f5c3ef 9# http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
da4b87b9
ER
10Summary: Sync and backup files between computers
11Name: dropbox
d4296247 12Version: 3.4.3
38baf4d5 13Release: 0.4
da4b87b9
ER
14License: Proprietary
15Group: Daemons
da4b87b9 16Source0: http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
d4296247 17# NoSource0-md5: b3beb92548b7c7cf0cc279582d69ed85
da4b87b9
ER
18NoSource: 0
19Source1: http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
d4296247 20# NoSource1-md5: 8e3430df10bdb876a1e3cd374faa0594
da4b87b9 21NoSource: 1
284b53dc 22URL: http://www.dropbox.com/
da4b87b9
ER
23BuildRequires: rpmbuild(macros) >= 1.566
24BuildRequires: sed >= 4.0
25BuildRequires: tar >= 1:1.15.1
6b9a4628 26BuildRequires: unzip
5fe51dfe 27BuildRequires: zip
8c0a6f53 28Conflicts: nautilus-dropbox < 0.6.3-2
da4b87b9
ER
29ExclusiveArch: %{ix86} %{x8664}
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32# generate no Provides from private modules
33%define _noautoprovfiles %{_libdir}/%{name}
34
d4b9c773
ER
35# libicu-42, but pld th already has 54
36%define icu_libs libicudata.so.42 libicui18n.so.42 libicuuc.so.42
37
da4b87b9 38# provided by package itself, but autodeps disabled
38baf4d5 39%define _noautoreq libwx_.*.so %{icu_libs} libffi.so.6 librsync.so.1
da4b87b9
ER
40
41# a zip and executable at the same time
42%define _noautostrip .*/library.zip\\|.*/dropbox
43
44# debuginfo wouldn't be useful
45%define _enable_debug_packages 0
46
b70c96ae 47# prelinked library, it is missing some cairo symbols
d4b9c773 48#define skip_post_check_so libwx_gtk2ud_core-2.8.so.0
b70c96ae 49
da4b87b9
ER
50%description
51Dropbox is software that syncs your files online and across your
52computers.
53
54Put your files into your Dropbox on one computer, and they'll be
55instantly available on any of your other computers that you've
56installed Dropbox on (Windows, Mac, and Linux too!) Because a copy of
57your files are stored on Dropbox's secure servers, you can also access
58them from any computer or mobile device using the Dropbox website.
59
eec680ba
ER
60%package gui
61Summary: Gtk+2 GUI of Dropbox
62Group: X11/Applications
63Requires: %{name} = %{version}-%{release}
64
65%description gui
66Gtk+2 Systray of Dropbox Daemon status.
67
da4b87b9
ER
68%prep
69%setup -qcT
70%ifarch %{ix86}
71%{__tar} --strip-components=1 -xzf %{SOURCE0}
72%endif
73%ifarch %{x8664}
74%{__tar} --strip-components=1 -xzf %{SOURCE1}
75%endif
27fd1422 76mv dropbox-lnx.*-%{version}/* .
da4b87b9 77
84f5c3ef 78# no need to package this
284b53dc
ER
79# altho system python is also 2.7, don't know how to enforce using it system libs
80#%{__rm} -r distribute-0.6.26-py2.7.egg
77d2e1b5
ER
81
82# libraries to be taken from system
f79c3c96 83# for a in *.so*; do ls -ld /lib64/$a %{_libdir}/$a; done 2>/dev/null
2033761e 84%{__rm} libpopt.so.0 libdrm.so.2 libGL.so.1
f79c3c96
ER
85#%{__rm} libffi.so.6 librsync.so.1
86#%{__rm} libQt5{Core,DBus,Gui,Network,OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets,Widgets}.so.5
84f5c3ef 87
da4b87b9
ER
88# make into symlink, looks cleaner than hardlink:
89# we can attach executable attrs to binary and leave no attrs for symlink in
90# %files section.
91ln -sf dropbox library.zip
92
84f5c3ef 93# fun, let's delete non-linux files from archive
9ece03ce 94unzip -l library.zip | \
f7bc3b8e 95 grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac).py|pymac|ui/cocoa|unittest' | \
9ece03ce
ER
96 grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework).py' | \
97 awk '{print $NF}' > lib.delete
77d2e1b5 98zip library.zip -d $(cat lib.delete)
f4d77724 99
da4b87b9
ER
100%install
101rm -rf $RPM_BUILD_ROOT
102install -d $RPM_BUILD_ROOT%{_bindir}
77d2e1b5 103ln -s %{_libdir}/%{name}/dropboxd $RPM_BUILD_ROOT%{_bindir}/dropboxd
da4b87b9
ER
104
105# install everything else
77d2e1b5
ER
106install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
107cp -a . $RPM_BUILD_ROOT%{_libdir}/%{name}
108%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib.delete
da4b87b9
ER
109
110# in doc
77d2e1b5 111%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/{ACKNOWLEDGEMENTS,VERSION,README}
da4b87b9
ER
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%files
117%defattr(644,root,root,755)
14bae0cf 118%doc ACKNOWLEDGEMENTS VERSION README
da4b87b9 119%attr(755,root,root) %{_bindir}/dropboxd
77d2e1b5
ER
120%dir %{_libdir}/%{name}
121%attr(755,root,root) %{_libdir}/%{name}/*.so*
122%attr(755,root,root) %{_libdir}/%{name}/dropbox
123%attr(755,root,root) %{_libdir}/%{name}/dropboxd
124%{_libdir}/%{name}/library.zip
125
2033761e 126%{_libdir}/%{name}/backports.ssl_match_hostname-*-py*.egg
284b53dc
ER
127%{_libdir}/%{name}/cffi-*-py*.egg
128%{_libdir}/%{name}/distribute-*-py*.egg
129%{_libdir}/%{name}/dropbox_sqlite_ext-*-py*.egg
2033761e 130%{_libdir}/%{name}/futures-*-py*.egg
284b53dc 131%{_libdir}/%{name}/mock-*-py*.egg
2033761e 132%{_libdir}/%{name}/psutil-*-py*.egg
284b53dc 133%{_libdir}/%{name}/pycparser-*-py*.egg-info
ea1995d6 134%{_libdir}/%{name}/requests-*-py*.egg
2033761e 135%{_libdir}/%{name}/tornado-*-py*.egg
fae5f35a 136
d4b9c773
ER
137# GUI parts
138%exclude %{_libdir}/%{name}/PyQt5.*.so
139%exclude %{_libdir}/%{name}/libQt5*.so.5
a3376eb8 140%exclude %{_libdir}/%{name}/libX11-xcb.so.1
d4b9c773 141%exclude %{_libdir}/%{name}/dbus.mainloop.pyqt5.so
eec680ba
ER
142
143%files gui
144%defattr(644,root,root,755)
92ada34f 145%attr(755,root,root) %{_libdir}/%{name}/wmctrl
d4b9c773
ER
146%attr(755,root,root) %{_libdir}/%{name}/PyQt5.*.so
147%attr(755,root,root) %{_libdir}/%{name}/libQt5*.so.5
a3376eb8 148%attr(755,root,root) %{_libdir}/%{name}/libX11-xcb.so.1
d4b9c773
ER
149%attr(755,root,root) %{_libdir}/%{name}/dbus.mainloop.pyqt5.so
150%dir %{_libdir}/%{name}/plugins
151%dir %{_libdir}/%{name}/plugins/platforms
152%attr(755,root,root) %{_libdir}/%{name}/plugins/platforms/libqxcb.so
153%{_libdir}/%{name}/qt.conf
77d2e1b5
ER
154%dir %{_libdir}/%{name}/images
155%{_libdir}/%{name}/images/emblems
156%{_libdir}/%{name}/images/hicolor
This page took 0.073869 seconds and 4 git commands to generate.