]> git.pld-linux.org Git - packages/dropbox.git/blame - dropbox.spec
up to 12.4.22
[packages/dropbox.git] / dropbox.spec
CommitLineData
eec680ba
ER
1# TODO
2# - avoid dropboxd relaunching itself with newer version if there's update available (disable auto updating):
3# glen 25034 19.9 1.5 1496132 81256 pts/46 Sl+ 11:02 1:02 /home/glen/.dropbox-dist/dropbox /newerversion
9dd470b7
ER
4# NOTES:
5# - Upstream Dropbox Support (https://www.dropbox.com/ticket)
77d2e1b5 6# - Release Notes (check new versions here): https://www.dropbox.com/release_notes
9dd470b7 7# - Download instructions (click the download link to find current version):
14bae0cf 8# http://www.dropbox.com/downloading?os=lnx
84f5c3ef 9# http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
da4b87b9
ER
10Summary: Sync and backup files between computers
11Name: dropbox
d78295a9 12# https://www.dropboxforum.com/hc/en-us/community/posts/206682016-New-Versioning-Scheme
fb570d47 13Version: 12.4.22
7f499e9b 14Release: 1
da4b87b9
ER
15License: Proprietary
16Group: Daemons
da4b87b9 17Source0: http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
fb570d47 18# NoSource0-md5: 0e94f3710fd5436064d9215e68cab13e
da4b87b9
ER
19NoSource: 0
20Source1: http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
fb570d47 21# NoSource1-md5: 33147635b18742ed2fdcda6b0c46b1e0
da4b87b9 22NoSource: 1
284b53dc 23URL: http://www.dropbox.com/
da4b87b9
ER
24BuildRequires: rpmbuild(macros) >= 1.566
25BuildRequires: sed >= 4.0
26BuildRequires: tar >= 1:1.15.1
6b9a4628 27BuildRequires: unzip
5fe51dfe 28BuildRequires: zip
8c0a6f53 29Conflicts: nautilus-dropbox < 0.6.3-2
da4b87b9
ER
30ExclusiveArch: %{ix86} %{x8664}
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33# generate no Provides from private modules
34%define _noautoprovfiles %{_libdir}/%{name}
35
d4b9c773
ER
36# libicu-42, but pld th already has 54
37%define icu_libs libicudata.so.42 libicui18n.so.42 libicuuc.so.42
38
da4b87b9 39# provided by package itself, but autodeps disabled
38baf4d5 40%define _noautoreq libwx_.*.so %{icu_libs} libffi.so.6 librsync.so.1
da4b87b9
ER
41
42# a zip and executable at the same time
43%define _noautostrip .*/library.zip\\|.*/dropbox
44
45# debuginfo wouldn't be useful
46%define _enable_debug_packages 0
47
b70c96ae 48# prelinked library, it is missing some cairo symbols
d4b9c773 49#define skip_post_check_so libwx_gtk2ud_core-2.8.so.0
b70c96ae 50
da4b87b9
ER
51%description
52Dropbox is software that syncs your files online and across your
53computers.
54
55Put your files into your Dropbox on one computer, and they'll be
56instantly available on any of your other computers that you've
57installed Dropbox on (Windows, Mac, and Linux too!) Because a copy of
58your files are stored on Dropbox's secure servers, you can also access
59them from any computer or mobile device using the Dropbox website.
60
eec680ba
ER
61%package gui
62Summary: Gtk+2 GUI of Dropbox
63Group: X11/Applications
64Requires: %{name} = %{version}-%{release}
65
66%description gui
67Gtk+2 Systray of Dropbox Daemon status.
68
da4b87b9
ER
69%prep
70%setup -qcT
71%ifarch %{ix86}
72%{__tar} --strip-components=1 -xzf %{SOURCE0}
73%endif
74%ifarch %{x8664}
75%{__tar} --strip-components=1 -xzf %{SOURCE1}
76%endif
27fd1422 77mv dropbox-lnx.*-%{version}/* .
da4b87b9 78
84f5c3ef 79# no need to package this
284b53dc
ER
80# altho system python is also 2.7, don't know how to enforce using it system libs
81#%{__rm} -r distribute-0.6.26-py2.7.egg
77d2e1b5
ER
82
83# libraries to be taken from system
d78295a9 84# for a in *.so*; do ls -ld /lib64/$a /us?/lib64/$a; done 2>/dev/null
2033761e 85%{__rm} libpopt.so.0 libdrm.so.2 libGL.so.1
3893feea 86%{__rm} libffi.so.6
d78295a9
ER
87%{__rm} libX11-xcb.so.1
88%{__rm} libQt5{Core,DBus,Gui,Network,OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets,Widgets,XcbQpa}.so.5
89%{__rm} qt.conf
90%{__rm} -r plugins
84f5c3ef 91
3893feea 92# keep librsync, won't finish syncing if not using upstream copy
5dd25d12 93test -f librsync.so.1
3893feea 94
84f5c3ef 95# fun, let's delete non-linux files from archive
9ece03ce 96unzip -l library.zip | \
8669a5fc
ER
97 grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac)\.py|pymac|ui/cocoa|unittest' | \
98 grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework)\.py' | \
99 grep -vE 'dropbox/mac/(version|__init__).py' | \
9ece03ce 100 awk '{print $NF}' > lib.delete
77d2e1b5 101zip library.zip -d $(cat lib.delete)
f4d77724 102
bd07dff0
ER
103# make into symlink, looks cleaner than hardlink:
104# we can attach executable attrs to binary and leave no attrs for symlink in
105# %files section.
106ln -sf dropbox library.zip
107
da4b87b9
ER
108%install
109rm -rf $RPM_BUILD_ROOT
110install -d $RPM_BUILD_ROOT%{_bindir}
77d2e1b5 111ln -s %{_libdir}/%{name}/dropboxd $RPM_BUILD_ROOT%{_bindir}/dropboxd
da4b87b9
ER
112
113# install everything else
77d2e1b5
ER
114install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
115cp -a . $RPM_BUILD_ROOT%{_libdir}/%{name}
116%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib.delete
da4b87b9
ER
117
118# in doc
77d2e1b5 119%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/{ACKNOWLEDGEMENTS,VERSION,README}
da4b87b9
ER
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%files
125%defattr(644,root,root,755)
14bae0cf 126%doc ACKNOWLEDGEMENTS VERSION README
da4b87b9 127%attr(755,root,root) %{_bindir}/dropboxd
77d2e1b5
ER
128%dir %{_libdir}/%{name}
129%attr(755,root,root) %{_libdir}/%{name}/*.so*
130%attr(755,root,root) %{_libdir}/%{name}/dropbox
131%attr(755,root,root) %{_libdir}/%{name}/dropboxd
132%{_libdir}/%{name}/library.zip
133
284b53dc 134%{_libdir}/%{name}/dropbox_sqlite_ext-*-py*.egg
2033761e 135%{_libdir}/%{name}/psutil-*-py*.egg
5948e56c 136%{_libdir}/%{name}/setuptools-*-py*.egg
fae5f35a 137
dbd4f1f7
ER
138# need +x bits for .so files
139%defattr(-,root,root,-)
140%{_libdir}/%{name}/cryptography-*-py*-linux-*.egg
141
d4b9c773
ER
142# GUI parts
143%exclude %{_libdir}/%{name}/PyQt5.*.so
d4b9c773 144%exclude %{_libdir}/%{name}/dbus.mainloop.pyqt5.so
eec680ba
ER
145
146%files gui
147%defattr(644,root,root,755)
92ada34f 148%attr(755,root,root) %{_libdir}/%{name}/wmctrl
d4b9c773 149%attr(755,root,root) %{_libdir}/%{name}/PyQt5.*.so
d4b9c773 150%attr(755,root,root) %{_libdir}/%{name}/dbus.mainloop.pyqt5.so
77d2e1b5
ER
151%dir %{_libdir}/%{name}/images
152%{_libdir}/%{name}/images/emblems
153%{_libdir}/%{name}/images/hicolor
e2a81b70 154%{_libdir}/%{name}/resources
This page took 0.057342 seconds and 4 git commands to generate.