]> git.pld-linux.org Git - packages/droidbattles.git/blob - droidbattles.spec
a6d283ea55cf8a9d5d18a31c252daac1b23ed20f
[packages/droidbattles.git] / droidbattles.spec
1 Summary:        A game of programming
2 Summary(pl.UTF-8):   Gra w programowanie
3 Name:           droidbattles
4 Version:        1.0.4
5 Release:        1
6 License:        GPL
7 Group:          X11/Applications/Games
8 Source0:        http://www.bluefire.nu/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  88f71cc17895d3aa77cfbb3428d41dbc
10 Source1:        http://www.bluefire.nu/%{name}/bots-light-01-06-11.tar.gz
11 # Source1-md5:  358a931c2d795f6c005a9b4da07c1439
12 Source2:        %{name}.desktop
13 Source3:        %{name}.png
14 URL:            http://www.bluefire.nu/droidbattles/
15 BuildRequires:  qt-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 So, you're having this argument about who's the best programmer? Or
20 you just want to have some programming fun? What better way to do it
21 than a little game of AI programming.
22
23 In DroidBattles you design the bots by choosing which hardware they
24 should contain. Each bot can have up to 32 hardware devices that you
25 can choose freely from a list of available types. Examples include
26 weapons, armor, CPU:s, engines... etc.
27
28 When you have chosen the hardware it's time to program it. You make a
29 program (in an assembler like language) that is loaded into a virtual
30 RAM of the bot and then executed by the CPU device(s) you've included
31 with the bot. You communicate with your devices through simple in/out
32 instruktions.
33
34 Other features of DroidBattles includes team-battle and set up of
35 "rules" for a game, (you can enable/disable hardware devices and also
36 set the costs).
37
38 You can make the bot have it's own graphics that is shown when the
39 simulation runs. When everyhing is ready you assemble the program and
40 a .bot file is created. You can now test this bot against other bots
41 in the simulator, and hopefully your bot will crush it's opponents.
42
43 %description -l pl.UTF-8
44 A więc spierasz się o to, kto jest najlepszym programistą? Lub po
45 prostu chcesz zaznać przyjemności programowania? Cóż lepszego może być
46 od gry, w której programujesz Sztuczną Inteligencję.
47
48 W DroidBattles projektujesz boty wybierając jaki hardware powinny
49 zawierać. Każdy bot może pomieścić do 32 urządzeń sprzętowych, które
50 możesz dowolnie wybierać z dostępnej listy. Mogą to być bronie,
51 pancerz, CPU, silniki... etc.
52
53 Gdy wybrałeś już sprzęt, nadszedł czas na zaprogramowanie. Tworzysz
54 program (w języku podobnym do assemblera), który jest ładowany do
55 wirtualnego RAMu bota, a następnie wykonywany przez jednostki
56 przetwarzania, które zainstalowałeś w bocie. Komunikujesz się ze
57 swoimi urządzeniami za pomocą prostych instrukcji wejścia/wyjścia.
58
59 Wśród innych zalet DroidBattles można wymienić bitwy drużynowe, jak i
60 zestawy "zasad" dla gry (możesz włączać/wyłączać urządzenia sprzętowe,
61 a także ustawiać koszt.)
62
63 Możesz stworzyć dla bota jego własną grafikę, która będzie pokazywana
64 podczas symulacji. Gdy wszystko jest gotowe, assemblujesz program i
65 utworzony zostaje plik .bot. Możesz wtedy przetestować bota w starciu
66 z innymi botami w symulatorze i przy dozie szczęścia zostać zwycięzcą.
67
68 %prep
69 %setup -q
70 mkdir bots
71 cd bots
72 tar zxvf %{SOURCE1}
73
74 %build
75 find . -exec touch \{\} \;
76 %configure2_13 \
77         --enable-final
78
79 cd %{name}
80 cat installdir.cpp | sed 's@/usr/local/droidbattles@%{_datadir}/droidbattles@' > installdir.cpp.new
81 mv -f installdir.cpp.new installdir.cpp
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_applnkdir}/Games}
87
88 cd %{name}
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91 rm docs/en/Makefile*
92 cd ..
93 for i in bots/*
94 do
95         mv $i $RPM_BUILD_ROOT/usr/local/%{name}/bots/
96 done
97 cd $RPM_BUILD_ROOT/usr
98 mv local/%{name} X11R6/share/
99 rm -rf X11R6/share/%{name}/doc
100 ln -s /usr/share/doc/%{name}-%{version} X11R6/share/%{name}/doc
101
102 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Games
103 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog TODO
111 %doc %{name}/docs/en/*.html
112 %attr(755,root,root) %{_bindir}/*
113 %{_datadir}/droidbattles
114 %{_pixmapsdir}/*
115 %{_applnkdir}/Games/*
This page took 0.062672 seconds and 2 git commands to generate.