]> git.pld-linux.org Git - packages/droidbattles.git/blame - droidbattles.spec
- tabs in preamble
[packages/droidbattles.git] / droidbattles.spec
CommitLineData
86697982 1Summary: A game of programming
5240e1f9 2Summary(pl.UTF-8): Gra w programowanie
86697982 3Name: droidbattles
4Version: 1.0.4
5Release: 1
6License: GPL
7Group: X11/Applications/Games
86697982 8Source0: http://www.bluefire.nu/%{name}/%{name}-%{version}.tar.gz
834552a2 9# Source0-md5: 88f71cc17895d3aa77cfbb3428d41dbc
86697982 10Source1: http://www.bluefire.nu/%{name}/bots-light-01-06-11.tar.gz
834552a2 11# Source1-md5: 358a931c2d795f6c005a9b4da07c1439
86697982 12Source2: %{name}.desktop
13Source3: %{name}.png
14URL: http://www.bluefire.nu/droidbattles/
15BuildRequires: qt-devel
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
86697982 18%description
19So, you're having this argument about who's the best programmer? Or
20you just want to have some programming fun? What better way to do it
21than a little game of AI programming.
22
23In DroidBattles you design the bots by choosing which hardware they
24should contain. Each bot can have up to 32 hardware devices that you
25can choose freely from a list of available types. Examples include
26weapons, armor, CPU:s, engines... etc.
27
28When you have chosen the hardware it's time to program it. You make a
29program (in an assembler like language) that is loaded into a virtual
30RAM of the bot and then executed by the CPU device(s) you've included
31with the bot. You communicate with your devices through simple in/out
32instruktions.
33
34Other features of DroidBattles includes team-battle and set up of
35"rules" for a game, (you can enable/disable hardware devices and also
36set the costs).
37
38You can make the bot have it's own graphics that is shown when the
39simulation runs. When everyhing is ready you assemble the program and
40a .bot file is created. You can now test this bot against other bots
41in the simulator, and hopefully your bot will crush it's opponents.
42
4fd49cea
JR
43%description -l pl.UTF-8
44A więc spierasz się o to, kto jest najlepszym programistą? Lub po
45prostu chcesz zaznać przyjemności programowania? Cóż lepszego może być
46od gry, w której programujesz Sztuczną Inteligencję.
86697982 47
4fd49cea
JR
48W DroidBattles projektujesz boty wybierając jaki hardware powinny
49zawierać. Każdy bot może pomieścić do 32 urządzeń sprzętowych, które
50możesz dowolnie wybierać z dostępnej listy. Mogą to być bronie,
86697982 51pancerz, CPU, silniki... etc.
52
4fd49cea
JR
53Gdy wybrałeś już sprzęt, nadszedł czas na zaprogramowanie. Tworzysz
54program (w języku podobnym do assemblera), który jest ładowany do
55wirtualnego RAMu bota, a następnie wykonywany przez jednostki
56przetwarzania, które zainstalowałeś w bocie. Komunikujesz się ze
57swoimi urządzeniami za pomocą prostych instrukcji wejścia/wyjścia.
86697982 58
4fd49cea
JR
59Wśród innych zalet DroidBattles można wymienić bitwy drużynowe, jak i
60zestawy "zasad" dla gry (możesz włączać/wyłączać urządzenia sprzętowe,
61a także ustawiać koszt.)
86697982 62
4fd49cea 63Możesz stworzyć dla bota jego własną grafikę, która będzie pokazywana
86697982 64podczas symulacji. Gdy wszystko jest gotowe, assemblujesz program i
4fd49cea
JR
65utworzony zostaje plik .bot. Możesz wtedy przetestować bota w starciu
66z innymi botami w symulatorze i przy dozie szczęścia zostać zwycięzcą.
86697982 67
68%prep
69%setup -q
70mkdir bots
71cd bots
72tar zxvf %{SOURCE1}
73
74%build
75find . -exec touch \{\} \;
76%configure2_13 \
77 --enable-final
78
79cd %{name}
80cat installdir.cpp | sed 's@/usr/local/droidbattles@%{_datadir}/droidbattles@' > installdir.cpp.new
81mv -f installdir.cpp.new installdir.cpp
82%{__make}
83
84%install
85rm -rf $RPM_BUILD_ROOT
86install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_applnkdir}/Games}
87
86697982 88cd %{name}
d843cf6b
PG
89%{__make} install \
90 DESTDIR=$RPM_BUILD_ROOT
86697982 91rm docs/en/Makefile*
92cd ..
93for i in bots/*
94do
95 mv $i $RPM_BUILD_ROOT/usr/local/%{name}/bots/
96done
97cd $RPM_BUILD_ROOT/usr
98mv local/%{name} X11R6/share/
99rm -rf X11R6/share/%{name}/doc
100ln -s /usr/share/doc/%{name}-%{version} X11R6/share/%{name}/doc
101
102install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Games
103install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%files
109%defattr(644,root,root,755)
c561a50a 110%doc AUTHORS ChangeLog TODO
86697982 111%doc %{name}/docs/en/*.html
112%attr(755,root,root) %{_bindir}/*
113%{_datadir}/droidbattles
114%{_pixmapsdir}/*
115%{_applnkdir}/Games/*
This page took 0.055527 seconds and 4 git commands to generate.