]> git.pld-linux.org Git - packages/drbd.git/blobdiff - drbd.spec
- typo in patch number
[packages/drbd.git] / drbd.spec
index 3942d36c0ca99fc0ee922997028e8927bd6b1627..038db7e69b6304c1e383b4b4e2b448304af8cb1e 100644 (file)
--- a/drbd.spec
+++ b/drbd.spec
@@ -1,38 +1,49 @@
 #
+# TODO:
+#  - trigger to update drbd-8.2 config
+#
 # Conditional build:
 %bcond_without dist_kernel     # allow non-distribution kernel
 %bcond_without kernel          # don't build kernel modules
-%bcond_without smp             # don't build SMP module
 %bcond_without userspace       # don't build userspace module
 %bcond_with    verbose         # verbose build (V=1)
 %bcond_with    grsec_kernel    # build for kernel-grsecurity
 #
+%ifarch sparc
+%undefine      with_smp
+%endif
+
+%if %{without kernel}
+%undefine      with_dist_kernel
+%endif
 %if %{with kernel} && %{with dist_kernel} && %{with grsec_kernel}
 %define        alt_kernel      grsecurity
 %endif
-#
-%ifarch sparc
-%undefine      with_smp
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
 %endif
 
-%define        _rel    4
+%define                _rel    1
+%define                pname   drbd
 Summary:       drbd is a block device designed to build high availibility clusters
-Summary(pl):   drbd jest urz±dzeniem blokowym dla klastrów o wysokiej niezawodno¶ci
-Name:          drbd
-Version:       0.7.22
+Summary(pl.UTF-8):     drbd jest urządzeniem blokowym dla klastrów o wysokiej niezawodności
+Name:          %{pname}%{_alt_kernel}
+Version:       8.3.2
 Release:       %{_rel}
 License:       GPL
 Group:         Base/Kernel
-Source0:       http://oss.linbit.com/drbd/0.7/%{name}-%{version}.tar.gz
-# Source0-md5: 589626e0c62d314d3bbe78275b9e7d2d
-Patch0:                %{name}-Makefile.patch
+Source0:       http://oss.linbit.com/drbd/8.3/%{pname}-%{version}.tar.gz
+# Source0-md5: 8aa8f7891d397ff25b7a3f77f56d353b
+Patch0:                %{pname}-Makefile.patch
+Patch1:                %{pname}-swab.patch
+Patch2:                %{pname}-parallel-install.patch
 URL:           http://www.drbd.org/
 %if %{with userspace}
 BuildRequires: bison
 BuildRequires: flex
 %endif
-%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build}
-BuildRequires: rpmbuild(macros) >= 1.330
+%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
+BuildRequires: rpmbuild(macros) >= 1.379
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -40,39 +51,44 @@ drbd is a block device which is designed to build high availability
 clusters. This is done by mirroring a whole block device via (a
 dedicated) network. You could see it as a network RAID1.
 
-%description -l pl
-drbd jest urz±dzeniem blokowym zaprojektowanym dla klastrów o wysokiej
-niezawodno¶ci. drbd dzia³a jako mirroring ca³ego urz±dzenia blokowego
-przez (dedykowan±) sieæ. Mo¿e byæ widoczny jako sieciowy RAID1.
+%description -l pl.UTF-8
+drbd jest urządzeniem blokowym zaprojektowanym dla klastrów o wysokiej
+niezawodności. drbd działa jako mirroring całego urządzenia blokowego
+przez (dedykowaną) sieć. Może być widoczny jako sieciowy RAID1.
 
-%description -l pt_BR
-O DRBD é um dispositivo de bloco que é projetado para construir
-clusters de Alta Disponibilidade. Isto é feito espelhando um
-dispositivo de bloco inteiro via rede (dedicada ou não). Pode ser
-visto como um RAID 1 via rede. Este pacote contém utilitários para
+%description -l pt_BR.UTF-8
+O DRBD é um dispositivo de bloco que é projetado para construir
+clusters de Alta Disponibilidade. Isto é feito espelhando um
+dispositivo de bloco inteiro via rede (dedicada ou não). Pode ser
+visto como um RAID 1 via rede. Este pacote contém utilitários para
 gerenciar dispositivos DRBD.
 
 %package -n drbdsetup
 Summary:       Setup tool and scripts for DRBD
-Summary(pl):   Narzêdzie konfiguracyjne i skrypty dla DRBD
-Summary(pt_BR):        Utilitários para gerenciar dispositivos DRBD
+Summary(pl.UTF-8):     Narzędzie konfiguracyjne i skrypty dla DRBD
+Summary(pt_BR.UTF-8):  Utilitários para gerenciar dispositivos DRBD
 Group:         Applications/System
 Requires(post,preun):  /sbin/chkconfig
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(postun):      /usr/sbin/groupdel
 Requires:      rc-scripts
+Provides:      group(haclient)
 Conflicts:     drbdsetup24
+Obsoletes:     drbdsetup8
 
 %description -n drbdsetup
 Setup tool and init scripts for DRBD.
 
-%description -n drbdsetup -l pl
-Narzêdzie konfiguracyjne i skrypty startowe dla DRBD.
+%description -n drbdsetup -l pl.UTF-8
+Narzędzie konfiguracyjne i skrypty startowe dla DRBD.
 
 %package -n kernel%{_alt_kernel}-block-drbd
 Summary:       Kernel module with drbd - a block device designed to build high availibility clusters
-Summary(pl):   Modu³ j±dra do drbd - urz±dzenia blokowego dla klastrów o wysokiej niezawodno¶ci
+Summary(pl.UTF-8):     Moduł jądra do drbd - urządzenia blokowego dla klastrów o wysokiej niezawodności
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_up}
+%{?with_dist_kernel:%requires_releq_kernel}
 Requires(post,postun): /sbin/depmod
 Requires:      drbdsetup
 
@@ -81,33 +97,28 @@ drbd is a block device which is designed to build high availability
 clusters. This is done by mirroring a whole block device via (a
 dedicated) network. You could see it as a network RAID1.
 
-%description -n kernel%{_alt_kernel}-block-drbd -l pl
-drbd jest urz±dzeniem blokowym zaprojektowanym dla klastrów o wysokiej
-niezawodno¶ci. drbd dzia³a jako mirroring ca³ego urz±dzenia blokowego
-przez (dedykowan±) sieæ. Mo¿e byæ widoczny jako sieciowy RAID1.
+%description -n kernel%{_alt_kernel}-block-drbd -l pl.UTF-8
+drbd jest urządzeniem blokowym zaprojektowanym dla klastrów o wysokiej
+niezawodności. drbd działa jako mirroring całego urządzenia blokowego
+przez (dedykowaną) sieć. Może być widoczny jako sieciowy RAID1.
 
-%package -n kernel%{_alt_kernel}-smp-block-drbd
-Summary:       SMP kernel module with drbd - a block device designed to build high availibility clusters
-Summary(pl):   Wersja SMP Modu³u j±dra do drbd - urz±dzenia blokowego dla klastrów o wysokiej niezawodno¶ci
-Release:       %{_rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_smp}
-Requires(post,postun): /sbin/depmod
-Requires:      drbdsetup
+%package -n bash-completion-drbd
+Summary:       bash-completion for drbd
+Summary(pl.UTF-8):     Bashowe uzupełnianie poleceń dla drbd
+Group:         Applications/Shells
+Requires:      bash-completion
 
-%description -n kernel%{_alt_kernel}-smp-block-drbd
-drbd is a block device which is designed to build high availability
-clusters. This is done by mirroring a whole block device via (a
-dedicated) network. You could see it as a network RAID1.
+%description -n bash-completion-drbd
+This package provides bash-completion for drbd.
 
-%description -n kernel%{_alt_kernel}-smp-block-drbd -l pl
-drbd jest urz±dzeniem blokowym zaprojektowanym dla klastrów o wysokiej
-niezawodno¶ci. drbd dzia³a jako mirroring ca³ego urz±dzenia blokowego
-przez (dedykowan±) sieæ. Mo¿e byæ widoczny jako sieciowy RAID1.
+%description -n bash-completion-drbd -l pl.UTF-8
+Ten pakiet dostarcza bashowe uzupełnianie poleceń dla drbd.
 
 %prep
-%setup -q
+%setup -q -n %{pname}-%{version}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %if %{with userspace}
@@ -123,7 +134,7 @@ cd drbd
 sed -i -e 's#$(CONFIG_BLK_DEV_DRBD)#m#g' Makefile-2.6
 ln -sf Makefile-2.6 Makefile
 # kernel module(s)
-%build_kernel_modules -m drbd EXTRA_CFLAGS="-DNO_MORE_DEV_FS"
+%build_kernel_modules -m drbd
 %endif
 
 %install
@@ -132,15 +143,15 @@ install -d $RPM_BUILD_ROOT{/sbin,%{_mandir}/man{5,8},%{_sysconfdir}} \
        $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/ha.d/resource.d}
 
 %if %{with kernel}
-%install_kernel_modules -m drbd/drbd -d misc
+%install_kernel_modules -m drbd/drbd -d block
 %endif
 
 %if %{with userspace}
-install user/{drbdadm,drbdsetup} $RPM_BUILD_ROOT/sbin
-install scripts/drbd.conf $RPM_BUILD_ROOT%{_sysconfdir}
+%{__make} install -C scripts \
+       PREFIX=$RPM_BUILD_ROOT
 install scripts/drbd $RPM_BUILD_ROOT/etc/rc.d/init.d
-
-install scripts/drbddisk $RPM_BUILD_ROOT%{_sysconfdir}/ha.d/resource.d
+rm -rf $RPM_BUILD_ROOT/etc/init.d
+install user/{drbdadm,drbdmeta,drbdsetup} $RPM_BUILD_ROOT/sbin
 
 install documentation/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
 install documentation/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
@@ -155,11 +166,8 @@ rm -rf $RPM_BUILD_ROOT
 %postun -n kernel%{_alt_kernel}-block-drbd
 %depmod %{_kernel_ver}
 
-%post -n kernel%{_alt_kernel}-smp-block-drbd
-%depmod %{_kernel_ver}smp
-
-%postun -n kernel%{_alt_kernel}-smp-block-drbd
-%depmod %{_kernel_ver}smp
+%pre -n drbdsetup
+%groupadd -g 60 haclient
 
 %post -n drbdsetup
 /sbin/chkconfig --add drbd
@@ -171,26 +179,33 @@ if [ "$1" = "0" ]; then
        /sbin/chkconfig --del drbd
 fi
 
+%postun -n drbdsetup
+if [ "$1" = "0" ]; then
+       %groupremove haclient
+fi
+
+
 %if %{with userspace}
 %files -n drbdsetup
 %defattr(644,root,root,755)
-%attr(755,root,root) /sbin/*
+%attr(755,root,root) /sbin/drbdadm
+%attr(2754,root,haclient) /sbin/drbdsetup
+%attr(2754,root,haclient) /sbin/drbdmeta
 %attr(754,root,root) /etc/rc.d/init.d/drbd
 %attr(755,root,root) %{_sysconfdir}/ha.d/resource.d/drbddisk
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/drbd.conf
 %{_mandir}/man[58]/*
+%dir /usr/lib/drbd
+%attr(755,root,root) /usr/lib/drbd/*
+
+%files -n bash-completion-drbd
+%defattr(644,root,root,755)
+/etc/bash_completion.d/drbdadm
 %endif
 
 %if %{with kernel}
 %files -n kernel%{_alt_kernel}-block-drbd
 %defattr(644,root,root,755)
 %doc ChangeLog README
-/lib/modules/%{_kernel_ver}/misc/drbd.ko*
-
-%if %{with smp} && %{with dist_kernel}
-%files -n kernel%{_alt_kernel}-smp-block-drbd
-%defattr(644,root,root,755)
-%doc ChangeLog README
-/lib/modules/%{_kernel_ver}smp/misc/drbd.ko*
-%endif
+/lib/modules/%{_kernel_ver}/block/drbd.ko*
 %endif
This page took 0.09358 seconds and 4 git commands to generate.