]> git.pld-linux.org Git - packages/dragonegg.git/blob - dragonegg.spec
- up to 3.6.2; not ready for either gcc 4.9 nor llvm 3.7
[packages/dragonegg.git] / dragonegg.spec
1 Summary:        DragonEgg - using LLVM as a GCC backend
2 Summary(pl.UTF-8):      DragonEgg - użycie LLVM-a jako backendu GCC
3 Name:           dragonegg
4 Version:        3.6.2
5 Release:        0.1
6 License:        GPL v2+
7 Group:          Development/Tools
8 #Source0Download: http://llvm.org/releases/download.html
9 Source0:        http://llvm.org/releases/%{version}/dragonegg-%{version}.src.tar.xz
10 # Source0-md5:  eda9a683f95e725b8e9a82d32f4a9d09
11 URL:            http://dragonegg.llvm.org/
12 # gcc plugin headers
13 BuildRequires:  gcc >= 6:4.5
14 BuildRequires:  gcc < 6:4.9
15 BuildRequires:  llvm-devel >= 3.5.1
16 BuildRequires:  llvm-devel < 3.7.0
17 Requires:       gcc >= 6:4.5
18 Requires:       llvm >= 3.5.1
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 DragonEgg is a gcc plugin that replaces GCC's optimizers and code
23 generators with those from the LLVM project. It works with gcc-4.5 or
24 newer, can target the x86/x86_64 and ARM processor families, and has
25 been successfully used on the Darwin, FreeBSD, kFreeBSD, Linux and
26 OpenBSD platforms. It fully supports Ada, C, C++ and Fortran. It has
27 partial support for Go, Java, Obj-C and Obj-C++.
28
29 %description -l pl.UTF-8
30 DragonEgg ("smocze jajo") to wtyczka gcc zastępująca optymalizatory i
31 generatory kodu GCC tymi z projektu LLVM. Działa z gcc 4.5 i nowszymi,
32 potrafi generować kod na procesory x86/x86_64 oraz ARM, działa na
33 platformach Darwin, FreeBSD, kFreeBSD, Linux oraz OpenBSD. Obsługuje w
34 pełni języki Ada, C, C++ i Fortran, natomiast częściowo - Go, Java,
35 Obj-C oraz Obj-C++.
36
37 %prep
38 %setup -q -n dragonegg-%{version}.src
39
40 %build
41 CC="%{__cc}" \
42 CFLAGS="%{rpmcflags}" \
43 CXXFLAGS="%{rpmcxxflags}" \
44 CPPFLAGS="%{rpmcppflags}" \
45 LDFLAGS="%{rpmldflags}" \
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_libdir}/dragonegg
51
52 install dragonegg.so $RPM_BUILD_ROOT%{_libdir}/dragonegg
53 cp -p integrated-as.specs $RPM_BUILD_ROOT%{_libdir}/dragonegg
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc README TODO
61 %dir %{_libdir}/dragonegg
62 %attr(755,root,root) %{_libdir}/dragonegg/dragonegg.so
63 %{_libdir}/dragonegg/integrated-as.specs
This page took 0.077186 seconds and 4 git commands to generate.