]> git.pld-linux.org Git - packages/dragonegg.git/blob - dragonegg.spec
- new
[packages/dragonegg.git] / dragonegg.spec
1 Summary:        DragonEgg - using LLVM as a GCC backend
2 Summary(pl.UTF-8):      DragonEgg - użycie LLVM-a jako backendu GCC
3 Name:           dragonegg
4 Version:        3.5.0
5 Release:        1
6 License:        GPL v2+
7 Group:          Development/Tools
8 Source0:        http://llvm.org/releases/%{version}/dragonegg-%{version}.src.tar.xz
9 # Source0-md5:  3689aab1f1bb79a07e19cc2ac85d91cb
10 URL:            http://dragonegg.llvm.org/
11 # gcc plugin headers
12 BuildRequires:  gcc >= 6:4.5
13 BuildRequires:  llvm-devel >= 3.5.0
14 Requires:       gcc >= 6:4.5
15 Requires:       llvm >= 3.5.0
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 DragonEgg is a gcc plugin that replaces GCC's optimizers and code
20 generators with those from the LLVM project. It works with gcc-4.5 or
21 newer, can target the x86/x86_64 and ARM processor families, and has
22 been successfully used on the Darwin, FreeBSD, kFreeBSD, Linux and
23 OpenBSD platforms. It fully supports Ada, C, C++ and Fortran. It has
24 partial support for Go, Java, Obj-C and Obj-C++.
25
26 %description -l pl.UTF-8
27 DragonEgg ("smocze jajo") to wtyczka gcc zastępująca optymalizatory i
28 generatory kodu GCC tymi z projektu LLVM. Działa z gcc 4.5 i nowszymi,
29 potrafi generować kod na procesory x86/x86_64 oraz ARM, działa na
30 platformach Darwin, FreeBSD, kFreeBSD, Linux oraz OpenBSD. Obsługuje w
31 pełni języki Ada, C, C++ i Fortran, natomiast częściowo - Go, Java,
32 Obj-C oraz Obj-C++.
33
34 %prep
35 %setup -q -n dragonegg-%{version}.src
36
37 %build
38 CC="%{__cc}" \
39 CFLAGS="%{rpmcflags}" \
40 CXXFLAGS="%{rpmcxxflags}" \
41 CPPFLAGS="%{rpmcppflags}" \
42 LDFLAGS="%{rpmldflags}" \
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_libdir}/dragonegg
48
49 install dragonegg.so $RPM_BUILD_ROOT%{_libdir}/dragonegg
50 cp -p integrated-as.specs $RPM_BUILD_ROOT%{_libdir}/dragonegg
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README TODO
58 %dir %{_libdir}/dragonegg
59 %attr(755,root,root) %{_libdir}/dragonegg/dragonegg.so
60 %{_libdir}/dragonegg/integrated-as.specs
This page took 0.056664 seconds and 4 git commands to generate.