]> git.pld-linux.org Git - packages/dragonegg.git/blob - dragonegg.spec
- up to 3.6.0, but doesn't even build with llvm 3.6.0, regardless of gcc version
[packages/dragonegg.git] / dragonegg.spec
1 Summary:        DragonEgg - using LLVM as a GCC backend
2 Summary(pl.UTF-8):      DragonEgg - użycie LLVM-a jako backendu GCC
3 Name:           dragonegg
4 Version:        3.6.0
5 Release:        0.1
6 License:        GPL v2+
7 Group:          Development/Tools
8 #Source0Download: http://llvm.org/releases/download.html
9 Source0:        http://llvm.org/releases/%{version}/dragonegg-%{version}.src.tar.xz
10 # Source0-md5:  bcc695c9515353a0a91f27b496bc2047
11 URL:            http://dragonegg.llvm.org/
12 # gcc plugin headers
13 BuildRequires:  gcc >= 6:4.5
14 BuildRequires:  gcc < 6:4.9
15 BuildRequires:  llvm-devel >= 3.5.1
16 # FIXME: https://llvm.org/bugs/show_bug.cgi?id=22925
17 BuildRequires:  llvm-devel < 3.6.0
18 Requires:       gcc >= 6:4.5
19 Requires:       llvm >= 3.5.1
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 DragonEgg is a gcc plugin that replaces GCC's optimizers and code
24 generators with those from the LLVM project. It works with gcc-4.5 or
25 newer, can target the x86/x86_64 and ARM processor families, and has
26 been successfully used on the Darwin, FreeBSD, kFreeBSD, Linux and
27 OpenBSD platforms. It fully supports Ada, C, C++ and Fortran. It has
28 partial support for Go, Java, Obj-C and Obj-C++.
29
30 %description -l pl.UTF-8
31 DragonEgg ("smocze jajo") to wtyczka gcc zastępująca optymalizatory i
32 generatory kodu GCC tymi z projektu LLVM. Działa z gcc 4.5 i nowszymi,
33 potrafi generować kod na procesory x86/x86_64 oraz ARM, działa na
34 platformach Darwin, FreeBSD, kFreeBSD, Linux oraz OpenBSD. Obsługuje w
35 pełni języki Ada, C, C++ i Fortran, natomiast częściowo - Go, Java,
36 Obj-C oraz Obj-C++.
37
38 %prep
39 %setup -q -n dragonegg-%{version}.src
40
41 %build
42 CC="%{__cc}" \
43 CFLAGS="%{rpmcflags}" \
44 CXXFLAGS="%{rpmcxxflags}" \
45 CPPFLAGS="%{rpmcppflags}" \
46 LDFLAGS="%{rpmldflags}" \
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_libdir}/dragonegg
52
53 install dragonegg.so $RPM_BUILD_ROOT%{_libdir}/dragonegg
54 cp -p integrated-as.specs $RPM_BUILD_ROOT%{_libdir}/dragonegg
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README TODO
62 %dir %{_libdir}/dragonegg
63 %attr(755,root,root) %{_libdir}/dragonegg/dragonegg.so
64 %{_libdir}/dragonegg/integrated-as.specs
This page took 0.063214 seconds and 3 git commands to generate.