]> git.pld-linux.org Git - packages/dpx.git/blob - dpx.spec
- unconditional noarch subpackages
[packages/dpx.git] / dpx.spec
1 %define rel     4
2 %define subver  svn4
3 Summary:        SMPTE DPX v2 Image Format reader/writer library
4 Summary(pl.UTF-8):      Biblioteka do odczytu/zapisu obrazów w formacie SMPTE DPX v2
5 Name:           dpx
6 Version:        0.5
7 Release:        0.%{subver}.%{rel}
8 License:        BSD
9 Group:          Libraries
10 # svn checkout http://dpx.googlecode.com/svn/trunk/ dpx
11 Source0:        %{name}-%{subver}.tar.xz
12 # Source0-md5:  a6bf177cb29eaaefb5208f3dcf486658
13 Patch0:         %{name}-shared.patch
14 URL:            http://code.google.com/p/dpx/
15 BuildRequires:  autoconf >= 2.61
16 BuildRequires:  automake
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtiff-devel
19 BuildRequires:  libtool >= 2:1.5
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 SMPTE DPX v2 Image Format reader/writer library written in portable
26 C++.
27
28 %description -l pl.UTF-8
29 Biblioteka do odczytu/zapisu obrazów w formacie SMPTE DPX v2, napisana
30 w przenośnym C++.
31
32 %package devel
33 Summary:        Header files for DPX library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki DPX
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libstdc++-devel
38
39 %description devel
40 Header files for DPX library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki DPX.
44
45 %package static
46 Summary:        Static DPX library
47 Summary(pl.UTF-8):      Statyczna biblioteka DPX
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static DPX library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka DPX.
56
57 %package apidocs
58 Summary:        DPX API documentation
59 Summary(pl.UTF-8):      Dokumentacja API biblioteki DPX
60 Group:          Documentation
61 %if "%{_rpmversion}" >= "5"
62 BuildArch:      noarch
63 %endif
64
65 %description apidocs
66 API and internal documentation for DPX library.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API biblioteki DPX.
70
71 %prep
72 %setup -q -n %{name}
73 %patch0 -p1
74
75 %build
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoconf}
79 %{__automake}
80 %configure \
81         --enable-shared
82
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS COPYING NEWS README
100 %attr(755,root,root) %{_bindir}/dpx2tiff
101 %attr(755,root,root) %{_bindir}/dpxheader
102 %attr(755,root,root) %{_libdir}/libdpx.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libdpx.so.0
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libdpx.so
108 %{_libdir}/libdpx.la
109 %{_includedir}/DPX*.h
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libdpx.a
114
115 %files apidocs
116 %defattr(644,root,root,755)
117 %doc doc/html/*.{css,html,png}
This page took 0.044389 seconds and 3 git commands to generate.