]> git.pld-linux.org Git - packages/doxygen.git/blob - doxygen.spec
- allow building without doc
[packages/doxygen.git] / doxygen.spec
1 #
2 # Conditional build:
3 %bcond_without  qt      # without doxywizard (qt-based)
4 #
5 Summary:        Doxygen is the documentation system for C/C++
6 Summary(es.UTF-8):      Doxygen es el sistema de documentación para C/C++
7 Summary(pl.UTF-8):      System dokumentowania dla C/C++
8 Summary(pt_BR.UTF-8):   Um sistema de documentação para C/C++
9 Summary(ru.UTF-8):      Система документирования для C та C++
10 Summary(uk.UTF-8):      Система документування для C та C++
11 Name:           doxygen
12 Version:        1.8.8
13 Release:        2
14 Epoch:          1
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
18 # Source0-md5:  0cbe6912fcac302a984bfcfb9231fec9
19 Patch0:         %{name}-qt-dirs.patch
20 URL:            http://www.doxygen.org/
21 %{?with_qt:BuildRequires:       QtGui-devel >= 4.3}
22 %{?with_qt:BuildRequires:       QtXml-devel >= 4.3}
23 BuildRequires:  bison
24 BuildRequires:  flex
25 BuildRequires:  ghostscript
26 BuildRequires:  ghostscript-fonts-std
27 BuildRequires:  libpng-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  perl-base
30 %{?with_qt:BuildRequires:       qt4-build >= 4.3}
31 %{?with_qt:BuildRequires:       qt4-qmake >= 4.3}
32 BuildRequires:  texlive-latex
33 BuildRequires:  texlive-pdftex
34 # I don't know what is the exact names in TI, please correct
35 %if "%{pld_release}" == "th"
36 Suggests:       texlive-fonts-larm
37 Suggests:       texlive-latex-cyrillic
38 Suggests:       texlive-latex-extend
39 Suggests:       texlive-latex-wasysym
40 Suggests:       texlive-makeindex
41 %endif
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 # because of qt
45 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
46
47 %description
48 Doxygen is a documentation system for C, C++ and IDL. It can generate
49 an on-line class browser (in HTML) and/or an off-line reference manual
50 (in LaTeX) from a set of documented source files. There is also
51 support for generating man pages and for converting the generated
52 output into Postscript, hyperlinked PDF or compressed HTML. The
53 documentation is extracted directly from the sources.
54
55 Doxygen can also be configured to extract the code-structure from
56 undocumented source files. This can be very useful to quickly find
57 your way in large source distributions.
58
59 %description -l es.UTF-8
60 Doxygen es un sistema de documentación para C, C++ e IDL. Es capaz de
61 generar un navegador on-line entre clases (en HTML) y-o un manual
62 off-line de referencia (en LaTeX) a partir de un conjunto de ficheros
63 de código fuente documentados. También hay soporte para generar
64 páginas man y para convertir la generada salida an Postscript, PDF con
65 hiperenlaces o HTML comprimido. La documentación se extrae
66 directamente de los fuentes.
67
68 Doxygen puede también ser configurado a extraer la estructura del
69 código de código fuente que carece de documentación. Eso puede ser muy
70 útil para orientarse rápidamente en distribuciones grandes de código
71 fuente.
72
73 %description -l pl.UTF-8
74 Doxygen to system dokumentowania dla C, C++ i IDL. Może generować
75 dokumentację klas on-line (w HTML-u) lub podręcznik off-line (w
76 LaTeXu) z zestawu udokumentowanych plików źródłowych. Ma także
77 możliwość generowania stron man i konwersji na Postscript, PDF z
78 hiperłączami oraz skompresowany HTML. Dokumentacja jest wyciągana
79 bezpośrednio ze źródeł.
80
81 Doxygen może być skonfigurowany także do wyciągania struktury kodu z
82 nieudokumentowanych plików źródłowych. Może być to przydatne do
83 szybkiego odnalezienia się w dużych źródłach.
84
85 %description -l pt_BR.UTF-8
86 Doxygen é uma sistema de documentação para C e C++ que gera um class
87 browser on-line (em HTML) e/ou um manual de referencia off-line (em
88 LaTeX) a partir de um conjunto de fontes documentados. A documentação
89 é extraida diretamente a partir dos fontes.
90
91 %description -l ru.UTF-8
92 Doxygen - это система документирования для C, C++ и IDL. Она может
93 создать онлайновый броузер классов (в HTML) и/или оффлайновый
94 справочник (в LaTeX) из набора документированных файлов. Есть также
95 поддержка создания man-страниц и конвертации сгенерированного вывода в
96 Postscript, PDF с гиперссылками и компрессированный HTML. Документация
97 извлекается непосредственно из исходных файлов.
98
99 Doxygen можно также сконфигурировать для получения структуры кода из
100 нелокументированных исходных файлов. Это может быть очень полезным для
101 того, чтобы бысто разобраться в большом проекте.
102
103 %description -l uk.UTF-8
104 Doxygen - це система документування для C, C++ та IDL. Вона може
105 створити онлайновий броузер класів (в HTML) та/чи оффлайновий довідник
106 (в LaTeX) з набору документованих вихідних файлів. Є також підтримка
107 для створення man-сторінок та конвертації згенерованого виводу в
108 Postscript, PDF з гіперлінками та компресований HTML. Документація
109 видобувається безпосердньо з вихідних файлів.
110
111 Doxygen можна також зконфігурувати для отримання структури коду з
112 недокументованих вихідних файлів. Це може бути дуже корисним для того,
113 щоб швидко розібратися у великому проекті.
114
115 %package doxywizard
116 Summary:        A GUI front-end for creating and editing configuration files
117 Summary(es.UTF-8):      Un front-end GUI para crear y editar ficheros de configuración
118 Summary(pl.UTF-8):      GUI do tworzenia i edycji plików konfiguracyjnych
119 Summary(pt_BR.UTF-8):   Wizard gráfico para o Doxygen
120 Group:          X11/Applications
121 Requires:       %{name} = %{epoch}:%{version}-%{release}
122
123 %description doxywizard
124 Doxywizard is a GUI front-end for creating and editing configuration
125 files that are used by doxygen.
126
127 %description doxywizard -l es.UTF-8
128 Doxywizard es un front-end GUI para crear y editar los ficheros de
129 configuración que son usados por doxygen.
130
131 %description doxywizard -l pl.UTF-8
132 Doxywizard to frontend z graficznym interfejsem do tworzenia i edycji
133 plików konfiguracyjnych używanych przez doxygen.
134
135 %description doxywizard -l pt_BR.UTF-8
136 Wizard gráfico para o Doxygen.
137
138 %prep
139 %setup -q
140 %patch0 -p1
141
142 %build
143 # don't change it to %%configure, not autoconf-generated!
144 ./configure \
145         --prefix %{_prefix} \
146         --perl %{__perl} \
147         --install %{_bindir}/install \
148         %{?with_qt:--with-doxywizard}
149
150 %{__make} \
151         CC="%{__cc}" \
152         CXX="%{__cxx}" \
153         LINK="%{__cxx}" \
154         QMAKE="%{_bindir}/qmake-qt4" \
155         QTDIR="%{_prefix}" \
156         CFLAGS="%{rpmcflags}" \
157         CXXFLAGS="%{rpmcxxflags} -DQT_LITE_UNICODE -DNODEBUG" \
158         LFLAGS="%{rpmldflags}"
159
160 %{__make} docs
161 #%%{__make} pdf
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %files
173 %defattr(644,root,root,755)
174 %doc html examples README.md
175 %attr(755,root,root) %{_bindir}/doxygen
176 %{_mandir}/man1/doxygen.1*
177
178 %if %{with qt}
179 %files doxywizard
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_bindir}/doxywizard
182 %{_mandir}/man1/doxywizard.1*
183 %endif
This page took 0.063401 seconds and 3 git commands to generate.