]> git.pld-linux.org Git - packages/dovecot-antispam.git/commitdiff
- add branch script
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 4 Aug 2018 20:08:58 +0000 (22:08 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 4 Aug 2018 20:08:58 +0000 (22:08 +0200)
branch.sh [new file with mode: 0755]

diff --git a/branch.sh b/branch.sh
new file mode 100755 (executable)
index 0000000..3cc006c
--- /dev/null
+++ b/branch.sh
@@ -0,0 +1,32 @@
+#!/bin/sh
+set -e
+url=https://git.sipsolutions.net/dovecot-antispam.git/
+package=dovecot-antispam
+tag=v2.0
+branch=master
+out=$package-git.patch
+repo=$package.git
+
+# use filterdiff, etc to exclude bad chunks from diff
+filter() {
+       cat
+}
+
+if [ ! -d $repo ]; then
+       git clone --bare $url -b $branch $repo
+fi
+
+cd $repo
+       git fetch origin +$branch:$branch +refs/tags/$tag:refs/tags/$tag
+       git log -p --reverse $tag..$branch | filter > ../$out.tmp
+cd ..
+
+if cmp -s $out{,.tmp}; then
+       echo >&2 "No new diffs..."
+       rm -f $out.tmp
+       exit 0
+fi
+mv -f $out{.tmp,}
+
+../md5 $package.spec
+../dropin $out
This page took 0.162037 seconds and 4 git commands to generate.