]> git.pld-linux.org Git - packages/dotproject.git/blob - dotproject.spec
- tabs in preamble
[packages/dotproject.git] / dotproject.spec
1 # TODO:
2 # - use system PEAR [ done, needs tests]
3 # - add lang packs from http://sourceforge.net/projects/dotmods/
4 # - check if it works at all...
5 #
6 Summary:        PHP web-based project management framework
7 Summary(pl.UTF-8):      Oparte na PHP i WWW środowisko do zarządzania projektami
8 Name:           dotproject
9 Version:        1.0.1
10 Release:        0.2
11 License:        BSD
12 Group:          Applications/WWW
13 Source0:        http://dl.sourceforge.net/dotproject/%{name}_%{version}.tar.gz
14 # Source0-md5:  7387852573613bb6d4fc4e592b76c69a
15 Patch0:         %{name}-system_PEAR.patch
16 URL:            http://sourceforge.net/projects/dotproject/
17 Requires:       php(gd)
18 Requires:       php(mysql)
19 Requires:       php-pear-Date
20 Requires:       webserver
21 Requires:       webserver(php)
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _phpdir         /usr/share/dotproject
26
27 %description
28 PHP web-based project management framework that includes modules for
29 companies, projects, tasks (with Gantt charts), forums, files,
30 calendar, contacts, tickets/helpdesk, multi-language support,
31 user/module permissions and themes.
32
33 %description -l pl.UTF-8
34 Oparte na PHP i WWW środowisko do zarządzania projektami zawierające
35 moduły dla firm, projektów, zadań (z wykresami Gantta), forum, plików,
36 kalendarza, kontaktów, biletów/helpdesku, obsługę wielu języków,
37 uprawnienia użytkowników do modułów oraz motywy.
38
39 %prep
40 %setup -q -n %{name}
41 %patch0 -p1
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{_phpdir}/{classes,db,files/temp,functions,images,includes,lib,locales,misc,modules,style} \
46         $RPM_BUILD_ROOT%{_sysconfdir}/httpd/%{name}
47
48 install *.php $RPM_BUILD_ROOT%{_phpdir}
49 install classes/* $RPM_BUILD_ROOT%{_phpdir}/classes
50 install functions/* $RPM_BUILD_ROOT%{_phpdir}/functions
51 install includes/* $RPM_BUILD_ROOT%{_phpdir}/includes
52 install locales/*.{php,html} $RPM_BUILD_ROOT%{_phpdir}/locales
53
54 cp -R images/* $RPM_BUILD_ROOT%{_phpdir}/images
55 cp -R lib/* $RPM_BUILD_ROOT%{_phpdir}/lib
56 cp -R misc/* $RPM_BUILD_ROOT%{_phpdir}/misc
57 cp -R modules/* $RPM_BUILD_ROOT%{_phpdir}/modules
58 cp -R style/* $RPM_BUILD_ROOT%{_phpdir}/style
59
60 # Locale:
61 install -d $RPM_BUILD_ROOT%{_phpdir}/locales/en
62 install locales/en/* $RPM_BUILD_ROOT%{_phpdir}/locales/en
63
64 # play with config - it should be writeable and shouldn't be in /usr:
65 rm $RPM_BUILD_ROOT%{_phpdir}/includes/config-dist.php
66 install includes/config-dist.php $RPM_BUILD_ROOT%{_sysconfdir}/httpd/%{name}/config.php
67 ln -s %{_sysconfdir}/httpd/%{name}/config.php $RPM_BUILD_ROOT%{_phpdir}/includes/config.php
68
69 # and remove PEAR's Date class that comes with the archive
70 rm -rf $RPM_BUILD_ROOT%{_phpdir}/lib/PEAR
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 #%triggerpostun  -- %{name} <= %{version}
76 #echo "You have to install %{name}-install package to prepare upgrade!!!"
77 #echo "For upgrade: http://<your.site.address>/<path>/install/upgrade.php"
78
79 %files
80 %defattr(644,root,root,755)
81 %doc ChangeLog docs/* db/*.sql
82 %attr(755,root,http) %dir %{_sysconfdir}/httpd/%{name}
83 %attr(640,root,http) %config(noreplace) %{_sysconfdir}/httpd/%{name}/config.php
84 %attr(750,root,http) %dir %{_phpdir}
85 %attr(640,root,http) %{_phpdir}/*.php
86 %attr(750,root,http) %dir %{_phpdir}/classes
87 %attr(640,root,http) %{_phpdir}/classes/*.php
88 %attr(640,root,http) %{_phpdir}/classes/*.html
89 %attr(750,root,http) %dir %{_phpdir}/functions
90 %attr(640,root,http) %{_phpdir}/functions/*
91 %attr(750,root,http) %dir %{_phpdir}/includes
92 %attr(640,root,http) %{_phpdir}/includes/*
93 %attr(750,root,http) %dir %{_phpdir}/images
94 %attr(640,root,http) %{_phpdir}/images/*.gif
95 %attr(750,root,http) %dir %{_phpdir}/images/icons
96 %attr(640,root,http) %{_phpdir}/images/icons/*.gif
97 %attr(640,root,http) %{_phpdir}/images/icons/*.png
98 %attr(750,root,http) %dir %{_phpdir}/images/obj
99 %attr(640,root,http) %{_phpdir}/images/obj/*.gif
100 %attr(750,root,http) %dir %{_phpdir}/lib
101 %attr(640,root,http) %{_phpdir}/lib/*
102 %attr(750,root,http) %dir %{_phpdir}/misc
103 %attr(640,root,http) %{_phpdir}/misc/*
104 %attr(750,root,http) %dir %{_phpdir}/modules
105 %attr(640,root,http) %{_phpdir}/modules/*
106 %attr(750,root,http) %dir %{_phpdir}/style
107 %attr(640,root,http)  %{_phpdir}/style/*.html
108 %attr(750,root,http) %dir %{_phpdir}/style/classic
109 %attr(750,root,http) %dir %{_phpdir}/style/classic/images
110 %attr(750,root,http) %dir %{_phpdir}/style/default
111 %attr(750,root,http) %dir %{_phpdir}/style/default/images
112 %attr(750,root,http) %dir %{_phpdir}/style/default/images/obj
113 %attr(640,root,http) %{_phpdir}/style/*/*.php
114 %attr(640,root,http) %{_phpdir}/style/*/*.html
115 %attr(640,root,http) %{_phpdir}/style/*/*.css
116 %attr(640,root,http) %{_phpdir}/style/*/images/*.gif
117 %attr(640,root,http) %{_phpdir}/style/*/images/*.html
118 %attr(640,root,http) %{_phpdir}/style/*/images/*.ico
119 %attr(640,root,http) %{_phpdir}/style/*/images/*.jpg
120 %attr(640,root,http) %{_phpdir}/style/*/images/*.png
121 %attr(640,root,http) %{_phpdir}/style/*/images/obj/*
122 %attr(750,root,http) %dir %{_phpdir}/locales
123 %attr(640,root,http) %{_phpdir}/locales/*.php
124 %attr(640,root,http) %{_phpdir}/locales/*.html
125 %attr(750,root,http) %dir %{_phpdir}/locales/en
126 %lang(en) %attr(640,root,http) %{_phpdir}/locales/en/*
127
128 #%lang(pl) %{_phpdir}/language/lang_polish
129 #%lang(pl) %{_phpdir}/templates/subSilver/images/lang_polish
130
131 #%lang(de) %{_phpdir}/language/lang_german
132 #%lang(de) %{_phpdir}/templates/subSilver/images/lang_german
133
134 #%lang(fr) %{_phpdir}/language/lang_french
135 #%lang(fr) %{_phpdir}/templates/subSilver/images/lang_french
This page took 0.061542 seconds and 3 git commands to generate.