]> git.pld-linux.org Git - packages/dotproject.git/blame - dotproject.spec
- tabs in preamble
[packages/dotproject.git] / dotproject.spec
CommitLineData
53ebf38a 1# TODO:
76873396 2# - use system PEAR [ done, needs tests]
53ebf38a
PG
3# - add lang packs from http://sourceforge.net/projects/dotmods/
4# - check if it works at all...
5#
6Summary: PHP web-based project management framework
4f02ac0b 7Summary(pl.UTF-8): Oparte na PHP i WWW środowisko do zarządzania projektami
53ebf38a
PG
8Name: dotproject
9Version: 1.0.1
11a95b36 10Release: 0.2
53ebf38a
PG
11License: BSD
12Group: Applications/WWW
13Source0: http://dl.sourceforge.net/dotproject/%{name}_%{version}.tar.gz
14# Source0-md5: 7387852573613bb6d4fc4e592b76c69a
76873396 15Patch0: %{name}-system_PEAR.patch
53ebf38a 16URL: http://sourceforge.net/projects/dotproject/
11a95b36
ER
17Requires: php(gd)
18Requires: php(mysql)
76873396 19Requires: php-pear-Date
53ebf38a 20Requires: webserver
11a95b36 21Requires: webserver(php)
53ebf38a
PG
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define _phpdir /usr/share/dotproject
26
27%description
28PHP web-based project management framework that includes modules for
29companies, projects, tasks (with Gantt charts), forums, files,
30calendar, contacts, tickets/helpdesk, multi-language support,
3f992287
JB
31user/module permissions and themes.
32
314c0024
JR
33%description -l pl.UTF-8
34Oparte na PHP i WWW środowisko do zarządzania projektami zawierające
35moduły dla firm, projektów, zadań (z wykresami Gantta), forum, plików,
36kalendarza, kontaktów, biletów/helpdesku, obsługę wielu języków,
37uprawnienia użytkowników do modułów oraz motywy.
53ebf38a
PG
38
39%prep
40%setup -q -n %{name}
76873396 41%patch0 -p1
53ebf38a
PG
42
43%install
44rm -rf $RPM_BUILD_ROOT
45install -d $RPM_BUILD_ROOT%{_phpdir}/{classes,db,files/temp,functions,images,includes,lib,locales,misc,modules,style} \
46 $RPM_BUILD_ROOT%{_sysconfdir}/httpd/%{name}
47
48install *.php $RPM_BUILD_ROOT%{_phpdir}
49install classes/* $RPM_BUILD_ROOT%{_phpdir}/classes
50install functions/* $RPM_BUILD_ROOT%{_phpdir}/functions
51install includes/* $RPM_BUILD_ROOT%{_phpdir}/includes
52install locales/*.{php,html} $RPM_BUILD_ROOT%{_phpdir}/locales
53
54cp -R images/* $RPM_BUILD_ROOT%{_phpdir}/images
55cp -R lib/* $RPM_BUILD_ROOT%{_phpdir}/lib
56cp -R misc/* $RPM_BUILD_ROOT%{_phpdir}/misc
57cp -R modules/* $RPM_BUILD_ROOT%{_phpdir}/modules
58cp -R style/* $RPM_BUILD_ROOT%{_phpdir}/style
59
60# Locale:
61install -d $RPM_BUILD_ROOT%{_phpdir}/locales/en
62install locales/en/* $RPM_BUILD_ROOT%{_phpdir}/locales/en
63
64# play with config - it should be writeable and shouldn't be in /usr:
65rm $RPM_BUILD_ROOT%{_phpdir}/includes/config-dist.php
66install includes/config-dist.php $RPM_BUILD_ROOT%{_sysconfdir}/httpd/%{name}/config.php
67ln -s %{_sysconfdir}/httpd/%{name}/config.php $RPM_BUILD_ROOT%{_phpdir}/includes/config.php
68
76873396
AG
69# and remove PEAR's Date class that comes with the archive
70rm -rf $RPM_BUILD_ROOT%{_phpdir}/lib/PEAR
71
53ebf38a
PG
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75#%triggerpostun -- %{name} <= %{version}
76#echo "You have to install %{name}-install package to prepare upgrade!!!"
77#echo "For upgrade: http://<your.site.address>/<path>/install/upgrade.php"
78
79%files
80%defattr(644,root,root,755)
81%doc ChangeLog docs/* db/*.sql
82%attr(755,root,http) %dir %{_sysconfdir}/httpd/%{name}
83%attr(640,root,http) %config(noreplace) %{_sysconfdir}/httpd/%{name}/config.php
84%attr(750,root,http) %dir %{_phpdir}
85%attr(640,root,http) %{_phpdir}/*.php
86%attr(750,root,http) %dir %{_phpdir}/classes
87%attr(640,root,http) %{_phpdir}/classes/*.php
88%attr(640,root,http) %{_phpdir}/classes/*.html
89%attr(750,root,http) %dir %{_phpdir}/functions
90%attr(640,root,http) %{_phpdir}/functions/*
91%attr(750,root,http) %dir %{_phpdir}/includes
92%attr(640,root,http) %{_phpdir}/includes/*
93%attr(750,root,http) %dir %{_phpdir}/images
94%attr(640,root,http) %{_phpdir}/images/*.gif
95%attr(750,root,http) %dir %{_phpdir}/images/icons
96%attr(640,root,http) %{_phpdir}/images/icons/*.gif
97%attr(640,root,http) %{_phpdir}/images/icons/*.png
98%attr(750,root,http) %dir %{_phpdir}/images/obj
99%attr(640,root,http) %{_phpdir}/images/obj/*.gif
100%attr(750,root,http) %dir %{_phpdir}/lib
101%attr(640,root,http) %{_phpdir}/lib/*
102%attr(750,root,http) %dir %{_phpdir}/misc
103%attr(640,root,http) %{_phpdir}/misc/*
104%attr(750,root,http) %dir %{_phpdir}/modules
105%attr(640,root,http) %{_phpdir}/modules/*
106%attr(750,root,http) %dir %{_phpdir}/style
107%attr(640,root,http) %{_phpdir}/style/*.html
108%attr(750,root,http) %dir %{_phpdir}/style/classic
109%attr(750,root,http) %dir %{_phpdir}/style/classic/images
110%attr(750,root,http) %dir %{_phpdir}/style/default
111%attr(750,root,http) %dir %{_phpdir}/style/default/images
112%attr(750,root,http) %dir %{_phpdir}/style/default/images/obj
113%attr(640,root,http) %{_phpdir}/style/*/*.php
114%attr(640,root,http) %{_phpdir}/style/*/*.html
115%attr(640,root,http) %{_phpdir}/style/*/*.css
116%attr(640,root,http) %{_phpdir}/style/*/images/*.gif
117%attr(640,root,http) %{_phpdir}/style/*/images/*.html
118%attr(640,root,http) %{_phpdir}/style/*/images/*.ico
119%attr(640,root,http) %{_phpdir}/style/*/images/*.jpg
120%attr(640,root,http) %{_phpdir}/style/*/images/*.png
121%attr(640,root,http) %{_phpdir}/style/*/images/obj/*
122%attr(750,root,http) %dir %{_phpdir}/locales
123%attr(640,root,http) %{_phpdir}/locales/*.php
124%attr(640,root,http) %{_phpdir}/locales/*.html
125%attr(750,root,http) %dir %{_phpdir}/locales/en
126%lang(en) %attr(640,root,http) %{_phpdir}/locales/en/*
127
128#%lang(pl) %{_phpdir}/language/lang_polish
129#%lang(pl) %{_phpdir}/templates/subSilver/images/lang_polish
130
131#%lang(de) %{_phpdir}/language/lang_german
132#%lang(de) %{_phpdir}/templates/subSilver/images/lang_german
133
134#%lang(fr) %{_phpdir}/language/lang_french
135#%lang(fr) %{_phpdir}/templates/subSilver/images/lang_french
This page took 0.088821 seconds and 4 git commands to generate.