]> git.pld-linux.org Git - packages/dotnet-tao.git/blob - dotnet-tao.spec
- auto mono prov/req
[packages/dotnet-tao.git] / dotnet-tao.spec
1 %include        /usr/lib/rpm/macros.mono
2 Summary:        Tao Framework
3 Summary(pl):    Framework Tao
4 Name:           tao
5 Version:        20050606
6 Release:        1
7 License:        MIT
8 Group:          Libraries
9 Source0:        %{name}-%{version}.tar.bz2
10 # Source0-md5:  170e143b8035644eb3c24db4cc7a2c3b
11 URL:            http://www.mono-project.com/Tao
12 BuildRequires:  mono >= 1.1.0
13 BuildRequires:  rpm-build >= 4.4.2-0.3
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The Tao Framework for .NET is a collection of bindings to facilitate
18 cross-platform game-related development utilizing the .NET platform.
19
20 Currently included bindings are OpenGL 1.5, GLU 1.3, GLUT 3.7.6, WGL,
21 various GL and WGL-related extensions, OpenAL 1.0, Cg 1.2.1, DevIL
22 1.6.6, SDL 1.2.7, and GLFW 2.4.2 (and some others).
23
24 These bindings all function in a cross-platform and cross-runtime
25 manner using Microsoft's .NET 1.0 and 1.1 runtimes on Windows and the
26 Mono runtime on Windows and Linux. Other platforms and runtimes have
27 not been tested, but, would most likely work with a minimal amount of
28 changes.
29
30 The bindings are also CLS-compliant, meaning that they can be used by
31 any .NET language, including C# and Visual Basic .NET, amongst others.
32
33 %description -l pl
34 Framework Tao dla .NET jest kolekcj± wi±zañ umo¿liwiaj±c±
35 miêdzyplatformowe tworzenie gier opartych na platformie .NET.
36
37 Aktualnie zawarte s± wi±zania do OpenGL 2.0, GLU 1.3, GLUT 3.7.6, WGL,
38 ró¿nych rozszerzeñ GL i WGL, OpenAL 1.0, Cg 1.2.1, DevIL 1.6.6, SDL
39 1.2.7 i GLFW 2.4.2 (i kilku innych).
40
41 Wszystkie te wi±zania zdatne s± do u¿ytku na wielu platformach
42 sprzêtowych i w wielu ¶rodowiskach uruchomieniowych. Obs³ugiwane jest
43 microsoftowe .NET 1.0 i 1.1 pod Windowsami oraz Mono pod Windowsami i
44 Linuksem. Inne platformy i ¶rodowiska nie zosta³y przetestowane, lecz
45 prawdopodobnie równie¿ bêd± dzia³aæ z minimaln± ilo¶ci± zmian.
46
47 Wi±zania s± równie¿ zgodne z CLS, co znaczy, ¿e mog± byæ u¿ywane przez
48 ró¿norakie jêzyki .NET, po¶ród nich na przyk³ad C# i Visual Basic
49 .NET.
50
51 %package examples
52 Summary:        Tao example programs
53 Summary(pl):    Przyk³adowe programy Tao
54 Group:          Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description examples
58 Tao example programs.
59
60 %description examples -l pl
61 Przyk³adowe programy Tao.
62
63 %prep
64 %setup -q
65
66 %build
67 %{__make} mono-1.1
68 %{__make} -C src \
69         STRONG=1
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/tao}
74
75 for i in dist/bin/*.dll
76 do
77         gacutil -root $RPM_BUILD_ROOT%{_libdir} -package tao -i $i
78 done
79
80 cp -Rf examples/* $RPM_BUILD_ROOT%{_examplesdir}/tao
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc README.txt src/Tao.*/Tao.*.Readme.txt
88 %attr(755,root,root) %{_libdir}/mono/gac/*/*/*.dll
89 %{_libdir}/mono/gac/*/*/*.config
90 %{_libdir}/mono/tao
91
92 %files examples
93 %defattr(644,root,root,755)
94 %{_examplesdir}/tao
This page took 0.083132 seconds and 3 git commands to generate.