]> git.pld-linux.org Git - packages/dotnet-tao.git/blob - dotnet-tao.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dotnet-tao.git] / dotnet-tao.spec
1 %include        /usr/lib/rpm/macros.mono
2 Summary:        Tao Framework
3 Summary(pl.UTF-8):      Framework Tao
4 Name:           dotnet-tao
5 Version:        20050606
6 Release:        1
7 License:        MIT
8 Group:          Libraries
9 Source0:        tao-%{version}.tar.bz2
10 # Source0-md5:  170e143b8035644eb3c24db4cc7a2c3b
11 URL:            http://www.mono-project.com/Tao
12 BuildRequires:  mono >= 1.1.7
13 BuildRequires:  rpmbuild(monoautodeps)
14 Requires:       mono >= 1.1.7
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 The Tao Framework for .NET is a collection of bindings to facilitate
19 cross-platform game-related development utilizing the .NET platform.
20
21 Currently included bindings are OpenGL 1.5, GLU 1.3, GLUT 3.7.6, WGL,
22 various GL and WGL-related extensions, OpenAL 1.0, Cg 1.2.1, DevIL
23 1.6.6, SDL 1.2.7, and GLFW 2.4.2 (and some others).
24
25 These bindings all function in a cross-platform and cross-runtime
26 manner using Microsoft's .NET 1.0 and 1.1 runtimes on Windows and the
27 Mono runtime on Windows and Linux. Other platforms and runtimes have
28 not been tested, but, would most likely work with a minimal amount of
29 changes.
30
31 The bindings are also CLS-compliant, meaning that they can be used by
32 any .NET language, including C# and Visual Basic .NET, amongst others.
33
34 %description -l pl.UTF-8
35 Framework Tao dla .NET jest kolekcją wiązań umożliwiającą
36 międzyplatformowe tworzenie gier opartych na platformie .NET.
37
38 Aktualnie zawarte są wiązania do OpenGL 2.0, GLU 1.3, GLUT 3.7.6, WGL,
39 różnych rozszerzeń GL i WGL, OpenAL 1.0, Cg 1.2.1, DevIL 1.6.6, SDL
40 1.2.7 i GLFW 2.4.2 (i kilku innych).
41
42 Wszystkie te wiązania zdatne są do użytku na wielu platformach
43 sprzętowych i w wielu środowiskach uruchomieniowych. Obsługiwane jest
44 microsoftowe .NET 1.0 i 1.1 pod Windows oraz Mono pod Windows i
45 Linuksem. Inne platformy i środowiska nie zostały przetestowane, lecz
46 prawdopodobnie również będą działać z minimalną ilością zmian.
47
48 Wiązania są również zgodne z CLS, co znaczy, że mogą być używane przez
49 różnorakie języki .NET, pośród nich na przykład C# i Visual Basic
50 .NET.
51
52 %package examples
53 Summary:        Tao example programs
54 Summary(pl.UTF-8):      Przykładowe programy Tao
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description examples
59 Tao example programs.
60
61 %description examples -l pl.UTF-8
62 Przykładowe programy Tao.
63
64 %prep
65 %setup -q -n tao-%{version}
66
67 %build
68 %{__make} mono-1.1
69 %{__make} -C src \
70         STRONG=1
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
75
76 for i in dist/bin/*.dll
77 do
78         gacutil -root $RPM_BUILD_ROOT%{_prefix}/lib -package tao -i $i
79 done
80
81 cp -Rf examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc README.txt src/Tao.*/Tao.*.Readme.txt
89 %attr(755,root,root) %{_prefix}/lib/mono/gac/*/*/*.dll
90 %{_prefix}/lib/mono/gac/*/*/*.config
91 %{_prefix}/lib/mono/tao
92
93 %files examples
94 %defattr(644,root,root,755)
95 %{_examplesdir}/%{name}-%{version}
This page took 0.055644 seconds and 3 git commands to generate.