]> git.pld-linux.org Git - packages/dosemu.git/commitdiff
- patchset 15
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 18 May 2003 15:49:10 +0000 (15:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed obsolete nox patch, updated make-new,man-pages patches
- added gcc33 patch (for ELF detection in gcc 3.3's specs)
- moved mkfatimage16(1) manual to proper package

Changed files:
    dosemu-gcc33.patch -> 1.1
    dosemu-make-new.patch -> 1.5
    dosemu-man-pages.patch -> 1.5
    dosemu-nox.patch -> 1.2
    dosemu.spec -> 1.88

dosemu-gcc33.patch [new file with mode: 0644]
dosemu-make-new.patch
dosemu-man-pages.patch
dosemu-nox.patch [deleted file]
dosemu.spec

diff --git a/dosemu-gcc33.patch b/dosemu-gcc33.patch
new file mode 100644 (file)
index 0000000..1e9f8b8
--- /dev/null
@@ -0,0 +1,11 @@
+--- dosemu-1.1.4/configure.ac.orig     2003-05-18 01:17:04.000000000 +0200
++++ dosemu-1.1.4/configure.ac  2003-05-18 01:20:19.000000000 +0200
+@@ -138,7 +138,7 @@
+    AC_MSG_WARN( )
+    ELF="ELF=1"
+  else
+-   if grep __ELF__ `$CC -v 2>&1|head -n1|cut -d' ' -f4` /dev/null 1>/dev/null 2>&1; then 
++   if grep '__ELF__\|elf_' `$CC -v 2>&1|head -n1|cut -d' ' -f4` /dev/null 1>/dev/null 2>&1; then 
+     ELF="ELF=1"
+    else
+      if test "$CONFIG_HOST" = "linux"; then
index 8dafd56434a788152e4c755fcb43414ac72090d6..6d599cb1cbf3de1b10ce1e6f56cc01942da4b145 100644 (file)
@@ -3,7 +3,7 @@
 @@ -421,15 +421,15 @@
  AC_SUBST(INCDIR)
  
- CFLAGS="-Wall -Wstrict-prototypes -Wmissing-declarations -Wnested-externs -Wpointer-arith"
+ CFLAGS="-Wall -Wstrict-prototypes -Wmissing-declarations -Wnested-externs"
 +OPT="$OPTFLAGS"
  if test "$dodebug" = "yes"; then
    CFLAGS="$CFLAGS -gstabs+"
 -     OPT="$OPT -malign-loops=2 -malign-jumps=2 -malign-functions=2"
 -  fi
 -
-   echo -n "checking for glibc..."
+   AC_MSG_CHECKING(for glibc...)
    set `echo -e '#include <features.h>\nXXAaZZ __GLIBC__ XXBbZZ __GLIBC_MINOR__'|gcc -E -|awk '/XXAaZZ/ {print $2 " " $4}'`
    major=$1; minor=$2
---- dosemu-1.0.1.orig/man/Makefile     Sun Mar  5 13:57:36 2000
-+++ dosemu-1.0.1/man/Makefile  Thu Aug 17 09:57:21 2000
-@@ -7,6 +7,6 @@
- install:
-       @install -d $(INSTROOT)/usr/man/man1; \
--      install *dos*.1 mkfatimage*.1 $(INSTROOT)/usr/man/man1
-+      install *dos*.1 mkfatimage*.1 $(INSTROOT)/usr/share/man/man1
- clean realclean:
 --- dosemu-1.1.4/src/arch/linux/dosext/sound/midid/Makefile.orig       Wed Dec 18 02:36:44 2002
 +++ dosemu-1.1.4/src/arch/linux/dosext/sound/midid/Makefile    Sun Jan 26 00:14:10 2003
 @@ -15,7 +15,7 @@
index e95b627831235fcc9c44da6023ecb1ff606c119a..ffc79ca981c9f2462b6e02288d28a4bd36bd02bc 100644 (file)
@@ -1,10 +1,12 @@
---- dosemu-1.1.4.orig/man/dosdebug.1   Mon Mar 18 11:43:03 1996
-+++ dosemu-1.1.4/man/dosdebug.1        Wed Dec 19 11:52:46 2001
+diff -Nur dosemu-1.1.4/man.orig/dosdebug.1 dosemu-1.1.4/man/dosdebug.1
+--- dosemu-1.1.4/man.orig/dosdebug.1   2002-12-18 02:36:44.000000000 +0100
++++ dosemu-1.1.4/man/dosdebug.1        2003-05-18 11:54:53.000000000 +0200
 @@ -1 +1 @@
 -.so man1/dosemu.bin.1
 +.so dos.1
---- dosemu-1.1.4.orig/man/dosemu.bin.1 Fri Jun  1 01:36:11 2001
-+++ dosemu-1.1.4/man/dosemu.bin.1      Wed Dec 19 11:22:05 2001
+diff -Nur dosemu-1.1.4/man.orig/dosemu.bin.1 dosemu-1.1.4/man/dosemu.bin.1
+--- dosemu-1.1.4/man.orig/dosemu.bin.1 2003-05-18 11:53:55.000000000 +0200
++++ dosemu-1.1.4/man/dosemu.bin.1      2003-05-18 12:02:15.000000000 +0200
 @@ -1,9 +1,9 @@
  .\" -*- nroff -*-  (This is for Emacs)
 -.TH DOSEMU.BIN 1 "Jan, 2003" "Version 1.1.4.1" "DOS Emulation"
  [
  .B \-ABCcdkVNXtsgKm234OU
  ]
-diff -Nru dosemu-1.0.2/man/xdos.1 dosemu-1.0.2.new/man/xdos.1
---- dosemu-1.0.2/man/xdos.1    Fri Jun  1 23:47:21 2001
-+++ dosemu-1.0.2.new/man/xdos.1        Wed Dec 19 11:53:00 2001
+@@ -82,11 +82,8 @@
+ .sp
+ .B dosdebug
+ .SH DESCRIPTION
+-.B dosemu.bin
+-is the binary wrapped by the script
+-.B dosemu
+-(1)
+-which invokes the Linux dos emulator, also known as
++.B dos
++invokes the Linux dos emulator, also known as
+ .BR DOSEMU .
+ .br
+ .I debugfile
+@@ -570,13 +567,12 @@
+ .SH FILES
+ .PD 0
+ .TP
+-.I /usr/local/bin/dosemu.bin
++.I /usr/bin/dos
++or
++.I /usr/X11R6/bin/dos
+ The binary
+ .TP
+-.I /usr/local/bin/dosemu
+-The wrapper script, it is recommended not to invoke dosemu.bin directly.
+-.TP
+-.I /usr/local/bin/xdosemu
++.I /usr/X11R6/bin/xdos
+ Same, but invoking DOS in an X window.
+ .TP
+ .I $HOME/.dosemu
+@@ -673,4 +669,4 @@
+ .SH "SEE ALSO"
+-.BR dosemu "(1), " mkfatimage16 "(1)"
++.BR mkfatimage16 "(1)"
+diff -Nur dosemu-1.1.4/man.orig/mkfatimage16.1 dosemu-1.1.4/man/mkfatimage16.1
+--- dosemu-1.1.4/man.orig/mkfatimage16.1       2002-12-18 02:36:44.000000000 +0100
++++ dosemu-1.1.4/man/mkfatimage16.1    2003-05-18 12:02:34.000000000 +0200
+@@ -127,7 +127,7 @@
+ .B DOSEMU
+ .SH "SEE ALSO"
+-.BR dosemu "(1), " xdosemu "(1), " mtools "(1)"
++.BR dos "(1), " mtools "(1)"
+diff -Nur dosemu-1.1.4/man.orig/ru/dosdebug.1 dosemu-1.1.4/man/ru/dosdebug.1
+--- dosemu-1.1.4/man.orig/ru/dosdebug.1        2003-05-18 11:53:54.000000000 +0200
++++ dosemu-1.1.4/man/ru/dosdebug.1     2003-05-18 12:02:53.000000000 +0200
 @@ -1 +1 @@
 -.so man1/dosemu.bin.1
 +.so dos.1
+diff -Nur dosemu-1.1.4/man.orig/ru/dosemu.bin.1 dosemu-1.1.4/man/ru/dosemu.bin.1
+--- dosemu-1.1.4/man.orig/ru/dosemu.bin.1      2003-05-18 11:53:54.000000000 +0200
++++ dosemu-1.1.4/man/ru/dosemu.bin.1   2003-05-18 12:21:46.000000000 +0200
+@@ -1,9 +1,9 @@
+ .\" -*- nroff -*-  (This is for Emacs)
+-.TH DOSEMU.BIN 1 "ñÎ×ÁÒØ 2003" "÷ÅÒÓÉÑ 1.1.4.1" "üÍÕÌÑÃÉÑ DOS"
++.TH DOS 1 "ñÎ×ÁÒØ 2003" "÷ÅÒÓÉÑ 1.1.4.1" "üÍÕÌÑÃÉÑ DOS"
+ .SH éíñ
+-dosemu.bin, dosdebug \- ÚÁÐÕÓËÁÅÔ DOS É ÐÒÉÌÏÖÅÎÉÑ DOS ÐÏÄ Linux
++dos, xdos, dosdebug \- ÚÁÐÕÓËÁÅÔ DOS É ÐÒÉÌÏÖÅÎÉÑ DOS ÐÏÄ Linux
+ .SH óéîôáëóéó
+-.B dosemu.bin
++.B dos
+ [
+ .B \-ABCcdkVNXtsgKm234OU
+ ]
+@@ -78,11 +78,8 @@
+ .sp
+ .B dosdebug
+ .SH ïðéóáîéå
+-.B dosemu.bin
+-Ñ×ÌÑÅÔÓÑ ÂÉÎÁÒÎÙÍ ÆÁÊÌÏÍ, ËÏÔÏÒÙÊ ÚÁÐÕÓËÁÅÔÓÑ ÓËÒÉÐÔÏÍ
+-.B dosemu
+-(1),
+-ÁËÔÉ×ÉÚÉÒÕÀÝÉÍ ÜÍÕÌÑÔÏÒ DOS ÐÏÄ Linux, ÔÁËÖÅ ÉÚ×ÅÓÔÎÙÊ ËÁË
++.B dos
++ÜÔÏ ÜÍÕÌÑÔÏÒ DOS ÐÏÄ Linux, ÔÁËÖÅ ÉÚ×ÅÓÔÎÙÊ ËÁË
+ .BR DOSEMU .
+ .br
+ .I æÁÊÌ_ÏÔÌÁÄËÉ
+@@ -573,14 +570,12 @@
+ .SH æáêìù
+ .PD 0
+ .TP
+-.I /usr/local/bin/dosemu.bin
++.I /usr/bin/dos
++ÉÌÉ
++.I /usr/X11R6/bin/dos
+ éÓÐÏÌÎÑÅÍÙÊ ÍÏÄÕÌØ
+ .TP
+-.I /usr/local/bin/dosemu
+-ïÂÅÒÔÏÞÎÙÊ ÓËÒÉÐÔ, ÒÅËÏÍÅÎÄÕÅÍÙÊ ÄÌÑ ÚÁÐÕÓËÁ dosemu.bin, ËÏÔÏÒÙÊ ÎÅ ÓÔÏÉÔ
+-ÚÁÐÕÓËÁÔØ ÎÅÐÏÓÒÅÄÓÔ×ÅÎÎÏ.
+-.TP
+-.I /usr/local/bin/xdosemu
++.I /usr/X11R6/bin/xdos
+ ôÏ ÖÅ ÓÁÍÏÅ, ÎÏ ÓÌÕÖÉÔ ÄÌÑ ÚÁÐÕÓËÁ DOS × X window.
+ .TP
+ .I $HOME/.dosemu
+@@ -675,4 +670,4 @@
+ .SH "óíïôòé ôáëöå"
+-.BR dosemu "(1), " mkfatimage16 "(1)"
++.BR mkfatimage16 "(1)"
+diff -Nur dosemu-1.1.4/man.orig/ru/mkfatimage16.1 dosemu-1.1.4/man/ru/mkfatimage16.1
+--- dosemu-1.1.4/man.orig/ru/mkfatimage16.1    2003-05-18 11:53:54.000000000 +0200
++++ dosemu-1.1.4/man/ru/mkfatimage16.1 2003-05-18 12:03:07.000000000 +0200
+@@ -130,7 +130,7 @@
+ .B DOSEMU
+ .SH "óíïôòé ôáëöå"
+-.BR dosemu "(1), " xdosemu "(1), " mtools "(1)"
++.BR dos "(1), " mtools "(1)"
+diff -Nur dosemu-1.1.4/man.orig/ru/xdosemu.1 dosemu-1.1.4/man/ru/xdosemu.1
+--- dosemu-1.1.4/man.orig/ru/xdosemu.1 2003-05-18 11:53:55.000000000 +0200
++++ dosemu-1.1.4/man/ru/xdosemu.1      2003-05-18 12:03:13.000000000 +0200
+@@ -1 +1 @@
+-.so man1/dosemu.1
++.so dos.1
+diff -Nur dosemu-1.1.4/man.orig/xdosemu.1 dosemu-1.1.4/man/xdosemu.1
+--- dosemu-1.1.4/man.orig/xdosemu.1    2003-05-18 11:53:55.000000000 +0200
++++ dosemu-1.1.4/man/xdosemu.1 2003-05-18 12:02:40.000000000 +0200
+@@ -1 +1 @@
+-.so man1/dosemu.1
++.so dos.1
diff --git a/dosemu-nox.patch b/dosemu-nox.patch
deleted file mode 100644 (file)
index 0a2824f..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
---- configure.ac.orig  Sat Feb 15 13:07:06 2003
-+++ configure.ac       Sat Feb 15 13:10:07 2003
-@@ -241,18 +241,19 @@
- )
- AC_PATH_XTRA
--LDFLAGS="$LDFLAGS $X_LIBS"
--CPPFLAGS="$X_CFLAGS"
--AC_CHECK_LIB(X11, XOpenDisplay, , 
-+if test "$no_x" = "yes" ; then
-+    AS_MESSAGE(checking Compiling without X support...)
-+else
-+      LDFLAGS="$LDFLAGS $X_LIBS"
-+      CPPFLAGS="$X_CFLAGS"
-+
-+      AC_CHECK_LIB(X11, XOpenDisplay, , 
-    # sometimes statically linked binaries need libdl too ...
-    AC_CHECK_LIB(X11, XCloseDisplay, LIBS="$LIBS -lX11 -ldl", 
-      AC_CHECK_LIB(Xwindow, main, , no_x="yes" ),
-   -ldl))
--if test "$no_x" = "yes" ; then
--    AS_MESSAGE(checking Compiling without X support...)
--else
-     AS_MESSAGE(checking Compiling with X support...)
-     AC_DEFINE(X_SUPPORT) 
-     X_SUPPORT="X_SUPPORT=1"
-@@ -260,34 +261,35 @@
-     AC_DEFINE(X_GRAPHICS)
-     X_GRAPHICS="X_GRAPHICS=1"
-     AC_SUBST(X_GRAPHICS)
--fi
--
- dnl Check for the MITSHM extention to speed up VGAemu
--AC_ARG_ENABLE(mitshm,
-+      AC_ARG_ENABLE(mitshm,
-               [  --enable-mitshm         force use of MITSHM X extension],
-               [forced_mitshm="yes"],[forced_mitshm="no"])
--AC_ARG_ENABLE(nomitshm,
-+      AC_ARG_ENABLE(nomitshm,
-               [  --enable-nomitshm       do NOT use the MITSHM X extension],
-               [forced_nomitshm="yes"],[forced_nomitshm="no"])
--if test "$forced_mitshm" = "yes" -a "$forced_nomitshm" = "yes" ; then
--  AC_MSG_ERROR(Can't use --enable-mitshm and --enable-nomitshm at the same time)
--fi
-+      if test "$forced_mitshm" = "yes" -a "$forced_nomitshm" = "yes" ; then
-+      AC_MSG_ERROR(Can't use --enable-mitshm and --enable-nomitshm at the same time)
-+      fi
--if test "$forced_nomitshm" != "yes" -a "$no_x" != "yes" ; then
--  AC_CHECK_HEADER(X11/extensions/XShm.h,
-+      if test "$forced_nomitshm" != "yes" -a "$no_x" != "yes" ; then
-+      AC_CHECK_HEADER(X11/extensions/XShm.h,
-          [AC_DEFINE(HAVE_MITSHM,1) LIBS="-lXext $LIBS"],
-          AS_MESSAGE(checking Compiling without the MITSHM X extension),
-          [#include <X11/Xlib.h>])
--fi
-+      fi
--AC_CHECK_HEADER(X11/extensions/xf86vmode.h,
-+      AC_CHECK_HEADER(X11/extensions/xf86vmode.h,
-          [AC_DEFINE(HAVE_XVIDMODE,1) LIBS="-lXxf86vm $LIBS"],
-          AS_MESSAGE(checking Compiling without the XF86 video mode extension),
-          [#include <X11/Xlib.h>])
-+fi
-+
-+
- PACKAGE_VERSION=`cat VERSION`
- VV=$PACKAGE_VERSION
index 8e7c401de9e9f5e61c88a52a61ae87a0ab7de591..03272b2eaec67dee392c8f5e106cc12a246038c9 100644 (file)
@@ -2,9 +2,6 @@
 # Conditional build:
 # _with_static         - linked static
 #
-# TODO: look at commented out patches
-#        documentation build is very very slow, I don't why
-
 Summary:       A DOS emulator
 Summary(de):   DOS-Emulator
 Summary(es):   Emulador DOS
@@ -14,10 +11,10 @@ Summary(pt_BR):     Emulador DOS
 Summary(tr):   DOS öykünümcüsü
 Name:          dosemu
 %define                ver 1.1.4
-%define        subver 13
+%define        subver 15
 Version:       %{ver}.%{subver}
 # Please don't bump to 1 until dosemu-1.2
-Release:       0.2
+Release:       0.3
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://dl.sourceforge.net/dosemu/%{name}-%{ver}.tgz
@@ -32,7 +29,8 @@ Patch1:               %{name}-make-new.patch
 Patch2:                %{name}-%{name}_conf.patch
 Patch3:                %{name}-doSgmlTools.patch
 Patch4:                %{name}-makehtml.patch
-Patch5:                %{name}-nox.patch
+Patch5:                %{name}-gcc33.patch
+#Patch5:               %{name}-nox.patch
 URL:           http://www.dosemu.org/
 BuildRequires: XFree86-devel
 BuildRequires: autoconf >= 2.57
@@ -141,13 +139,12 @@ mkfatimage16.
 %prep
 %setup -q -n %{name}-%{ver} -a1 -a6
 sh tmp/do_patch
-
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p0
+%patch5 -p1
 
 %build
 OPTFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"; export OPTFLAGS
@@ -179,6 +176,9 @@ mv -f bin/dosemu.bin bin/dos-x
 mv -f bin/dos-nox bin/dosemu.bin
 
 mv -f man/dosemu.bin.1 man/dos.1
+mv -f man/xdosemu.1 man/xdos.1
+mv -f man/ru/dosemu.bin.1 man/ru/dos.1
+mv -f man/ru/xdosemu.1 man/ru/xdos.1
 
 # documentation
 %{__make} -C src/doc/DANG html
@@ -190,7 +190,7 @@ find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_xbindir},%{_sysconfdir},%{_pixmapsdir}} \
-       $RPM_BUILD_ROOT{%{_mandir}/man1,%{_mandir}/pl/man1} \
+       $RPM_BUILD_ROOT{%{_mandir}/man1,%{_mandir}/{pl,ru}/man1} \
        $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel} \
        $RPM_BUILD_ROOT%{_applnkdir}/System
 
@@ -212,6 +212,7 @@ install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
 
 install man/{dos.1,dosdebug.1,xdos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
 install pl/man1/{dos.1,dosdebug.1,xdos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
+install man/ru/{dos.1,dosdebug.1,xdos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/ru/man1
 
 install commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
 install commands/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
@@ -219,8 +220,6 @@ cp %{SOURCE3} PRZECZYTAJ_TO
 cp %{SOURCE4} README.PLD
 install %{SOURCE5} $RPM_BUILD_ROOT%{_applnkdir}/System
 
-#ln -sf dosemu/comcom.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/command.com
-
 rm -f doc/{configuration,dosemu.lsm}
 
 %clean
@@ -240,9 +239,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_dosemudir}/bootdir
 %dir %{_dosemudir}/bootdir/dosemu
 %{_dosemudir}/bootdir/dosemu/*
-#%%{_dosemudir}/bootdir/command.com
-%{_mandir}/man1/[dm]*
+%{_mandir}/man1/d*
 %lang(pl) %{_mandir}/pl/man1/d*
+%lang(ru) %{_mandir}/ru/man1/d*
 %{_pixmapsdir}/dosemu.xpm
 
 %files -n xdosemu
@@ -258,11 +257,12 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_dosemudir}/bootdir
 %dir %{_dosemudir}/bootdir/dosemu
 %{_dosemudir}/bootdir/dosemu/*
-#%%{_dosemudir}/bootdir/command.com
-%{_mandir}/man1/[dm]*
+%{_mandir}/man1/d*
 %{_mandir}/man1/xdos.1*
 %lang(pl) %{_mandir}/pl/man1/d*
 %lang(pl) %{_mandir}/pl/man1/xdos.1*
+%lang(ru) %{_mandir}/ru/man1/d*
+%lang(ru) %{_mandir}/ru/man1/xdos.1*
 %{_applnkdir}/System/*
 %{_pixmapsdir}/dosemu.xpm
 
@@ -272,3 +272,5 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/hdinfo
 %attr(755,root,root) %{_bindir}/mkhdimage
 %attr(755,root,root) %{_bindir}/mkfatimage16
+%{_mandir}/man1/mkfatimage16.1*
+%lang(ru) %{_mandir}/ru/man1/mkfatimage16.1*
This page took 0.106191 seconds and 4 git commands to generate.