]> git.pld-linux.org Git - packages/dosemu.git/blobdiff - dosemu.spec
- some installation fixes
[packages/dosemu.git] / dosemu.spec
index da7d0ccba3accc7275fd3578e80677956a3fb548..fb0aefbb4fd551c08677db6bc64e33dc828ddce9 100644 (file)
@@ -1,6 +1,10 @@
+#
 # Conditional build:
-# --with static                - linked static
+# _with_static         - linked static
 #
+# TODO: look at commented out patches
+#        documentation build is very very slow, I don't why
+
 Summary:       A DOS emulator
 Summary(de):   DOS-Emulator
 Summary(es):   Emulador DOS
@@ -9,42 +13,41 @@ Summary(pl): Emulator DOSa
 Summary(pt_BR):        Emulador DOS
 Summary(tr):   DOS öykünümcüsü
 Name:          dosemu
-Version:       1.0.2
-Release:       19
+%define                ver 1.1.4
+%define        subver 13
+Version:       %{ver}.%{subver}
+# Please don't bump to 1 until dosemu-1.2
+Release:       0.2
 License:       GPL v2
 Group:         Applications/Emulators
-Source0:       ftp://ftp.sourceforge.net/pub/sourceforge/dosemu/%{name}-%{version}.tgz
-Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
-Source2:       %{name}-sys.tar.gz
+Source0:       ftp://ftp.sourceforge.net/pub/sourceforge/dosemu/%{name}-%{ver}.tgz
+Source1:       http://dosemu.sourceforge.net/testing/patchset-%{version}.tgz
+#Source2:      %{name}-sys.tar.gz
 Source3:       %{name}-PRZECZYTAJ_TO
 Source4:       %{name}-README.PLD
 Source5:       %{name}.desktop
-Patch0:                ftp://ftp.sourceforge.net/pub/sourceforge/dosemu/patch-1.0.2.1.gz
-Patch1:                %{name}-1.0.2-man-pages.patch
-Patch2:                %{name}-0.98.1-security.patch
-Patch3:                %{name}-make-new.patch
-Patch4:                %{name}-Polish_keyboard.patch
-Patch5:                %{name}-%{name}_conf.patch
-Patch6:                %{name}-alt224.patch
-Patch7:                pmstack.diff
-Patch8:                %{name}-rawkeyboard-console.patch
-Patch9:                %{name}-comcom.patch
-Patch10:       %{name}-global.conf-xdos.patch
-Patch11:       c_run_irqs.diff
+Source6:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
+Patch0:                %{name}-man-pages.patch
+Patch1:                %{name}-parser-buf.patch
+Patch2:                %{name}-make-new.patch
+Patch3:                %{name}-%{name}_conf.patch
+Patch4:                %{name}-doSgmlTools.patch
+Patch5:                %{name}-makehtml.patch
+Patch6:                %{name}-nox.patch
 URL:           http://www.dosemu.org/
 BuildRequires: XFree86-devel
 BuildRequires: autoconf
 BuildRequires: bin86
 BuildRequires: bison
-#BuildRequires:        docbook-dtd-sgml
+BuildRequires: docbook-dtd30-sgml
 BuildRequires: flex
-#BuildRequires:        lynx
-#BuildRequires:        openjade
+BuildRequires: lynx
+BuildRequires: openjade
 BuildRequires: perl
-#BuildRequires:        sgml-tools
+BuildRequires: sgml-tools
 BuildRequires: slang-devel
+BuildRequires: util-linux
 BuildRequires: unzip
-#Requires:     dos
 %{?_with_static:BuildRequires: glibc-static}
 %{?_with_static:BuildRequires: XFree86-static}
 %{?_with_static:BuildRequires: slang-static}
@@ -94,7 +97,6 @@ Summary(tr):  X alt
 Group:         Applications/Emulators
 Provides:      dosemu
 Obsoletes:     dosemu
-#Requires:     dos
 
 %description -n xdosemu
 Xdosemu is a version of the dosemu DOS emulator that runs with the X
@@ -138,56 +140,54 @@ Programy pomocnicze dla dosemu: dexeconfig, hdinfo, mkhdimage,
 mkfatimage16.
 
 %prep
-%setup -q -a1 -a2
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p0
-%patch6 -p1
-%patch7 -p0
-%patch8 -p0
-%patch9 -p1
-%patch10 -p1
-%patch11 -p0
+%setup -q -n %{name}-%{ver} -a1 -a6
+sh tmp/do_patch
+
+#%patch0 -p1
+#%patch1 -p1
+#%patch2 -p1
+#%patch3 -p1
+%patch4        -p1
+%patch5 -p1
+%patch6 -p0
 
 %build
 OPTFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"; export OPTFLAGS
 
-#./mkpluginhooks enable plugin_keyboard off plugin_kbd_unicode on \
-#plugin_extra_charset on plugin_term on plugin_translate on plugin_demo off
 
-cp -f base-configure.in configure.in
+./mkpluginhooks enable plugin_keyboard off plugin_kbd_unicode on \
+plugin_extra_charset on plugin_term on plugin_translate on plugin_demo off
+
+#cp -f base-configure.in configure.in
 %{__autoconf}
 
 # non-X version
-%configure \
+%configure2_13 \
 %{?_with_static:--enable-linkstatic} \
        --enable-new-intcode \
        --enable-aspi \
        --without-x
 
-echo | %{__make}
+%{__make} WAIT=no
 mv -f bin/dosemu.bin bin/dos-nox
 
 # X version
-%configure \
+%configure2_13 \
 %{?_with_static:--enable-linkstatic} \
        --enable-new-intcode \
        --enable-aspi
-echo | %{__make}
+%{__make} WAIT=no
 mv -f bin/dosemu.bin bin/dos-x
 mv -f bin/dos-nox bin/dosemu.bin
 
 mv -f man/dosemu.bin.1 man/dos.1
 
 # documentation
-#%{__make} docs
-#find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
+%{__make} -C src/doc/DANG html
+%{__make} -C src/doc/HOWTO html
+%{__make} -C src/doc/README html
 
-# midid daemon
-%{__make} midid
+find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -196,6 +196,8 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_xbindir},%{_sysconfdir},%{_pixmapsdir}}
        $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel} \
        $RPM_BUILD_ROOT%{_applnkdir}/System
 
+#%{__make} install DESTDIR=$RPM_BUILD_ROOT
+
 install bin/dosemu.bin $RPM_BUILD_ROOT%{_bindir}/dos
 install bin/dos-x $RPM_BUILD_ROOT%{_xbindir}/dos
 install bin/midid $RPM_BUILD_ROOT%{_bindir}/midid
@@ -205,25 +207,22 @@ install bin/dosdebug $RPM_BUILD_ROOT%{_bindir}/dosdebug
 install src/tools/periph/{dexeconfig,hdinfo,mkhdimage,mkfatimage16} $RPM_BUILD_ROOT%{_bindir}
 ln -sf dos $RPM_BUILD_ROOT%{_bindir}/dosexec
 
-install etc/dosemu.xpm $RPM_BUILD_ROOT%{_prefix}/X11R6/share/pixmaps
-install etc/dosemu.users.secure $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
+install etc/dosemu.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
+install etc/dosemu.users.example $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
 install etc/global.conf $RPM_BUILD_ROOT%{_dosemudir}/global.conf
 install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
 
 install man/{dos.1,dosdebug.1,xdos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
 install pl/man1/{dos.1,dosdebug.1,xdos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
 
-install src/plugin/commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
-install dosemu/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
+install commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
+install commands/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
 cp %{SOURCE3} PRZECZYTAJ_TO
 cp %{SOURCE4} README.PLD
-install %{SOURCE5} $RPM_BUILD_ROOT%{_applnkdir}/System/
+install %{SOURCE5} $RPM_BUILD_ROOT%{_applnkdir}/System
 
 #ln -sf dosemu/comcom.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/command.com
 
-# Take out irritating ^H's from the documentation
-for i in `ls --color=no doc/` ; do cat doc/$i > $i ; cat $i | perl -p -e 's/.\010//g' > doc/$i ; done
-
 rm -f doc/{configuration,dosemu.lsm}
 
 %clean
@@ -231,7 +230,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc QuickStart COPYING ChangeLog* doc/* PRZECZYTAJ_TO README.PLD
+%doc QuickStart COPYING ChangeLog* doc/*.html PRZECZYTAJ_TO README.PLD
 %dir %{_dosemudir}
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dosemu.conf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dosemu.users
@@ -250,7 +249,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n xdosemu
 %defattr(644,root,root,755)
-%doc QuickStart COPYING ChangeLog* doc/* PRZECZYTAJ_TO README.PLD
+%doc QuickStart COPYING ChangeLog* doc/*.html PRZECZYTAJ_TO README.PLD
 %dir %{_dosemudir}
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dosemu.conf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dosemu.users
This page took 0.078021 seconds and 4 git commands to generate.