]> git.pld-linux.org Git - packages/doom3.git/commitdiff
- 1.3.1302. old one stored in branch DEMO
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 5 Nov 2005 00:28:51 +0000 (00:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    doom3.spec -> 1.7

doom3.spec

index a5d1c0f876e8ec44c81e630e0983cd2f3314fb6f..f49c00baab77abbcf56b843a4aa276f9c0f14f06 100644 (file)
@@ -1,26 +1,26 @@
 # NOTE: You could add to your 'mirrors', to get stuff downloaded:
 #  ftp://dl.xs4all.nl/pub/mirror/idsoftware/idstuff/doom3/linux/
 # TODO:
-#  - package dedicated server - doomded.x86, I couldn't get doom3 running so I
-#  wasn't interested anymore :)
+#  - package dedicated server - doomded.x86
 #  - check if system libstdc++ and libgcc_s can be used
 #    answered here: http://zerowing.idsoftware.com/linux/doom/#head-d15dfbca9b3ba90b9bacb7476ad2f0afe3bb0f72
 #  - check license?
 #
 # Conditional build:
 %bcond_with    demo    # package demo data
+%define                demo_version 1.1.1286
 #
 Summary:       Doom III - 3rd installment of the classic id 3D first-person shooter
 Summary(pl):   Doom III - trzecia czê¶æ klasyki FPP z id Software
 Name:          doom3
-Version:       1.1.1286
-Release:       0.2
+Version:       1.3.1302
+Release:       0.8
 Vendor:                id Software
 License:       DOOM3
 Group:         Applications/Games
 Source0:       ftp://ftp.idsoftware.com/idstuff/doom3/linux/%{name}-linux-%{version}.x86.run
-# NoSource0-md5:       2a45d0769b39473887c61a11cbba981c
-Source1:       ftp://ftp.idsoftware.com/idstuff/doom3/linux/%{name}-linux-%{version}-demo.x86.run
+# NoSource0-md5:       b1d04da2d64bb8d54f64cbaa2fdb4490
+Source1:       ftp://ftp.idsoftware.com/idstuff/doom3/linux/%{name}-linux-%{demo_version}-demo.x86.run
 # NoSource1-md5:       81dcf8ead198f14844c554b25e07abbe
 Source2:       %{name}.desktop
 NoSource:      0
@@ -31,28 +31,45 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                no_install_post_strip   1
 
-%define                _noautoprov     libgcc_s.so.1 libstdc++.so.5
-%define                _gamedir        /usr/%{_lib}/games/doom3
+%define                _noautoprov             libgcc_s.so.1 libstdc++.so.5
+%define                _noautoreqdep   libgcc_s.so.1 libstdc++.so.5
+%define                _gamelibdir             %{_libdir}/games/doom3
+%define                _gamedatadir    %{_datadir}/games/doom3
 
 %description
-Doom III demo for Linux.
+Doom III for Linux.
+
+To play the game you need to copy data files from your Doom III CD or
+you could try playing demo by installing %{name}-demo package.
 
 %description -l pl
-Demo Doom III dla Linuksa.
+Doom III dla Linuksa.
+
+%package demo
+Summary:       Doom III Demo data files
+Group:         Applications/Games
+Version:       %{demo_version}
+# main package version is mostly bigger than demo itself.
+Requires:      %{name} >= %{demo_version}
+
+%description demo
+This package contains the data files for Doom III Demo.
 
 %prep
 %setup -qcT
-sh %{SOURCE0} --tar xf
+%if %{with demo}
 sh %{SOURCE1} --tar xf
+%endif
+# here we overwrite files which are shared with demo package. that's intentional
+sh %{SOURCE0} --tar xf
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_gamedir}/{demo,base} \
+install -d $RPM_BUILD_ROOT{%{_gamelibdir},%{_gamedatadir}/{demo,base}} \
        $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_bindir}}
 
-install gamex86.so $RPM_BUILD_ROOT%{_gamedir}
-install libgcc_s.so.1 libstdc++.so.5 $RPM_BUILD_ROOT%{_gamedir}
-install bin/Linux/x86/doom.x86 $RPM_BUILD_ROOT%{_gamedir}
+install libgcc_s.so.1 libstdc++.so.5 $RPM_BUILD_ROOT%{_gamelibdir}
+install bin/Linux/x86/doom.x86 $RPM_BUILD_ROOT%{_gamelibdir}
 
 install %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
@@ -61,14 +78,19 @@ cat << 'EOF' > $RPM_BUILD_ROOT%{_bindir}/%{name}
 #!/bin/sh
 # Needed to make symlinks/shortcuts work.
 # the binaries must run with correct working directory
-cd %{_gamedir}
+cd %{_gamelibdir}
 export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
 exec ./doom.x86 "$@"
 EOF
 
-%{?with_demo:install demo/* $RPM_BUILD_ROOT%{_gamedir}/demo}
+%if %{with demo}
+install gamex86.so $RPM_BUILD_ROOT%{_gamelibdir}
+install demo/* $RPM_BUILD_ROOT%{_gamedatadir}/demo
+ln -s %{_gamedatadir}/demo $RPM_BUILD_ROOT%{_gamelibdir}/demo
+%endif
 
-install base/* $RPM_BUILD_ROOT%{_gamedir}/base
+install base/* $RPM_BUILD_ROOT%{_gamedatadir}/base
+ln -s %{_gamedatadir}/base $RPM_BUILD_ROOT%{_gamelibdir}/base
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -77,19 +99,22 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc License.txt README version.info
 %attr(755,root,root) %{_bindir}/%{name}
-%dir %{_gamedir}
-%attr(755,root,root) %{_gamedir}/doom.x86
-%attr(755,root,root) %{_gamedir}/gamex86.so
-%attr(755,root,root) %{_gamedir}/libgcc_s.so.1
-%attr(755,root,root) %{_gamedir}/libstdc++.so.5
-
+%dir %{_gamelibdir}
+%attr(755,root,root) %{_gamelibdir}/doom.x86
+%attr(755,root,root) %{_gamelibdir}/libgcc_s.so.1
+%attr(755,root,root) %{_gamelibdir}/libstdc++.so.5
 %{_desktopdir}/%{name}.desktop
 %{_pixmapsdir}/%{name}.png
+%dir %{_gamedatadir}
+%dir %{_gamedatadir}/base
+%{_gamedatadir}/base/*
+%{_gamelibdir}/base
 
 %if %{with demo}
-%dir %{_gamedir}/demo
-%{_gamedir}/demo/*
+%files demo
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_gamelibdir}/gamex86.so
+%dir %{_gamedatadir}/demo
+%{_gamedatadir}/demo/*
+%{_gamelibdir}/demo
 %endif
-
-%dir %{_gamedir}/base
-%{_gamedir}/base/*
This page took 0.076981 seconds and 4 git commands to generate.