]> git.pld-linux.org Git - packages/doom3.git/blame - doom3.spec
- updated URL for 1.3
[packages/doom3.git] / doom3.spec
CommitLineData
650dcfb5 1# NOTE: You could add to your 'mirrors', to get stuff downloaded:
4934e9ce
ER
2# ftp://dl.xs4all.nl/pub/mirror/idsoftware/idstuff/doom3/linux/
3# TODO:
21343c5e 4# - package dedicated server - doomded.x86
931f8c9a 5# - check if system libstdc++ and libgcc_s can be used
66c9675b 6# answered here: http://zerowing.idsoftware.com/linux/doom/#head-d15dfbca9b3ba90b9bacb7476ad2f0afe3bb0f72
567d3c3c 7# so? we are not gentoo.
4934e9ce
ER
8# - check license?
9#
10# Conditional build:
11%bcond_with demo # package demo data
21343c5e 12%define demo_version 1.1.1286
931f8c9a 13#
4934e9ce 14Summary: Doom III - 3rd installment of the classic id 3D first-person shooter
425c7960
ER
15Summary(de.UTF-8): Doom III - der dritte Teil des FPP Klassikers von id Software
16Summary(pl.UTF-8): Doom III - trzecia część klasyki FPP z id Software
4934e9ce 17Name: doom3
21343c5e
ER
18Version: 1.3.1302
19Release: 0.8
4934e9ce
ER
20Vendor: id Software
21License: DOOM3
22Group: Applications/Games
d6b8bb12 23Source0: ftp://ftp.idsoftware.com/idstuff/doom3/linux/old/%{name}-linux-%{version}.x86.run
21343c5e
ER
24# NoSource0-md5: b1d04da2d64bb8d54f64cbaa2fdb4490
25Source1: ftp://ftp.idsoftware.com/idstuff/doom3/linux/%{name}-linux-%{demo_version}-demo.x86.run
4934e9ce
ER
26# NoSource1-md5: 81dcf8ead198f14844c554b25e07abbe
27Source2: %{name}.desktop
931f8c9a
JB
28NoSource: 0
29NoSource: 1
4934e9ce
ER
30URL: http://www.doom3.com/
31ExclusiveArch: %{ix86}
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%define no_install_post_strip 1
4934e9ce 35
21343c5e 36%define _noautoprov libgcc_s.so.1 libstdc++.so.5
05d5faec 37%define _noautoreq libgcc_s.so.1 libstdc++.so.5
21343c5e 38%define _gamelibdir %{_libdir}/games/doom3
d6b8bb12 39%define _gamedatadir %{_datadir}/games/doom3
4934e9ce
ER
40
41%description
21343c5e
ER
42Doom III for Linux.
43
44To play the game you need to copy data files from your Doom III CD or
45you could try playing demo by installing %{name}-demo package.
4934e9ce 46
fe884e4f
JR
47%description -l de.UTF-8
48Doom III für Linux.
57610bcf 49
50Um das Spiel zu spielen musst du die Dateien aus deiner Doom III CD
51kopieren oder du kannst das Demo ausprobieren indem du %{name}-demo
52installierst.
53
fe884e4f 54%description -l pl.UTF-8
21343c5e
ER
55Doom III dla Linuksa.
56
fe884e4f
JR
57Do grania trzeba skopiować pliki danych z płyty Doom III, albo można
58spróbować grać w wersji demo instalując pakiet %{name}-demo.
567d3c3c 59
21343c5e
ER
60%package demo
61Summary: Doom III Demo data files
425c7960
ER
62Summary(de.UTF-8): Doom III Demo Dateien
63Summary(pl.UTF-8): Pliki danych Doom III Demo
21343c5e
ER
64Group: Applications/Games
65Version: %{demo_version}
66# main package version is mostly bigger than demo itself.
67Requires: %{name} >= %{demo_version}
68
69%description demo
70This package contains the data files for Doom III Demo.
0eb8b890 71
fe884e4f
JR
72%description demo -l de.UTF-8
73Dieses Packet enthält Dateien für das Doom III Demo.
57610bcf 74
fe884e4f 75%description demo -l pl.UTF-8
567d3c3c
JB
76Ten pakiet zawiera pliki danych dla gry Doom III Demo.
77
4934e9ce
ER
78%prep
79%setup -qcT
21343c5e 80%if %{with demo}
4934e9ce 81sh %{SOURCE1} --tar xf
21343c5e
ER
82%endif
83# here we overwrite files which are shared with demo package. that's intentional
84sh %{SOURCE0} --tar xf
4934e9ce
ER
85
86%install
87rm -rf $RPM_BUILD_ROOT
21343c5e 88install -d $RPM_BUILD_ROOT{%{_gamelibdir},%{_gamedatadir}/{demo,base}} \
931f8c9a 89 $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_bindir}}
4934e9ce 90
21343c5e
ER
91install libgcc_s.so.1 libstdc++.so.5 $RPM_BUILD_ROOT%{_gamelibdir}
92install bin/Linux/x86/doom.x86 $RPM_BUILD_ROOT%{_gamelibdir}
4934e9ce
ER
93
94install %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
95install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
96
1cb3f44e 97cat << 'EOF' > $RPM_BUILD_ROOT%{_bindir}/%{name}
4934e9ce
ER
98#!/bin/sh
99# Needed to make symlinks/shortcuts work.
100# the binaries must run with correct working directory
21343c5e 101cd %{_gamelibdir}
4934e9ce
ER
102export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
103exec ./doom.x86 "$@"
104EOF
105
21343c5e
ER
106%if %{with demo}
107install gamex86.so $RPM_BUILD_ROOT%{_gamelibdir}
108install demo/* $RPM_BUILD_ROOT%{_gamedatadir}/demo
109ln -s %{_gamedatadir}/demo $RPM_BUILD_ROOT%{_gamelibdir}/demo
110%endif
4934e9ce 111
21343c5e
ER
112install base/* $RPM_BUILD_ROOT%{_gamedatadir}/base
113ln -s %{_gamedatadir}/base $RPM_BUILD_ROOT%{_gamelibdir}/base
4934e9ce
ER
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files
119%defattr(644,root,root,755)
120%doc License.txt README version.info
121%attr(755,root,root) %{_bindir}/%{name}
21343c5e
ER
122%dir %{_gamelibdir}
123%attr(755,root,root) %{_gamelibdir}/doom.x86
124%attr(755,root,root) %{_gamelibdir}/libgcc_s.so.1
125%attr(755,root,root) %{_gamelibdir}/libstdc++.so.5
4934e9ce
ER
126%{_desktopdir}/%{name}.desktop
127%{_pixmapsdir}/%{name}.png
21343c5e
ER
128%dir %{_gamedatadir}
129%dir %{_gamedatadir}/base
130%{_gamedatadir}/base/*
131%{_gamelibdir}/base
4934e9ce
ER
132
133%if %{with demo}
21343c5e
ER
134%files demo
135%defattr(644,root,root,755)
136%attr(755,root,root) %{_gamelibdir}/gamex86.so
137%dir %{_gamedatadir}/demo
138%{_gamedatadir}/demo/*
139%{_gamelibdir}/demo
4934e9ce 140%endif
This page took 1.35159 seconds and 4 git commands to generate.