]> git.pld-linux.org Git - packages/doom3.git/blame - doom3.spec
- one current dir in LD_LIBRARY_PATH is enough
[packages/doom3.git] / doom3.spec
CommitLineData
650dcfb5 1# NOTE: You could add to your 'mirrors', to get stuff downloaded:
4934e9ce
ER
2# ftp://dl.xs4all.nl/pub/mirror/idsoftware/idstuff/doom3/linux/
3# TODO:
21343c5e 4# - package dedicated server - doomded.x86
931f8c9a 5# - check if system libstdc++ and libgcc_s can be used
66c9675b 6# answered here: http://zerowing.idsoftware.com/linux/doom/#head-d15dfbca9b3ba90b9bacb7476ad2f0afe3bb0f72
567d3c3c 7# so? we are not gentoo.
4934e9ce
ER
8# - check license?
9#
10# Conditional build:
11%bcond_with demo # package demo data
21343c5e 12%define demo_version 1.1.1286
931f8c9a 13#
4934e9ce 14Summary: Doom III - 3rd installment of the classic id 3D first-person shooter
425c7960
ER
15Summary(de.UTF-8): Doom III - der dritte Teil des FPP Klassikers von id Software
16Summary(pl.UTF-8): Doom III - trzecia część klasyki FPP z id Software
4934e9ce 17Name: doom3
21343c5e
ER
18Version: 1.3.1302
19Release: 0.8
4934e9ce
ER
20Vendor: id Software
21License: DOOM3
22Group: Applications/Games
d6b8bb12 23Source0: ftp://ftp.idsoftware.com/idstuff/doom3/linux/old/%{name}-linux-%{version}.x86.run
21343c5e
ER
24# NoSource0-md5: b1d04da2d64bb8d54f64cbaa2fdb4490
25Source1: ftp://ftp.idsoftware.com/idstuff/doom3/linux/%{name}-linux-%{demo_version}-demo.x86.run
4934e9ce
ER
26# NoSource1-md5: 81dcf8ead198f14844c554b25e07abbe
27Source2: %{name}.desktop
931f8c9a
JB
28NoSource: 0
29NoSource: 1
4934e9ce
ER
30URL: http://www.doom3.com/
31ExclusiveArch: %{ix86}
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
21343c5e 34%define _noautoprov libgcc_s.so.1 libstdc++.so.5
05d5faec 35%define _noautoreq libgcc_s.so.1 libstdc++.so.5
21343c5e 36%define _gamelibdir %{_libdir}/games/doom3
d6b8bb12 37%define _gamedatadir %{_datadir}/games/doom3
4934e9ce
ER
38
39%description
21343c5e
ER
40Doom III for Linux.
41
42To play the game you need to copy data files from your Doom III CD or
43you could try playing demo by installing %{name}-demo package.
4934e9ce 44
fe884e4f
JR
45%description -l de.UTF-8
46Doom III für Linux.
57610bcf 47
48Um das Spiel zu spielen musst du die Dateien aus deiner Doom III CD
49kopieren oder du kannst das Demo ausprobieren indem du %{name}-demo
50installierst.
51
fe884e4f 52%description -l pl.UTF-8
21343c5e
ER
53Doom III dla Linuksa.
54
fe884e4f
JR
55Do grania trzeba skopiować pliki danych z płyty Doom III, albo można
56spróbować grać w wersji demo instalując pakiet %{name}-demo.
567d3c3c 57
21343c5e
ER
58%package demo
59Summary: Doom III Demo data files
425c7960
ER
60Summary(de.UTF-8): Doom III Demo Dateien
61Summary(pl.UTF-8): Pliki danych Doom III Demo
21343c5e
ER
62Group: Applications/Games
63Version: %{demo_version}
64# main package version is mostly bigger than demo itself.
65Requires: %{name} >= %{demo_version}
66
67%description demo
68This package contains the data files for Doom III Demo.
0eb8b890 69
fe884e4f
JR
70%description demo -l de.UTF-8
71Dieses Packet enthält Dateien für das Doom III Demo.
57610bcf 72
fe884e4f 73%description demo -l pl.UTF-8
567d3c3c
JB
74Ten pakiet zawiera pliki danych dla gry Doom III Demo.
75
4934e9ce
ER
76%prep
77%setup -qcT
21343c5e 78%if %{with demo}
4934e9ce 79sh %{SOURCE1} --tar xf
21343c5e
ER
80%endif
81# here we overwrite files which are shared with demo package. that's intentional
82sh %{SOURCE0} --tar xf
4934e9ce
ER
83
84%install
85rm -rf $RPM_BUILD_ROOT
21343c5e 86install -d $RPM_BUILD_ROOT{%{_gamelibdir},%{_gamedatadir}/{demo,base}} \
931f8c9a 87 $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_bindir}}
4934e9ce 88
21343c5e
ER
89install libgcc_s.so.1 libstdc++.so.5 $RPM_BUILD_ROOT%{_gamelibdir}
90install bin/Linux/x86/doom.x86 $RPM_BUILD_ROOT%{_gamelibdir}
4934e9ce
ER
91
92install %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
93install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
94
1cb3f44e 95cat << 'EOF' > $RPM_BUILD_ROOT%{_bindir}/%{name}
4934e9ce
ER
96#!/bin/sh
97# Needed to make symlinks/shortcuts work.
98# the binaries must run with correct working directory
21343c5e 99cd %{_gamelibdir}
c6adca42 100export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}.
4934e9ce
ER
101exec ./doom.x86 "$@"
102EOF
103
21343c5e
ER
104%if %{with demo}
105install gamex86.so $RPM_BUILD_ROOT%{_gamelibdir}
106install demo/* $RPM_BUILD_ROOT%{_gamedatadir}/demo
107ln -s %{_gamedatadir}/demo $RPM_BUILD_ROOT%{_gamelibdir}/demo
108%endif
4934e9ce 109
21343c5e
ER
110install base/* $RPM_BUILD_ROOT%{_gamedatadir}/base
111ln -s %{_gamedatadir}/base $RPM_BUILD_ROOT%{_gamelibdir}/base
4934e9ce
ER
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%files
117%defattr(644,root,root,755)
118%doc License.txt README version.info
119%attr(755,root,root) %{_bindir}/%{name}
21343c5e
ER
120%dir %{_gamelibdir}
121%attr(755,root,root) %{_gamelibdir}/doom.x86
122%attr(755,root,root) %{_gamelibdir}/libgcc_s.so.1
123%attr(755,root,root) %{_gamelibdir}/libstdc++.so.5
4934e9ce
ER
124%{_desktopdir}/%{name}.desktop
125%{_pixmapsdir}/%{name}.png
21343c5e
ER
126%dir %{_gamedatadir}
127%dir %{_gamedatadir}/base
128%{_gamedatadir}/base/*
129%{_gamelibdir}/base
4934e9ce
ER
130
131%if %{with demo}
21343c5e
ER
132%files demo
133%defattr(644,root,root,755)
134%attr(755,root,root) %{_gamelibdir}/gamex86.so
135%dir %{_gamedatadir}/demo
136%{_gamedatadir}/demo/*
137%{_gamelibdir}/demo
4934e9ce 138%endif
This page took 1.974837 seconds and 4 git commands to generate.