]> git.pld-linux.org Git - packages/domoticz.git/commitdiff
- Updated to 4.10717
authorJaroslaw Kruk <kruk.jaroslaw@gmail.com>
Sat, 5 Oct 2019 17:26:32 +0000 (19:26 +0200)
committerJaroslaw Kruk <kruk.jaroslaw@gmail.com>
Sat, 5 Oct 2019 17:27:38 +0000 (19:27 +0200)
boost-1.70.patch [deleted file]
domoticz-openzwave.patch
domoticz-python.patch
domoticz-tinyxpath.patch
domoticz-version.patch
domoticz.spec

diff --git a/boost-1.70.patch b/boost-1.70.patch
deleted file mode 100644 (file)
index 4d2bd8a..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-From 9d226dab339f5767ec01ea1bcc9043ceee185cca Mon Sep 17 00:00:00 2001
-From: Rob Peters <info@domoticz.com>
-Date: Mon, 25 Mar 2019 08:50:23 +0100
-Subject: [PATCH] Fix for boot 1.70 get_io_service, fixed #3117
-
----
- hardware/Pinger.cpp                   | 10 ++++++++--
- hardware/TCPProxy/tcpproxy_server.cpp |  8 +++++++-
- 2 files changed, 15 insertions(+), 3 deletions(-)
-
-diff --git a/hardware/Pinger.cpp b/hardware/Pinger.cpp
-index 01a955ba4..184378738 100644
---- a/hardware/Pinger.cpp
-+++ b/hardware/Pinger.cpp
-@@ -18,6 +18,12 @@
- #include <iostream>
-+#if BOOST_VERSION >= 107000
-+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
-+#else
-+#define GET_IO_SERVICE(s) ((s).get_io_service())
-+#endif
-+
- class pinger
-       : private domoticz::noncopyable
- {
-@@ -76,7 +82,7 @@ class pinger
-                               num_tries_++;
-                               if (num_tries_ > 4)
-                               {
--                                      resolver_.get_io_service().stop();
-+                                      GET_IO_SERVICE(resolver_).stop();
-                               }
-                               else
-                               {
-@@ -118,7 +124,7 @@ class pinger
-                       if (num_replies_++ == 0)
-                               timer_.cancel();
-                       m_PingState = true;
--                      resolver_.get_io_service().stop();
-+                      GET_IO_SERVICE(resolver_).stop();
-               }
-               else
-               {
-diff --git a/hardware/TCPProxy/tcpproxy_server.cpp b/hardware/TCPProxy/tcpproxy_server.cpp
-index fddac08de..60445d9c2 100644
---- a/hardware/TCPProxy/tcpproxy_server.cpp
-+++ b/hardware/TCPProxy/tcpproxy_server.cpp
-@@ -15,6 +15,12 @@
- #include "stdafx.h"
- #include "tcpproxy_server.h"
-+#if BOOST_VERSION >= 107000
-+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
-+#else
-+#define GET_IO_SERVICE(s) ((s).get_io_service())
-+#endif
-+
- namespace tcp_proxy
- {
-       bridge::bridge(boost::asio::io_service& ios)
-@@ -38,7 +44,7 @@ namespace tcp_proxy
-               boost::asio::ip::tcp::endpoint end;
--              boost::asio::io_service &ios=downstream_socket_.get_io_service();
-+              boost::asio::io_service &ios= GET_IO_SERVICE(downstream_socket_);
-               boost::asio::ip::tcp::resolver resolver(ios);
-               boost::asio::ip::tcp::resolver::query query(upstream_host, upstream_port, boost::asio::ip::resolver_query_base::numeric_service);
-               boost::asio::ip::tcp::resolver::iterator i = resolver.resolve(query);
index 84cabdb1714c9b66f1d007d5ed546021a80d64c4..bcf6aaf72765a518139e17206a36f3f347d8de7e 100644 (file)
@@ -1,8 +1,7 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 42082192..f16726f8 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -682,7 +682,7 @@ endif()
+diff -urN domoticz-4.10717.orig/CMakeLists.txt domoticz-4.10717/CMakeLists.txt
+--- domoticz-4.10717.orig/CMakeLists.txt       2019-05-10 11:37:55.000000000 +0200
++++ domoticz-4.10717/CMakeLists.txt    2019-10-05 12:18:52.336750288 +0200
+@@ -689,7 +689,7 @@
  IF(OpenZWave)
    message(STATUS ${OpenZWave})
    target_link_libraries(domoticz ${OpenZWave})
@@ -11,10 +10,9 @@ index 42082192..f16726f8 100644
    add_definitions(-DWITH_OPENZWAVE)
    # open-zwave needs libudev if statically linked
    IF(USE_STATIC_OPENZWAVE)
-diff --git a/hardware/openzwave/control_panel/ozwcp.cpp b/hardware/openzwave/control_panel/ozwcp.cpp
-index ffd8d742..79c708ce 100644
---- a/hardware/openzwave/control_panel/ozwcp.cpp
-+++ b/hardware/openzwave/control_panel/ozwcp.cpp
+diff -urN domoticz-4.10717.orig/hardware/openzwave/control_panel/ozwcp.cpp domoticz-4.10717/hardware/openzwave/control_panel/ozwcp.cpp
+--- domoticz-4.10717.orig/hardware/openzwave/control_panel/ozwcp.cpp   2019-05-10 11:37:55.000000000 +0200
++++ domoticz-4.10717/hardware/openzwave/control_panel/ozwcp.cpp        2019-10-05 12:13:41.340069579 +0200
 @@ -39,11 +39,11 @@
  #include <stdlib.h>
  #include <time.h>
@@ -32,10 +30,9 @@ index ffd8d742..79c708ce 100644
  
  #include <sys/stat.h>
  #include <fstream>
-diff --git a/hardware/openzwave/control_panel/ozwcp.h b/hardware/openzwave/control_panel/ozwcp.h
-index 29ebc0e3..7a027815 100644
---- a/hardware/openzwave/control_panel/ozwcp.h
-+++ b/hardware/openzwave/control_panel/ozwcp.h
+diff -urN domoticz-4.10717.orig/hardware/openzwave/control_panel/ozwcp.h domoticz-4.10717/hardware/openzwave/control_panel/ozwcp.h
+--- domoticz-4.10717.orig/hardware/openzwave/control_panel/ozwcp.h     2019-05-10 11:37:55.000000000 +0200
++++ domoticz-4.10717/hardware/openzwave/control_panel/ozwcp.h  2019-10-05 12:14:19.620071306 +0200
 @@ -37,8 +37,8 @@
  
  #include <list>
@@ -45,5 +42,5 @@ index 29ebc0e3..7a027815 100644
 +#include <Driver.h>
 +#include <Notification.h>
  
- using namespace OpenZWave;
+ #define MAX_NODES 255
  
index e6332deb79b07db21f52e55ae5dbe6828a2925c2..9ef3e7ef4e9eeb02a94078ad08b13a8e5f9e6dc9 100644 (file)
@@ -1,33 +1,19 @@
-From f7b229ce873ff71e2b48e855075153dc1026750d Mon Sep 17 00:00:00 2001
-From: Michael Cronenworth <mike@cchtml.com>
-Date: Mon, 7 Aug 2017 14:37:28 -0500
-Subject: [PATCH] Follow PEP-384 when finding and opening python3 library
-
-Instead of maintaining a list of all Python versions the Python 3
-standard defines that there MUST be a stable ABI and we can always
-rely on a "python3.dll" or a "libpython3.so" existing.
-
-This also fixes library loading on Linux distributions that use
-SO versioned libraries.
----
- hardware/plugins/DelayedLink.h | 28 ++--------------------------
- 1 file changed, 2 insertions(+), 26 deletions(-)
-
-diff --git a/hardware/plugins/DelayedLink.h b/hardware/plugins/DelayedLink.h
-index 25c83f034..ecf19da09 100644
---- a/hardware/plugins/DelayedLink.h
-+++ b/hardware/plugins/DelayedLink.h
-@@ -126,16 +126,10 @@ namespace Plugins {
+diff -urN domoticz-4.10717.orig/hardware/plugins/DelayedLink.h domoticz-4.10717/hardware/plugins/DelayedLink.h
+--- domoticz-4.10717.orig/hardware/plugins/DelayedLink.h       2019-05-10 11:37:55.000000000 +0200
++++ domoticz-4.10717/hardware/plugins/DelayedLink.h    2019-10-05 19:05:40.930495976 +0200
+@@ -145,18 +145,10 @@
                                if (!shared_lib_) shared_lib_ = LoadLibrary("python35_d.dll");
                                if (!shared_lib_) shared_lib_ = LoadLibrary("python34_d.dll");
  #     else
+-                              if (!shared_lib_) shared_lib_ = LoadLibrary("python38.dll");
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python37.dll");
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python36.dll");
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python35.dll");
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python34.dll");
-+                              if (!shared_lib_) shared_lib_ = LoadLibrary("python3.dll");
++                              if (!shared_lib_) shared_lib_ = LoadLibrary("python.dll");
  #     endif
  #else
+-                              if (!shared_lib_) FindLibrary("python3.8", true);
 -                              if (!shared_lib_) FindLibrary("python3.7", true);
 -                              if (!shared_lib_) FindLibrary("python3.6", true);
 -                              if (!shared_lib_) FindLibrary("python3.5", true);
@@ -36,7 +22,7 @@ index 25c83f034..ecf19da09 100644
  #endif
                                if (shared_lib_)
                                {
-@@ -232,24 +226,12 @@ namespace Plugins {
+@@ -271,24 +263,12 @@
                                                library = "lib" + sLibrary + ".so";
                                                shared_lib_ = dlopen(library.c_str(), RTLD_LAZY | RTLD_GLOBAL);
                                        }
@@ -61,7 +47,7 @@ index 25c83f034..ecf19da09 100644
                                        // look in /usr/local/lib directory (handles build from source)
                                        if (!shared_lib_)
                                        {
-@@ -257,12 +239,6 @@ namespace Plugins {
+@@ -296,12 +276,6 @@
                                                shared_lib_ = dlopen(library.c_str(), RTLD_LAZY | RTLD_GLOBAL);
  
                                        }
@@ -71,6 +57,6 @@ index 25c83f034..ecf19da09 100644
 -                                              library = "/usr/local/lib/lib" + sLibrary + "m.so";
 -                                              shared_lib_ = dlopen(library.c_str(), RTLD_LAZY | RTLD_GLOBAL);
 -                                      }
-                               }
-                               else
-                               {
+                                       // MacOS
+                                       // look for .dylib in /usr/local/lib
+                                       if (!shared_lib_)
index bb24e7c28ebcdfb7d3f65879848d5e6aadc37fb1..84874c03ad4502d47e73fee8e4fd51a6c06255a9 100644 (file)
@@ -93,7 +93,7 @@ index bc231d8f6..334f203a6 100644
  # SET(OperatingSystem "Linux")
 --- a/hardware/OnkyoAVTCP.cpp  2018-06-23 09:18:06.000000000 -0500
 +++ b/hardware/OnkyoAVTCP.cpp  2018-07-08 14:21:06.884163094 -0500
-@@ -3,16 +3,16 @@
+@@ -3,15 +3,15 @@
  #include "../main/Logger.h"
  #include "../main/Helper.h"
  #include "../main/SQLHelper.h"
@@ -107,7 +107,6 @@ index bc231d8f6..334f203a6 100644
  
 +#include <iostream>
  #include <sstream>
- #include <map>
 +#include <tinyxml.h>
  
  #define RETRY_DELAY 30
index 33c66a97f0f3e683cb8e1aec6ecc563597faef60..b87fb342cc6e928d78a62599790052e1f913dce9 100644 (file)
@@ -1,9 +1,9 @@
 --- a/appversion.default       2017-07-30 05:19:41.000000000 -0500
 +++ b/appversion.default       2017-07-31 11:36:32.150644222 -0500
 @@ -1,3 +1,3 @@
--#define APPVERSION 5876
+-#define APPVERSION 9700
 -#define APPHASH "b97777b"
 -#define APPDATE 1478691222
-+#define APPVERSION 9700
-+#define APPHASH "2772d9f"
-+#define APPDATE 1529763480
++#define APPVERSION 10717
++#define APPHASH "649306c"
++#define APPDATE 1557423720
index f86c3f0e6eb3e81a8fb768e6917d82f38fc23f3e..147460056268c80b0cb39807d6f5d27566fee6f5 100644 (file)
@@ -1,15 +1,15 @@
 Summary:       Open source Home Automation System
 Name:          domoticz
-Version:       4.9700
-Release:       3
+Version:       4.10717
+Release:       1
 License:       GPLv3+ and ASL 2.0 and Boost and BSD and MIT
 Group:         Base
 URL:           http://www.domoticz.com
 Source0:       https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
-# Source0-md5: 726d838d5d80eed4335b0dfeefb2af6c
+# Source0-md5: 1d5f5572ae43379a6d62023cb8da0e9b
 Source1:       %{name}.service
 Source2:       %{name}.conf
-# Source says its version 3.5876, but it's really 3.8153
+# Source says its version 4.9700, but it's really 4.10717
 Patch1:                %{name}-version.patch
 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
 Patch2:                %{name}-tinyxpath.patch
@@ -21,7 +21,6 @@ Patch4:               %{name}-openzwave-Dev.patch
 Patch5:                %{name}-python.patch
 Patch6:                domoticz-ozw-barrier-support-0002.patch
 Patch7:                domoticz-cp-js.patch
-Patch8:                boost-1.70.patch
 BuildRequires: boost-devel
 BuildRequires: cmake
 BuildRequires: curl-devel
@@ -81,11 +80,10 @@ and much more. Notifications/Alerts can be sent to any mobile device
 %patch1 -p1 -b.version
 %patch2 -p1 -b.tinyxpath
 %patch3 -p1 -b.openzwave
-%patch4 -p1 -b.openzwave-Dev
+#%patch4 -p1 -b.openzwave-Dev
 %patch5 -p1 -b.python
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
 rm -f hardware/openzwave/*.h
 rm -rf hardware/openzwave/aes
 rm -rf hardware/openzwave/command_classes
This page took 0.049873 seconds and 4 git commands to generate.