]> git.pld-linux.org Git - packages/domoticz.git/blob - domoticz.spec
rel 2
[packages/domoticz.git] / domoticz.spec
1 Summary:        Open source Home Automation System
2 Name:           domoticz
3 Version:        2021.1
4 Release:        2
5 License:        GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6 Group:          Base
7 URL:            http://www.domoticz.com
8 Source0:        https://github.com/domoticz/domoticz/archive/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  28349806fc3ddb0514ea7d9255ceecd0
10 Source1:        %{name}.service
11 Source2:        %{name}.conf
12 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
13 Patch0:         %{name}-tinyxpath.patch
14 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
15 Patch1:         %{name}-python.patch
16 Patch2:         no-git.patch
17 Patch3:         %{name}-gpio.patch
18 Patch4:         %{name}-no_updates.patch
19 BuildRequires:  boost-devel >= 1.66.0
20 BuildRequires:  cereal-devel
21 BuildRequires:  cmake >= 3.16.0
22 BuildRequires:  curl-devel
23 BuildRequires:  jsoncpp-devel
24 BuildRequires:  libfmt-devel
25 BuildRequires:  libmosquitto-devel
26 BuildRequires:  libopenzwave-devel >= 1.5.0
27 BuildRequires:  libstdc++-devel >= 6:4.9
28 BuildRequires:  libusb-compat-devel
29 BuildRequires:  linux-libc-headers
30 BuildRequires:  lua53-devel
31 BuildRequires:  minizip-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  python3 >= 1:3.4
35 BuildRequires:  python3-devel >= 1:3.4
36 BuildRequires:  rpmbuild(macros) >= 1.644
37 BuildRequires:  sqlite3-devel
38 BuildRequires:  tinyxml-devel
39 BuildRequires:  tinyxpath-devel
40 BuildRequires:  zlib-devel
41 Requires(pre):  /usr/sbin/groupadd
42 Requires(pre):  /usr/sbin/useradd
43 Requires(post,preun,postun):    systemd-units >= 38
44 Requires:       fonts-TTF-Google-Droid
45 Requires:       fonts-TTF-OpenSans
46 Requires:       libopenzwave >= 1.5.0
47 Requires:       setup >= 2.10.1
48 Suggests:       python3-libs
49 Provides:       group(domoticz)
50 Provides:       user(domoticz)
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Domoticz is a Home Automation System that lets you monitor and
55 configure various devices like: Lights, Switches, various
56 sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
57 and much more. Notifications/Alerts can be sent to any mobile device
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63 %patch2 -p1
64 %patch3 -p1
65 %patch4 -p1
66
67 APPVERSION="%{version}"
68 echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
69 echo '#define APPHASH "%{snap}"' >> appversion.h
70 APPDATE=$(date --date="%{date}" "+%s")
71 echo "#define APPDATE ${APPDATE}" >> appversion.h
72
73 %{__rm} -r extern tinyxpath
74
75 %build
76 install -d build && cd build
77 export CXXFLAGS="%{rpmcxxflags} -DPYTHON_LIBDIR=\\\"%{_libdir}\\\""
78 %cmake \
79         -DUSE_BUILTIN_JSONCPP=NO \
80         -DUSE_BUILTIN_LIBFMT=NO \
81         -DUSE_BUILTIN_MINIZIP=NO \
82         -DUSE_BUILTIN_MQTT=NO \
83         -DUSE_BUILTIN_SQLITE=NO \
84         -DUSE_BUILTIN_TINYXPATH=NO \
85         -DUSE_LUA_STATIC=NO \
86         -DUSE_OPENSSL_STATIC=NO \
87         -DUSE_STATIC_BOOST=NO \
88         -DUSE_STATIC_LIBSTDCXX=NO \
89         -DUSE_STATIC_OPENZWAVE=NO \
90         -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
91         ..
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -C build install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/sysconfig,%{systemdunitdir},%{_sharedstatedir}/%{name}}
102
103 # remove docs, we grab them in files below
104 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
105
106 # move binary to standard directory
107 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
108
109 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
110 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
111
112 # Unbundle DroidSans.ttf
113 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/{Droid,Open}Sans.ttf
114 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
115         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
116 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
117         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/OpenSans.ttf
118 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
119         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
120 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
121         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/OpenSans.ttf
122 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
123         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
124 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
125         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/OpenSans.ttf
126
127 # OpenZWave Control Panel temp file
128 ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
129         $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %pre
135 %groupadd -g 342 domoticz
136 %useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout,i2c -g domoticz domoticz
137
138 %post
139 %systemd_post %{name}.service
140
141 %preun
142 %systemd_preun %{name}.service
143
144 %postun
145 if [ "$1" = "0" ]; then
146         %userremove mpd
147         %groupremove mpd
148 fi
149 %systemd_reload
150
151 %files
152 %defattr(644,root,root,755)
153 %doc License.txt README.md History.txt
154 %attr(755,root,root) %{_bindir}/%{name}
155 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
156 %{_datadir}/%{name}
157 %dir %attr(750,domoticz,domoticz) %{_sharedstatedir}/%{name}
158 %{systemdunitdir}/%{name}.service
This page took 0.079862 seconds and 3 git commands to generate.