]> git.pld-linux.org Git - packages/domoticz.git/blob - domoticz.spec
039274c84afbf1c9d6c2f949ca2fc3e1bb5d6239
[packages/domoticz.git] / domoticz.spec
1 Summary:        Open source Home Automation System
2 Name:           domoticz
3 Version:        2020.2
4 Release:        3
5 License:        GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6 Group:          Base
7 URL:            http://www.domoticz.com
8 Source0:        https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9 # Source0-md5:  fd383a13d13d0976c72f332d6db1d24e
10 Source1:        %{name}.service
11 Source2:        %{name}.conf
12 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
13 Patch0:         %{name}-tinyxpath.patch
14 # Use system openzwave includes
15 Patch1:         %{name}-openzwave.patch
16 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
17 Patch2:         %{name}-python.patch
18 Patch3:         no-git.patch
19 Patch4:         boost-1.73.patch
20 Patch5:         %{name}-gpio.patch
21 Patch6:         python3.9.patch
22 BuildRequires:  boost-devel >= 1.66.0
23 BuildRequires:  cereal-devel
24 BuildRequires:  cmake >= 3.16.0
25 BuildRequires:  curl-devel
26 BuildRequires:  jsoncpp-devel
27 BuildRequires:  libmosquitto-devel
28 BuildRequires:  libopenzwave-devel >= 1.5.0
29 BuildRequires:  libstdc++-devel >= 6:4.8.1
30 BuildRequires:  libusb-compat-devel
31 BuildRequires:  linux-libc-headers
32 BuildRequires:  lua53-devel
33 BuildRequires:  minizip-devel
34 BuildRequires:  openssl-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  python3 >= 1:3.4
37 BuildRequires:  python3-devel >= 1:3.4
38 BuildRequires:  rpmbuild(macros) >= 1.644
39 BuildRequires:  sqlite3-devel
40 BuildRequires:  tinyxml-devel
41 BuildRequires:  tinyxpath-devel
42 BuildRequires:  zlib-devel
43 Requires(pre):  /usr/sbin/groupadd
44 Requires(pre):  /usr/sbin/useradd
45 Requires(post,preun,postun):    systemd-units >= 38
46 Requires:       fonts-TTF-Google-Droid
47 Requires:       fonts-TTF-OpenSans
48 Requires:       libopenzwave >= 1.5.0
49 Provides:       group(domoticz)
50 Provides:       user(domoticz)
51
52 %description
53 Domoticz is a Home Automation System that lets you monitor and
54 configure various devices like: Lights, Switches, various
55 sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
56 and much more. Notifications/Alerts can be sent to any mobile device
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p1
62 %patch2 -p1
63 %patch3 -p1
64 %patch4 -p1
65 %patch5 -p1
66 %patch6 -p1
67
68 APPVERSION="%{version}"
69 echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
70 echo '#define APPHASH "%{snap}"' >> appversion.h
71 APPDATE=$(date --date="%{date}" "+%s")
72 echo "#define APPDATE ${APPDATE}" >> appversion.h
73
74 %{__rm} -r extern tinyxpath
75
76 %build
77 install -d build && cd build
78 %cmake \
79         -DUSE_BUILTIN_JSONCPP=NO \
80         -DUSE_BUILTIN_MINIZIP=NO \
81         -DUSE_BUILTIN_MQTT=NO \
82         -DUSE_BUILTIN_SQLITE=NO \
83         -DUSE_BUILTIN_TINYXPATH=NO \
84         -DUSE_LUA_STATIC=NO \
85         -DUSE_OPENSSL_STATIC=NO \
86         -DUSE_STATIC_BOOST=NO \
87         -DUSE_STATIC_LIBSTDCXX=NO \
88         -DUSE_STATIC_OPENZWAVE=NO \
89         -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
90         ..
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} -C build install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/sysconfig,%{systemdunitdir},%{_sharedstatedir}/%{name}}
101
102 # remove docs, we grab them in files below
103 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
104
105 # move binary to standard directory
106 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
107
108 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
109 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
110
111 # Unbundle DroidSans.ttf
112 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/{Droid,Open}Sans.ttf
113 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
114         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
115 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
116         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/OpenSans.ttf
117 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
118         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
119 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
120         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/OpenSans.ttf
121 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
122         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
123 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
124         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/OpenSans.ttf
125
126 # OpenZWave Control Panel temp file
127 ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
128         $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %pre
134 %groupadd -g 342 domoticz
135 %useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout -g domoticz domoticz
136
137 %post
138 %systemd_post %{name}.service
139
140 %preun
141 %systemd_preun %{name}.service
142
143 %postun
144 if [ "$1" = "0" ]; then
145         %userremove mpd
146         %groupremove mpd
147 fi
148 %systemd_reload
149
150 %files
151 %defattr(644,root,root,755)
152 %doc License.txt README.md History.txt
153 %attr(755,root,root) %{_bindir}/%{name}
154 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
155 %{_datadir}/%{name}
156 %dir %attr(750,domoticz,domoticz) %{_sharedstatedir}/%{name}
157 %{systemdunitdir}/%{name}.service
This page took 0.042671 seconds and 2 git commands to generate.