]> git.pld-linux.org Git - packages/domoticz.git/blame_incremental - domoticz.spec
make python patch sane
[packages/domoticz.git] / domoticz.spec
... / ...
CommitLineData
1Summary: Open source Home Automation System
2Name: domoticz
3Version: 2021.1
4Release: 1
5License: GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6Group: Base
7URL: http://www.domoticz.com
8Source0: https://github.com/domoticz/domoticz/archive/%{version}/%{name}-%{version}.tar.gz
9# Source0-md5: 28349806fc3ddb0514ea7d9255ceecd0
10Source1: %{name}.service
11Source2: %{name}.conf
12# Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
13Patch0: %{name}-tinyxpath.patch
14# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
15Patch1: %{name}-python.patch
16Patch2: no-git.patch
17Patch3: %{name}-gpio.patch
18Patch4: %{name}-no_updates.patch
19BuildRequires: boost-devel >= 1.66.0
20BuildRequires: cereal-devel
21BuildRequires: cmake >= 3.16.0
22BuildRequires: curl-devel
23BuildRequires: jsoncpp-devel
24BuildRequires: libfmt-devel
25BuildRequires: libmosquitto-devel
26BuildRequires: libopenzwave-devel >= 1.5.0
27BuildRequires: libstdc++-devel >= 6:4.9
28BuildRequires: libusb-compat-devel
29BuildRequires: linux-libc-headers
30BuildRequires: lua53-devel
31BuildRequires: minizip-devel
32BuildRequires: openssl-devel
33BuildRequires: pkgconfig
34BuildRequires: python3 >= 1:3.4
35BuildRequires: python3-devel >= 1:3.4
36BuildRequires: rpmbuild(macros) >= 1.644
37BuildRequires: sqlite3-devel
38BuildRequires: tinyxml-devel
39BuildRequires: tinyxpath-devel
40BuildRequires: zlib-devel
41Requires(pre): /usr/sbin/groupadd
42Requires(pre): /usr/sbin/useradd
43Requires(post,preun,postun): systemd-units >= 38
44Requires: fonts-TTF-Google-Droid
45Requires: fonts-TTF-OpenSans
46Requires: libopenzwave >= 1.5.0
47Requires: setup >= 2.10.1
48Provides: group(domoticz)
49Provides: user(domoticz)
50
51%description
52Domoticz is a Home Automation System that lets you monitor and
53configure various devices like: Lights, Switches, various
54sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
55and much more. Notifications/Alerts can be sent to any mobile device
56
57%prep
58%setup -q
59%patch0 -p1
60%patch1 -p1
61%patch2 -p1
62%patch3 -p1
63%patch4 -p1
64
65APPVERSION="%{version}"
66echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
67echo '#define APPHASH "%{snap}"' >> appversion.h
68APPDATE=$(date --date="%{date}" "+%s")
69echo "#define APPDATE ${APPDATE}" >> appversion.h
70
71%{__rm} -r extern tinyxpath
72
73%build
74install -d build && cd build
75export CXXFLAGS="%{rpmcxxflags} -DPYTHON_LIBDIR=\\\"%{_libdir}\\\""
76%cmake \
77 -DUSE_BUILTIN_JSONCPP=NO \
78 -DUSE_BUILTIN_LIBFMT=NO \
79 -DUSE_BUILTIN_MINIZIP=NO \
80 -DUSE_BUILTIN_MQTT=NO \
81 -DUSE_BUILTIN_SQLITE=NO \
82 -DUSE_BUILTIN_TINYXPATH=NO \
83 -DUSE_LUA_STATIC=NO \
84 -DUSE_OPENSSL_STATIC=NO \
85 -DUSE_STATIC_BOOST=NO \
86 -DUSE_STATIC_LIBSTDCXX=NO \
87 -DUSE_STATIC_OPENZWAVE=NO \
88 -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
89 ..
90
91%{__make}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96%{__make} -C build install \
97 DESTDIR=$RPM_BUILD_ROOT
98
99install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/sysconfig,%{systemdunitdir},%{_sharedstatedir}/%{name}}
100
101# remove docs, we grab them in files below
102%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
103
104# move binary to standard directory
105mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
106
107cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
108cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
109
110# Unbundle DroidSans.ttf
111%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/{Droid,Open}Sans.ttf
112ln -s %{_fontsdir}/TTF/DroidSans.ttf \
113 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
114ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
115 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/OpenSans.ttf
116ln -s %{_fontsdir}/TTF/DroidSans.ttf \
117 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
118ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
119 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/OpenSans.ttf
120ln -s %{_fontsdir}/TTF/DroidSans.ttf \
121 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
122ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
123 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/OpenSans.ttf
124
125# OpenZWave Control Panel temp file
126ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
127 $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%pre
133%groupadd -g 342 domoticz
134%useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout,i2c -g domoticz domoticz
135
136%post
137%systemd_post %{name}.service
138
139%preun
140%systemd_preun %{name}.service
141
142%postun
143if [ "$1" = "0" ]; then
144 %userremove mpd
145 %groupremove mpd
146fi
147%systemd_reload
148
149%files
150%defattr(644,root,root,755)
151%doc License.txt README.md History.txt
152%attr(755,root,root) %{_bindir}/%{name}
153%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
154%{_datadir}/%{name}
155%dir %attr(750,domoticz,domoticz) %{_sharedstatedir}/%{name}
156%{systemdunitdir}/%{name}.service
This page took 0.077488 seconds and 4 git commands to generate.