]> git.pld-linux.org Git - packages/domoticz.git/blame - domoticz.spec
handle user/group correctly
[packages/domoticz.git] / domoticz.spec
CommitLineData
9dda6696
AM
1Summary: Open source Home Automation System
2Name: domoticz
72784cf7 3Version: 2020.2
0abc31de 4Release: 3
9dda6696
AM
5License: GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6Group: Base
7URL: http://www.domoticz.com
72784cf7
AM
8Source0: https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9# Source0-md5: fd383a13d13d0976c72f332d6db1d24e
9dda6696
AM
10Source1: %{name}.service
11Source2: %{name}.conf
9dda6696 12# Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
bc226567 13Patch0: %{name}-tinyxpath.patch
9dda6696 14# Use system openzwave includes
bc226567 15Patch1: %{name}-openzwave.patch
9dda6696 16# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
bc226567
JP
17Patch2: %{name}-python.patch
18Patch3: no-git.patch
19Patch4: boost-1.73.patch
4987f952 20BuildRequires: boost-devel >= 1.66.0
72784cf7 21BuildRequires: cereal-devel
4987f952 22BuildRequires: cmake >= 3.16.0
9dda6696 23BuildRequires: curl-devel
4987f952 24BuildRequires: jsoncpp-devel
9dda6696 25BuildRequires: libmosquitto-devel
9dda6696 26BuildRequires: libopenzwave-devel >= 1.5.0
4987f952
JP
27BuildRequires: libstdc++-devel >= 6:4.8.1
28BuildRequires: libusb-compat-devel
29BuildRequires: linux-libc-headers
30BuildRequires: lua53-devel
72784cf7 31BuildRequires: minizip-devel
9dda6696 32BuildRequires: openssl-devel
4987f952
JP
33BuildRequires: pkgconfig
34BuildRequires: python3 >= 1:3.4
35BuildRequires: python3-devel >= 1:3.4
36BuildRequires: sqlite3-devel
37BuildRequires: tinyxml-devel
9dda6696
AM
38BuildRequires: tinyxpath-devel
39BuildRequires: zlib-devel
0e22aa87
JP
40Requires(pre): /usr/sbin/groupadd
41Requires(pre): /usr/sbin/useradd
42Requires(post,preun,postun): systemd-units >= 38
43Requires: fonts-TTF-Google-Droid
4987f952 44Requires: libopenzwave >= 1.5.0
ed4fe787
JP
45Provides: group(domoticz)
46Provides: user(domoticz)
9dda6696
AM
47
48%description
49Domoticz is a Home Automation System that lets you monitor and
50configure various devices like: Lights, Switches, various
51sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
52and much more. Notifications/Alerts can be sent to any mobile device
53
54%prep
72784cf7 55%setup -q
bc226567
JP
56%patch0 -p1
57%patch1 -p1
58%patch2 -p1
59%patch3 -p1
60%patch4 -p1
10f7a92e
AM
61
62APPVERSION="%{version}"
63echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
64echo '#define APPHASH "%{snap}"' >> appversion.h
65APPDATE=$(date --date="%{date}" "+%s")
66echo "#define APPDATE ${APPDATE}" >> appversion.h
67
0e22aa87 68%{__rm} -r extern tinyxpath
9dda6696
AM
69
70%build
71install -d build && cd build
72%cmake \
4987f952
JP
73 -DUSE_BUILTIN_JSONCPP=NO \
74 -DUSE_BUILTIN_MINIZIP=NO \
71593ba7
JR
75 -DUSE_BUILTIN_MQTT=NO \
76 -DUSE_BUILTIN_SQLITE=NO \
77 -DUSE_BUILTIN_TINYXPATH=NO \
4987f952
JP
78 -DUSE_LUA_STATIC=NO \
79 -DUSE_OPENSSL_STATIC=NO \
71593ba7 80 -DUSE_STATIC_BOOST=NO \
4987f952
JP
81 -DUSE_STATIC_LIBSTDCXX=NO \
82 -DUSE_STATIC_OPENZWAVE=NO \
71593ba7
JR
83 -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
84 ..
00bce45c 85
9dda6696
AM
86%{__make}
87
88%install
89rm -rf $RPM_BUILD_ROOT
0e22aa87 90
00bce45c 91%{__make} -C build install \
0e22aa87
JP
92 DESTDIR=$RPM_BUILD_ROOT
93
94install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/sysconfig,%{systemdunitdir},%{_sharedstatedir}/%{name}}
9dda6696
AM
95
96# remove docs, we grab them in files below
0e22aa87 97%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
9dda6696
AM
98
99# move binary to standard directory
0e22aa87 100mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
9dda6696 101
0e22aa87 102cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
9dda6696
AM
103cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
104
9dda6696 105# Unbundle DroidSans.ttf
0e22aa87
JP
106%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/DroidSans.ttf
107ln -s %{_fontsdir}/TTF/DroidSans.ttf \
108 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
109ln -s %{_fontsdir}/TTF/DroidSans.ttf \
110 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
111ln -s %{_fontsdir}/TTF/DroidSans.ttf \
112 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
9dda6696
AM
113
114# OpenZWave Control Panel temp file
115ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
0e22aa87 116 $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
9dda6696
AM
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%pre
ed4fe787
JP
122%groupadd -g 342 domoticz
123%useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout -g domoticz domoticz
9dda6696
AM
124
125%post
126%systemd_post %{name}.service
127
128%preun
129%systemd_preun %{name}.service
130
131%postun
ed4fe787
JP
132if [ "$1" = "0" ]; then
133 %userremove mpd
134 %groupremove mpd
135fi
5ac2f181 136%systemd_reload
9dda6696
AM
137
138%files
139%defattr(644,root,root,755)
0e22aa87 140%doc License.txt README.md History.txt
9dda6696
AM
141%attr(755,root,root) %{_bindir}/%{name}
142%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
0e22aa87
JP
143%{_datadir}/%{name}
144%dir %attr(750,domoticz,domoticz) %{_sharedstatedir}/%{name}
9dda6696 145%{systemdunitdir}/%{name}.service
This page took 0.149188 seconds and 4 git commands to generate.