]> git.pld-linux.org Git - packages/domoticz.git/blame - domoticz.spec
- release 2 (by relup.sh)
[packages/domoticz.git] / domoticz.spec
CommitLineData
9dda6696
AM
1Summary: Open source Home Automation System
2Name: domoticz
72784cf7 3Version: 2020.2
1ae38ec5 4Release: 2
9dda6696
AM
5License: GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6Group: Base
7URL: http://www.domoticz.com
72784cf7
AM
8Source0: https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9# Source0-md5: fd383a13d13d0976c72f332d6db1d24e
9dda6696
AM
10Source1: %{name}.service
11Source2: %{name}.conf
10f7a92e 12
9dda6696
AM
13# Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
14Patch2: %{name}-tinyxpath.patch
15# Use system openzwave includes
16Patch3: %{name}-openzwave.patch
17# Work against Dev branch of OpenZWave upstream
18Patch4: %{name}-openzwave-Dev.patch
19# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
20Patch5: %{name}-python.patch
d051ba14 21Patch6: no-git.patch
9dda6696 22BuildRequires: boost-devel
72784cf7 23BuildRequires: cereal-devel
9dda6696
AM
24BuildRequires: cmake
25BuildRequires: curl-devel
26BuildRequires: libmosquitto-devel
27BuildRequires: libmosquittopp-devel
28BuildRequires: libopenzwave-devel >= 1.5.0
29BuildRequires: libstdc++-devel
30BuildRequires: libusb-devel
31BuildRequires: lua-devel
72784cf7 32BuildRequires: minizip-devel
9dda6696
AM
33BuildRequires: openssl-devel
34BuildRequires: python3-devel
35BuildRequires: sqlite-devel
36BuildRequires: systemd-devel
37BuildRequires: tinyxpath-devel
38BuildRequires: zlib-devel
06cb1c68
AM
39Requires(pre): /usr/sbin/groupadd
40Requires(pre): /usr/sbin/useradd
9dda6696
AM
41Requires(post): systemd
42Requires(postun): systemd
43Requires(preun): systemd
06cb1c68 44Requires: fonts-TTF-Google-Droid
9dda6696
AM
45Provides: bundled(js-ace)
46Provides: bundled(js-angular-ui-bootstrap) = 0.13.4
47Provides: bundled(js-angularamd) = 0.2.1
48Provides: bundled(js-angularjs) = 1.5.8
49Provides: bundled(js-blockly)
50Provides: bundled(js-bootbox)
51Provides: bundled(js-bootstrap) = 3.2.0
52Provides: bundled(js-colpick)
53Provides: bundled(js-d3)
54Provides: bundled(js-datatables-datatools) = 2.2.3
55Provides: bundled(js-dateformat) = 1.2.3
56Provides: bundled(js-filesaver) = 0.0-git20140725
57Provides: bundled(js-highcharts) = 4.2.6
58Provides: bundled(js-html5shiv) = 3.6.2
59Provides: bundled(js-i18next) = 1.8.0
60Provides: bundled(js-ion-sound) = 3.0.6
61Provides: bundled(js-jquery) = 1.12.0
62Provides: bundled(js-jquery-noty) = 2.1.0
63Provides: bundled(js-less) = 1.3.0
64Provides: bundled(js-ngdraggable)
65Provides: bundled(js-nggrid)
66Provides: bundled(js-ozwcp)
67Provides: bundled(js-require) = 2.1.14
68Provides: bundled(js-respond) = 1.1.0
69Provides: bundled(js-wow) = 0.1.9
70Provides: bundled(js-zeroclipboard) = 1.0.4
71
72%description
73Domoticz is a Home Automation System that lets you monitor and
74configure various devices like: Lights, Switches, various
75sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
76and much more. Notifications/Alerts can be sent to any mobile device
77
78%prep
72784cf7 79%setup -q
10f7a92e
AM
80
81APPVERSION="%{version}"
82echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
83echo '#define APPHASH "%{snap}"' >> appversion.h
84APPDATE=$(date --date="%{date}" "+%s")
85echo "#define APPDATE ${APPDATE}" >> appversion.h
86
9dda6696
AM
87%patch2 -p1 -b.tinyxpath
88%patch3 -p1 -b.openzwave
86ad2462 89#%patch4 -p1 -b.openzwave-Dev
9dda6696 90%patch5 -p1 -b.python
d051ba14 91%patch6 -p1
10f7a92e 92
9dda6696
AM
93rm -f hardware/openzwave/*.h
94rm -rf hardware/openzwave/aes
95rm -rf hardware/openzwave/command_classes
96rm -rf hardware/openzwave/platform
97rm -rf hardware/openzwave/value_classes
98rm -rf sqlite/
99rm -rf tinyxpath/
100
101%build
102install -d build && cd build
103%cmake \
71593ba7
JR
104 -DUSE_OPENSSL_STATIC=NO \
105 -DUSE_STATIC_LIBSTDCXX=NO \
106 -DUSE_STATIC_OPENZWAVE=NO \
72784cf7
AM
107 -DUSE_OPENSSL_STATIC=NO \
108 -DUSE_BUILTIN_JSONCPP=NO \
71593ba7 109 -DUSE_BUILTIN_LUA=NO \
72784cf7 110 -DUSE_BUILTIN_MINIZIP=NO \
71593ba7
JR
111 -DUSE_BUILTIN_MQTT=NO \
112 -DUSE_BUILTIN_SQLITE=NO \
113 -DUSE_BUILTIN_TINYXPATH=NO \
114 -DUSE_STATIC_BOOST=NO \
115 -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
116 ..
00bce45c 117
9dda6696
AM
118%{__make}
119
120%install
121rm -rf $RPM_BUILD_ROOT
00bce45c
AM
122%{__make} -C build install \
123 DESTDIR=$RPM_BUILD_ROOT
9dda6696
AM
124
125# remove docs, we grab them in files below
126rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
127
128# move binary to standard directory
129install -d $RPM_BUILD_ROOT%{_bindir}/
130mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/
131
132# install systemd service and config
133install -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
134install -d $RPM_BUILD_ROOT%{systemdunitdir}/
135cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/
136cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
137
138# create database/ssl cert directory
139install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/
140
141# Disable the app's self-update script
142
143# Unbundle DroidSans.ttf
144rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/DroidSans.ttf
06cb1c68 145ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
146 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/
147rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/DroidSans.ttf
06cb1c68 148ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
149 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/
150rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/DroidSans.ttf
06cb1c68 151ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
152 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/
153
154# OpenZWave Control Panel temp file
155ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
156 $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
157
158%clean
159rm -rf $RPM_BUILD_ROOT
160
161%pre
162getent group domoticz >/dev/null || groupadd -r domoticz
163getent passwd domoticz >/dev/null || \
164useradd -r -g domoticz -d %{_datadir}/%{name} -s /sbin/nologin \
165-c "Domoticz Home Automation Server" domoticz
166# For OpenZWave USB access (/dev/ttyACM#)
167usermod -G domoticz,dialout domoticz
168
169%post
170%systemd_post %{name}.service
171
172%preun
173%systemd_preun %{name}.service
174
175%postun
5ac2f181 176%systemd_reload
9dda6696
AM
177
178%files
179%defattr(644,root,root,755)
180%doc License.txt
181%doc README.md History.txt
182%attr(755,root,root) %{_bindir}/%{name}
183%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
184%{_datadir}/%{name}/
185%attr(755,domoticz,domoticz) %{_sharedstatedir}/%{name}/
186%{systemdunitdir}/%{name}.service
This page took 0.886012 seconds and 4 git commands to generate.