]> git.pld-linux.org Git - packages/dokuwiki.git/commitdiff
up to 2014-05-05 "Ponder Stibbons"
authorElan Ruusamäe <glen@delfi.ee>
Fri, 9 May 2014 08:10:43 +0000 (11:10 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 9 May 2014 08:10:43 +0000 (11:10 +0300)
dokuwiki-config.patch
dokuwiki-notifyns.patch
dokuwiki.spec
interwiki-outputonly.patch
system-jquery.patch
task-1821.patch

index be6ae2f1c219cf674a61c9eb5007cb65938c9058..e868c51fa6daa87af5aee6da266478643b8087e5 100644 (file)
  $conf['userewrite']  = 0;                //this makes nice URLs: 0: off 1: .htaccess 2: internal
  $conf['useslash']    = 0;                //use slash instead of colon? only when rewrite is on
  $conf['sepchar']     = '_';              //word separator character in page names; may be a
---- dokuwiki-2013-12-08/install.php~   2013-12-18 23:05:54.321131662 +0200
-+++ dokuwiki-2013-12-08/install.php    2013-12-18 23:06:30.110557953 +0200
-@@ -58,7 +58,7 @@
-     '2012-01-25'   => '72c083c73608fc43c586901fd5dabb74',
+--- dokuwiki-2014-05-06/install.php~   2014-05-08 11:32:46.919361482 +0300
++++ dokuwiki-2014-05-06/install.php    2014-05-08 11:33:23.585438490 +0300
+@@ -59,7 +59,7 @@
      '2012-09-10'   => 'eb0b3fc90056fbc12bac6f49f7764df3',
      '2013-05-10'   => '7b62b75245f57f122d3e0f8ed7989623',
--    '2013-12-08'   => '263c76af309fbf083867c18a34ff5214',
-+    '2013-12-08'   => '5527d61a24b4feb0ade5a952848108fb',
+     '2013-12-08'   => '263c76af309fbf083867c18a34ff5214',
+-    '2014-05-05'   => '263c76af309fbf083867c18a34ff5214',
++    '2014-05-05'   => '5527d61a24b4feb0ade5a952848108fb',
  );
  
  
index 1e92e6cba11975d50d9215501bd2e0d139d8490d..7c192e5ea9676a34f9707338b569232cec687d7b 100644 (file)
      } elseif($who == 'subscribers') {
          if(!actionOK('subscribe')) return false; //subscribers enabled?
          if($conf['useacl'] && $_SERVER['REMOTE_USER'] && $minor) return false; //skip minors
---- dokuwiki-2013-05-10/inc/media.php~ 2013-05-10 15:45:54.000000000 +0300
-+++ dokuwiki-2013-05-10/inc/media.php  2013-05-28 22:49:27.423136743 +0300
-@@ -551,10 +551,11 @@
+--- dokuwiki-2014-05-06/inc/media.php~ 2014-05-06 15:09:52.000000000 +0300
++++ dokuwiki-2014-05-06/inc/media.php  2014-05-08 11:24:16.977561680 +0300
+@@ -573,10 +573,11 @@
   */
  function media_notify($id,$file,$mime,$old_rev=false){
      global $conf;
--    if(empty($conf['notify'])) return; //notify enabled?
+-    if(empty($conf['notify'])) return false; //notify enabled?
 +    $to = notifyNS($id, $conf['notify']);
-+    if(empty($to)) return; //notify enabled?
++    if(empty($to)) return false; //notify enabled?
  
      $subscription = new Subscription();
--    return $subscription->send_media_diff($conf['notify'], 'uploadmail', $id, $old_rev, '');
-+    return $subscription->send_media_diff($to, 'uploadmail', $id, $old_rev, '');
+-    return $subscription->send_media_diff($conf['notify'], 'uploadmail', $id, $old_rev);
++    return $subscription->send_media_diff($to, 'uploadmail', $id, $old_rev);
  }
  
  /**
index ee10bc4efb9b2c583274ba9178532642e95d03d8..6575ce31832da3dd806357fbd91468e91c8d3a5d 100644 (file)
@@ -1,4 +1,4 @@
-%define                subver  2013-12-08
+%define                subver  2014-05-05
 %define                ver             %(echo %{subver} | tr -d -)
 #define                snap    1
 #define                rc_     1
@@ -12,7 +12,7 @@ Release:      1
 License:       GPL v2
 Group:         Applications/WWW
 Source0:       http://download.dokuwiki.org/src/dokuwiki/%{name}-%{subver}.tgz
-# Source0-md5: 620b7fed511e643ad05ad13207baa502
+# Source0-md5: 9bc798f823f1907664d769f3d1f588b7
 Source1:       %{name}-apache.conf
 Source2:       %{name}-lighttpd.conf
 Source3:       http://glen.alkohol.ee/pld/jude.png
@@ -50,7 +50,7 @@ Patch26:      system-lessphp.patch
 URL:           https://www.dokuwiki.org/
 BuildRequires: fslint
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
-BuildRequires: rpmbuild(macros) >= 1.520
+BuildRequires: rpmbuild(macros) >= 1.693
 Requires:      jquery >= 1.8
 #Requires:     jquery >= 1.9.1
 Requires:      jquery-cookie
@@ -127,7 +127,7 @@ po pierwszej instalacji. Potem należy go odinstalować, jako że
 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
 
 %prep
-%setup -q -n %{name}-%{?rc_:rc}%{subver} %{?snap:-c}
+%setup -q -n %{name}-%{?rc_:rc}2014-05-06 %{?snap:-c}
 %if 0%{?snap:1}
 mv *-dokuwiki-*/* .
 test -e VERSION || echo %{subver}-git > VERSION
@@ -190,8 +190,7 @@ find -name _dummy | xargs %{__rm}
 # flash source on git tarballs
 rm -rf lib/_fla
 rm -rf lib/plugins/testing
-rm -rf lib/plugins/config/_test
-rm -rf lib/plugins/usermanager/_test
+rm -r lib/plugins/*/_test
 
 # use system packages
 %{__rm} lib/scripts/jquery/update.sh
@@ -359,10 +358,11 @@ exit 0
 %{_appdir}/index.php
 %dir %{_appdir}/bin
 %attr(755,root,root) %{_appdir}/bin/dwpage.php
+%attr(755,root,root) %{_appdir}/bin/gittool.php
 %attr(755,root,root) %{_appdir}/bin/indexer.php
 %attr(755,root,root) %{_appdir}/bin/render.php
-%attr(755,root,root) %{_appdir}/bin/wantedpages.php
 %attr(755,root,root) %{_appdir}/bin/striplangs.php
+%attr(755,root,root) %{_appdir}/bin/wantedpages.php
 
 %dir %{_appdir}/inc
 %{_appdir}/inc/*.php
@@ -373,6 +373,7 @@ exit 0
 # allow plugins dir permission change to allow installation of plugins from admin
 # however does not work with rpm 4.5
 %dir %config %verify(not group mode) %{_appdir}/lib/plugins
+%{_appdir}/lib/plugins/*.php
 %dir %{_appdir}/lib/plugins/acl
 %{_appdir}/lib/plugins/acl/*.*
 %{_appdir}/lib/plugins/acl/pix
@@ -399,9 +400,10 @@ exit 0
 %{_appdir}/lib/plugins/config/*.*
 %{_appdir}/lib/plugins/config/images
 %{_appdir}/lib/plugins/config/settings
-%dir %{_appdir}/lib/plugins/plugin
-%{_appdir}/lib/plugins/plugin/*.*
-%{_appdir}/lib/plugins/plugin/classes
+%dir %{_appdir}/lib/plugins/extension
+%{_appdir}/lib/plugins/extension/*.*
+%{_appdir}/lib/plugins/extension/helper
+%{_appdir}/lib/plugins/extension/images
 %dir %{_appdir}/lib/plugins/revert
 %{_appdir}/lib/plugins/revert/*.*
 %dir %{_appdir}/lib/plugins/safefnrecode
@@ -413,7 +415,6 @@ exit 0
 %{_appdir}/lib/plugins/info/*.*
 %dir %{_appdir}/lib/plugins/popularity
 %{_appdir}/lib/plugins/popularity/*.*
-%{_appdir}/lib/plugins/*.php
 
 %{_appdir}/lib/images
 %{_appdir}/lib/scripts
index 27fe9a5b05cf01309290b4dc3dadfebf10710f2f..a0fe4356490a52c04685196f1269a5b534a8df73 100644 (file)
@@ -1,9 +1,9 @@
---- dokuwiki-rc2013-10-28/inc/parser/xhtml.php~        2013-11-13 22:20:29.920364255 +0200
-+++ dokuwiki-rc2013-10-28/inc/parser/xhtml.php 2013-11-13 22:20:52.460009959 +0200
-@@ -686,7 +686,7 @@
+--- dokuwiki-2014-05-06/inc/parser/xhtml.php~  2014-05-08 11:24:44.093792329 +0300
++++ dokuwiki-2014-05-06/inc/parser/xhtml.php   2014-05-08 11:25:15.469954476 +0300
+@@ -689,7 +689,7 @@
  
      /**
-     */
+      */
 -    function interwikilink($match, $name = null, $wikiName, $wikiUri) {
 +    function interwikilink($match, $name = null, $wikiName, $wikiUri, $returnonly = false) {
          global $conf;
index 4cf4f109da6a8b427b568c7970d0236173981395..3ccb4fa5af737b423d241f6e4748adf2d7ecfd17 100644 (file)
@@ -1,16 +1,15 @@
---- dokuwiki-2013-05-10/lib/exe/js.php 2013-05-28 11:51:39.656021911 +0300
-+++ dokuwiki-2013-05-10/lib/exe/js.php 2013-05-28 16:22:44.737594377 +0300
-@@ -40,10 +40,9 @@
+--- dokuwiki-2014-05-06/lib/exe/js.php~        2014-05-06 15:09:52.000000000 +0300
++++ dokuwiki-2014-05-06/lib/exe/js.php 2014-05-08 11:22:58.838818098 +0300
+@@ -40,9 +40,9 @@
  
      // array of core files
      $files = array(
 -                DOKU_INC."lib/scripts/jquery/jquery$min.js",
 -                DOKU_INC.'lib/scripts/jquery/jquery.cookie.js',
 -                DOKU_INC."lib/scripts/jquery/jquery-ui$min.js",
--                DOKU_INC."lib/scripts/jquery/jquery-migrate$min.js",
 +                "/usr/share/jquery/jquery$min.js",
-+                '/usr/share/jquery/cookie/cookie.js',
-+                '/usr/share/jquery/ui/jquery-ui.js',
++                "/usr/share/jquery/cookie/cookie.js",
++                "/usr/share/jquery/ui/jquery-ui.js",
+                 DOKU_INC."lib/scripts/jquery/jquery-migrate$min.js",
+                 DOKU_INC.'inc/lang/'.$conf['lang'].'/jquery.ui.datepicker.js',
                  DOKU_INC."lib/scripts/fileuploader.js",
-                 DOKU_INC."lib/scripts/fileuploaderextended.js",
-                 DOKU_INC.'lib/scripts/helpers.js',
index 4854d2040f348465aef7853aececd16ad08f9c57..f7c7eba83f5fa9c36638780ef638158942c07d43 100644 (file)
@@ -4,37 +4,34 @@ TODO:
 use rev1, rev2
 http://wintersunset.delfi.lan/dokuwiki/googledrawing?do=diff&rev1=1345291381&rev2=&difftype=sidebyside
 
---- dokuwiki-2012-07-16/inc/html.php~  2012-07-16 11:47:58.000000000 +0300
-+++ dokuwiki-2012-07-16/inc/html.php   2012-07-16 11:53:24.640163788 +0300
-@@ -1086,9 +1086,13 @@
-     // given as rev and rev2 parameters, with rev2 being optional. Or in an
-     // array in rev2.
+--- dokuwiki-2014-05-06/inc/html.php   2014-05-08 11:27:02.548232655 +0300
++++ dokuwiki-2014-05-06/inc/html.php   2014-05-08 11:27:02.548232655 +0300
+@@ -1134,7 +1134,13 @@
      $rev1 = $REV;
--
      $rev2 = $INPUT->ref('rev2');
--    if(is_array($rev2)){
+-    if(is_array($rev2)) {
 +
 +    // handle $r1 + $r2, see DW #1821
 +    if ($INPUT->has('r1') && $INPUT->has('r2')) {
 +        $rev1 = $INPUT->int('r1');
 +        $rev2 = $INPUT->int('r2');
++
 +    } elseif(is_array($rev2)){
          $rev1 = (int) $rev2[0];
          $rev2 = (int) $rev2[1];
  
---- dokuwiki-20110329/inc/html.php~    2011-03-29 09:20:42.000000000 +0300
-+++ dokuwiki-20110329/inc/html.php     2011-03-29 09:21:51.507042136 +0300
-@@ -1030,8 +1030,8 @@
-         $diffurl = wl($ID, array(
-                         'do'       => 'diff',
--                        'rev2[0]'  => $l_rev,
--                        'rev2[1]'  => $r_rev,
-+                        'r1'       => $l_rev,
-+                        'r2'       => $r_rev,
-                         'difftype' => $type,
-                       ));
-         ptln('<br /><a class="wikilink1" href="'.$diffurl.'">'.$lang['difflink'].'</a>');
+@@ -1458,8 +1464,8 @@
+     } else {
+         $urlparam = array(
+             'do' => 'diff',
+-            'rev2[0]' => $lrev,
+-            'rev2[1]' => $rrev,
++            'r1' => $lrev,
++            'r2' => $rrev,
+             'difftype' => $difftype,
+         );
+     }
 --- dokuwiki/inc/subscription.php      2013-05-29 22:02:46.801329978 +0300
 +++ dokuwiki/inc/subscription.php      2013-05-29 23:04:29.374883349 +0300
 @@ -384,12 +384,13 @@
This page took 0.165243 seconds and 4 git commands to generate.