]> git.pld-linux.org Git - packages/dokuwiki.git/commitdiff
- up to 2012-07-08 snap
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 8 Jul 2012 08:31:31 +0000 (08:31 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dokuwiki-geshi.patch -> 1.6
    dokuwiki-http_auth-option.patch -> 1.6
    dokuwiki-notify-respect-minor.patch -> 1.3
    dokuwiki-notifyns.patch -> 1.4
    dokuwiki.spec -> 1.109

dokuwiki-geshi.patch
dokuwiki-http_auth-option.patch
dokuwiki-notify-respect-minor.patch
dokuwiki-notifyns.patch
dokuwiki.spec

index 1468d0a97f8bcf5405186659a981317bfcd5402a..0e1f884e44cf0781c57a149d218f27abe8fa2f62 100644 (file)
@@ -1,9 +1,9 @@
---- dokuwiki-rc2010-10-07/inc/parserutils.php~ 2010-10-07 21:21:37.000000000 +0300
-+++ dokuwiki-rc2010-10-07/inc/parserutils.php  2010-10-07 21:24:30.142987536 +0300
-@@ -634,14 +634,14 @@
+--- dokuwiki-2012-07-08/./inc/parserutils.php~ 2012-07-07 13:06:48.000000000 +0300
++++ dokuwiki-2012-07-08/./inc/parserutils.php  2012-07-08 11:20:06.395684716 +0300
+@@ -748,14 +748,14 @@
      $cache = getCacheName($language.$code,".code");
      $ctime = @filemtime($cache);
-     if($ctime && !$_REQUEST['purge'] &&
+     if($ctime && !$INPUT->bool('purge') &&
 -            $ctime > filemtime(DOKU_INC.'inc/geshi.php') &&                 // geshi changed
 -            $ctime > @filemtime(DOKU_INC.'inc/geshi/'.$language.'.php') &&  // language syntax definition changed
 +            $ctime > filemtime('/usr/share/php/geshi.php') &&                 // geshi changed
index 9bf82b67fa1019dedc30591367d5ea3f4519a5da..5240da7d4d4f47f4c7fc38edce4862c1d0a6d76c 100644 (file)
@@ -8,14 +8,14 @@
  $conf['securecookie'] = 1;               //never send HTTPS cookies via HTTP
  
  /* Advanced Options */
---- dokuwiki-rc2010-10-07/inc/auth.php~        2010-10-07 21:25:10.000000000 +0300
-+++ dokuwiki-rc2010-10-07/inc/auth.php 2010-10-07 21:26:19.795893378 +0300
-@@ -77,7 +77,7 @@
+--- dokuwiki-2012-07-08/inc/auth.php~  2012-07-07 13:06:48.000000000 +0300
++++ dokuwiki-2012-07-08/inc/auth.php   2012-07-08 11:21:54.220213692 +0300
+@@ -84,7 +84,7 @@
      }
  
      // if no credentials were given try to use HTTP auth (for SSO)
--    if(empty($_REQUEST['u']) && empty($_COOKIE[DOKU_COOKIE]) && !empty($_SERVER['PHP_AUTH_USER'])){
-+    if($conf['http_auth'] && empty($_REQUEST['u']) && empty($_COOKIE[DOKU_COOKIE]) && !empty($_SERVER['PHP_AUTH_USER'])){
-         $_REQUEST['u'] = $_SERVER['PHP_AUTH_USER'];
-         $_REQUEST['p'] = $_SERVER['PHP_AUTH_PW'];
-         $_REQUEST['http_credentials'] = true;
+-    if(!$INPUT->str('u') && empty($_COOKIE[DOKU_COOKIE]) && !empty($_SERVER['PHP_AUTH_USER'])) {
++    if($conf['http_auth'] && !$INPUT->str('u') && empty($_COOKIE[DOKU_COOKIE]) && !empty($_SERVER['PHP_AUTH_USER'])) {
+         $INPUT->set('u', $_SERVER['PHP_AUTH_USER']);
+         $INPUT->set('p', $_SERVER['PHP_AUTH_PW']);
+         $INPUT->set('http_credentials', true);
index 114436e04cb2aea98a89d8c52b3fc415f3c8c0fb..4ceecf3deed7c6f1c8968bd0a8133ba4b7da0409 100644 (file)
@@ -1,9 +1,9 @@
---- dokuwiki-rc2010-10-07/inc/common.php~      2010-10-07 21:27:15.000000000 +0300
-+++ dokuwiki-rc2010-10-07/inc/common.php       2010-10-07 21:28:01.732549375 +0300
-@@ -1073,6 +1073,7 @@
-     // decide if there is something to do
-     if($who == 'admin'){
-         if(empty($conf['notify'])) return; //notify enabled?
+--- dokuwiki-2012-07-08/inc/common.php~        2012-07-07 13:06:48.000000000 +0300
++++ dokuwiki-2012-07-08/inc/common.php 2012-07-08 11:23:14.913603122 +0300
+@@ -1110,6 +1110,7 @@
+     // decide if there is something to do, eg. whom to mail
+     if($who == 'admin') {
+         if(empty($conf['notify'])) return false; //notify enabled?
 +        if($conf['useacl'] && $_SERVER['REMOTE_USER'] && $minor) return; //skip minors
          $text = rawLocale('mailtext');
          $to   = $conf['notify'];
index 631970f850b0013bc07738afdb1aad0679ea6ad7..2f7bd7fa40b3484372f8bc724f7cd455aa0f5b9d 100644 (file)
@@ -1,5 +1,5 @@
---- dokuwiki-rc2010-10-07/inc/common.php~      2010-10-07 21:31:18.000000000 +0300
-+++ dokuwiki-rc2010-10-07/inc/common.php       2010-10-07 21:33:06.502518916 +0300
+--- dokuwiki-2012-07-08/inc/common.php~        2012-07-08 11:24:16.000000000 +0300
++++ dokuwiki-2012-07-08/inc/common.php 2012-07-08 11:25:44.509886848 +0300
 @@ -902,6 +902,34 @@
    return $date;
  }
  /**
   * Sends a notify mail on page change
   *
-@@ -1100,10 +1100,10 @@
+@@ -1137,10 +1137,10 @@
  
-     // decide if there is something to do
-     if($who == 'admin'){
--        if(empty($conf['notify'])) return; //notify enabled?
+     // decide if there is something to do, eg. whom to mail
+     if($who == 'admin') {
+-        if(empty($conf['notify'])) return false; //notify enabled?
          if($conf['useacl'] && $_SERVER['REMOTE_USER'] && $minor) return; //skip minors
 +        $to   = notifyNS($id, $conf['notify']);
 +        if(empty($to)) return; //notify enabled?
          $text = rawLocale('mailtext');
 -        $to   = $conf['notify'];
          $bcc  = '';
-     }elseif($who == 'subscribers'){
-         if(!$conf['subscribers']) return; //subscribers enabled?
-@@ -1116,9 +1116,9 @@
+     } elseif($who == 'subscribers') {
+         if(!$conf['subscribers']) return false; //subscribers enabled?
+@@ -1155,9 +1155,9 @@
          $to   = '';
          $text = rawLocale('subscr_single');
-     }elseif($who == 'register'){
--        if(empty($conf['registernotify'])) return;
+     } elseif($who == 'register') {
+-        if(empty($conf['registernotify'])) return false;
 +        $to   = notifyNS($id, $conf['registernotify']);
 +        if(empty($to)) return;
          $text = rawLocale('registermail');
 -        $to   = $conf['registernotify'];
          $bcc  = '';
-     }else{
-         return; //just to be safe
+     } else {
+         return false; //just to be safe
index 2dc86593c3dbfab6d31a1e3ab4b1a44c4a67a16f..aab6e59dc832ed6ebc341ec14174b9a4388cd518 100644 (file)
@@ -1,4 +1,4 @@
-%define                subver  2012-06-24
+%define                subver  2012-07-08
 %define                ver             %(echo %{subver} | tr -d -)
 %define                snap    1
 %define                php_min_version 5.2.4
@@ -7,12 +7,12 @@ Summary:      PHP-based Wiki webapplication
 Summary(pl.UTF-8):     Aplikacja WWW Wiki oparta na PHP
 Name:          dokuwiki
 Version:       %{ver}
-Release:       1.11
+Release:       0.12
 License:       GPL v2
 Group:         Applications/WWW
 #Source0:      http://www.splitbrain.org/_media/projects/dokuwiki/%{name}-%{subver}.tgz
 Source0:       http://github.com/splitbrain/dokuwiki/tarball/master/%{name}.tgz
-# Source0-md5: 32e73e37068f66392be004374d885af9
+# Source0-md5: d7afe9a8a4a73637d4620017f16f4b6a
 Source1:       %{name}-apache.conf
 Source2:       %{name}-lighttpd.conf
 Source3:       http://glen.alkohol.ee/pld/jude.png
This page took 0.091792 seconds and 4 git commands to generate.