]> git.pld-linux.org Git - packages/dokuwiki.git/commitdiff
add option to dump different icon sizes
authorElan Ruusamäe <glen@delfi.ee>
Sun, 19 Jul 2015 14:15:24 +0000 (17:15 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 19 Jul 2015 14:16:19 +0000 (17:16 +0300)
rejected by upstream
https://github.com/splitbrain/dokuwiki/pull/1187

dokuwiki.spec
iconsizes-dump.patch [new file with mode: 0644]

index 7cfd57d158c996ad7df4d906fcf6abe36d46068c..6450a242222ee43eed925d548ec758b66e61067d 100644 (file)
@@ -48,6 +48,7 @@ Patch22:      adldap.patch
 Patch24:       more-buttons.patch
 Patch25:       system-phpseclib.patch
 Patch26:       system-lessphp.patch
+Patch27:       iconsizes-dump.patch
 URL:           https://www.dokuwiki.org/
 BuildRequires: fslint
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
@@ -156,6 +157,7 @@ echo '====== PlayGround ======' >  data/pages/playground/playground.txt
 %patch24 -p1
 %patch25 -p1
 %patch26 -p1
+%patch27 -p1
 
 %patch66 -p1
 
diff --git a/iconsizes-dump.patch b/iconsizes-dump.patch
new file mode 100644 (file)
index 0000000..f017497
--- /dev/null
@@ -0,0 +1,54 @@
+From dcd19aee23d60b285ec5d4991eb1f3b51cae34b7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Elan=20Ruusam=C3=A4e?= <glen@delfi.ee>
+Date: Tue, 9 Jun 2015 11:16:12 +0300
+Subject: [PATCH] fileicons: allow specify what sizes to dump
+URL: https://github.com/splitbrain/dokuwiki/pull/1187
+Status: Rejected by upstream
+
+---
+ lib/images/fileicons/index.php | 17 ++++++++++++++++-
+ 1 file changed, 16 insertions(+), 1 deletion(-)
+
+diff --git a/lib/images/fileicons/index.php b/lib/images/fileicons/index.php
+index 09b6c9d..ffb41c5 100644
+--- a/lib/images/fileicons/index.php
++++ b/lib/images/fileicons/index.php
+@@ -28,6 +28,13 @@
+ </head>
+ <body>
++<?php
++$sizes = isset($_GET['sizes']) ? explode(',', (string)$_GET['sizes']) : array(16, 32);
++?>
++
++<?php
++if (in_array(16, $sizes)) :
++?>
+ <div class="white box">
+ <?php
+ foreach (glob('*.png') as $img) {
+@@ -45,7 +52,13 @@
+ </div>
+ <br style="clear: left" />
++<?php
++endif;
++?>
++<?php
++if (in_array(32, $sizes)) :
++?>
+ <div class="white box">
+     <?php
+     foreach (glob('32x32/*.png') as $img) {
+@@ -61,7 +74,9 @@
+     }
+     ?>
+ </div>
+-
++<?php
++endif;
++?>
+ </body>
+ </html>
This page took 0.13343 seconds and 4 git commands to generate.