]> git.pld-linux.org Git - packages/dokuwiki-plugin-pagelist.git/blob - dokuwiki-plugin-pagelist.spec
- do not use subshell, so the exit code could be propagated
[packages/dokuwiki-plugin-pagelist.git] / dokuwiki-plugin-pagelist.spec
1 %define         plugin          pagelist
2 Summary:        DokuWiki Pagelist Plugin
3 Name:           dokuwiki-plugin-%{plugin}
4 Version:        20080808
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        http://www.chimeric.de/_src/plugin-pagelist.tgz
9 # Source0-md5:  fd632aca9688a48c682a1ebdfe1e2aba
10 Source1:        dokuwiki-find-lang.sh
11 URL:            http://www.dokuwiki.org/plugin:pagelist
12 Requires:       dokuwiki >= 20061106
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         dokuconf        /etc/webapps/dokuwiki
17 %define         dokudir         /usr/share/dokuwiki
18 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
19
20 %description
21 The Pagelist Plugin does – as its name says – list wiki pages in a
22 nice way. Besides its function as a stand-alone syntax plugin, it
23 serves as helper plugin for the Blog, Discussion, Editor, Tag, Task
24 and Dir plugins.
25
26 %prep
27 %setup -q -n %{plugin}
28 if [ $(cat VERSION | tr -d -) != %{version} ]; then
29         : %%{version} mismatch, should be: $(cat VERSION | tr -d -)
30         exit 1
31 fi
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT%{plugindir}
36 cp -a . $RPM_BUILD_ROOT%{plugindir}
37 rm -f $RPM_BUILD_ROOT%{plugindir}/{COPYING,README,VERSION}
38
39 # find locales
40 sh %{SOURCE1} %{name}.lang
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %post
46 # force css cache refresh
47 if [ -f %{dokuconf}/local.php ]; then
48         touch %{dokuconf}/local.php
49 fi
50
51
52 %files -f %{name}.lang
53 %defattr(644,root,root,755)
54 %doc README
55 %dir %{plugindir}
56 %{plugindir}/*.php
57 %{plugindir}/*.css
58 %{plugindir}/conf
This page took 0.038848 seconds and 3 git commands to generate.