]> git.pld-linux.org Git - packages/dokuwiki-plugin-orphanswanted.git/blob - dokuwiki-plugin-orphanswanted.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dokuwiki-plugin-orphanswanted.git] / dokuwiki-plugin-orphanswanted.spec
1 %define         subver  2017-06-25
2 %define         ver             %(echo %{subver} | tr -d -)
3 %define         plugin          orphanswanted
4 %define         php_min_version 5.3.0
5 %include        /usr/lib/rpm/macros.php
6 Summary:        DokuWiki plugin to find orphan pages, Wanted pages with reference counts
7 Name:           dokuwiki-plugin-%{plugin}
8 Version:        %{ver}
9 Release:        1
10 License:        GPL v2
11 Group:          Applications/WWW
12 Source0:        https://github.com/lupo49/dokuwiki-plugin-orphanswanted/archive/163625f/%{plugin}-%{subver}.tar.gz
13 # Source0-md5:  b14fbb365e9b9e0dfcde770e7b50a0d3
14 URL:            https://www.dokuwiki.org/plugin:orphanswanted
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.553
17 Requires:       dokuwiki >= 20131208
18 Requires:       php(core) >= %{php_min_version}
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         dokuconf        /etc/webapps/dokuwiki
23 %define         dokudir         /usr/share/dokuwiki
24 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
25 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
26
27 %description
28 Use this plugin to find orphan pages and wanted pages.
29
30 OrphansWanted show which pages are:
31 - Orphans (the page exists, but it has no links to it)
32 - Wanted (the page does not exist, but there are link(s) to it
33   elsewhere on the site)
34 - Valid (the page exists, and it can be reached through a link)
35
36 Each table shows the reference count and a link to backlinks.
37
38 %prep
39 %setup -qc
40 mv *-%{plugin}-*/* .
41
42 %build
43 version=$(awk '/^date/{print $2}' plugin.info.txt)
44 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
45         : %%{version} mismatch
46         exit 1
47 fi
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{plugindir}
52 cp -a . $RPM_BUILD_ROOT%{plugindir}
53 rm $RPM_BUILD_ROOT%{plugindir}/{COPYING,README}
54
55 %find_lang %{name}.lang
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files -f %{name}.lang
61 %defattr(644,root,root,755)
62 %doc README
63 %dir %{plugindir}
64 %{plugindir}/*.php
65 %{plugindir}/*.txt
66 %{plugindir}/conf
This page took 0.052016 seconds and 3 git commands to generate.