]> git.pld-linux.org Git - packages/dokuwiki-plugin-odt.git/blob - dokuwiki-plugin-odt.spec
- up to 20100812
[packages/dokuwiki-plugin-odt.git] / dokuwiki-plugin-odt.spec
1 %define         plugin          odt
2 Summary:        DokuWiki odt (Open Document Text) Export Plugin
3 Summary(pl.UTF-8):      Wtyczka do eksportowania plików odt (Open Document Text)
4 Name:           dokuwiki-plugin-%{plugin}
5 Version:        20100812
6 Release:        1
7 License:        GPL v2
8 Group:          Applications/WWW
9 Source0:        http://aurelien.bompard.org/projects/files/dokuwiki-odt/dokuwiki-odt-20100812.zip
10 # Source0-md5:  28839a411068e2c923c74734e35481ff
11 Patch0:         dokuwiki-ziplib.patch
12 Patch1:         geshi.patch
13 URL:            http://wiki.splitbrain.org/plugin:odt
14 BuildRequires:  unzip
15 Requires:       dokuwiki >= 20070626
16 Requires:       php-common >= 4:5.0
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         dokuconf        /etc/webapps/dokuwiki
21 %define         dokudir         /usr/share/dokuwiki
22 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
23 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
24
25 %description
26 This plugin allows you to export a page to the OpenDocument format
27 used by Open Office and other word processors. This is especially
28 useful when you need to give a single page to a customer
29
30 Hint: Open Office can also export to PDF.
31
32 %description -l pl.UTF-8
33 Ta wtyczka pozwala na eksportowanie strony do formatu OpenDocument,
34 używanego przez Open Office i inne edytory tekstu. Przydatna jest w
35 sytuacji w której musisz dać pojedyńczą stronę klientowi.
36
37 Podpowiedź: Open Office pozwala także na eksportowanie do PDF.
38
39 %prep
40 %setup -qc
41 mv %{plugin}/* .
42
43 %patch0 -p1
44 %patch1 -p1
45
46 version=$( awk '/^date/{print $2}' info.txt)
47 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
48         : %%{version} mismatch
49         exit 1
50 fi
51
52 rm -f ZipLib.class.php
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{plugindir}
57 cp -a conf lang *.php *.png *.xml info.txt $RPM_BUILD_ROOT%{plugindir}
58 rm -f $RPM_BUILD_ROOT%{plugindir}/{ChangeLog,.gitignore}
59
60 %find_lang %{name}.lang
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 # force css cache refresh
67 if [ -f %{dokuconf}/local.php ]; then
68         touch %{dokuconf}/local.php
69 fi
70
71 %files -f %{name}.lang
72 %defattr(644,root,root,755)
73 %doc ChangeLog.txt README.txt
74 %defattr(644,root,root,755)
75 %dir %{plugindir}
76 %{plugindir}/*.txt
77 %{plugindir}/*.png
78 %{plugindir}/*.xml
79 %{plugindir}/*.php
80 %dir %{plugindir}/conf
81 %{plugindir}/conf/*.php
This page took 0.061079 seconds and 4 git commands to generate.