]> git.pld-linux.org Git - packages/dokuwiki-plugin-odt.git/blob - dokuwiki-plugin-odt.spec
up to 2017-02-18; requires 2015-08-10 “Detritus”
[packages/dokuwiki-plugin-odt.git] / dokuwiki-plugin-odt.spec
1 %define         subver  2017-02-18
2 %define         ver             %(echo %{subver} | tr -d -)
3 %define         plugin          odt
4 %define         php_min_version 5.5
5 Summary:        OpenOffice.org/LibreOffice.org Export
6 Summary(pl.UTF-8):      Wtyczka do eksportowania plików odt (Open Document Text)
7 Name:           dokuwiki-plugin-%{plugin}
8 Version:        %{ver}
9 Release:        1
10 License:        GPL v2
11 Group:          Applications/WWW
12 Source0:        https://github.com/LarsGit223/dokuwiki-plugin-odt/archive/%{subver}/%{name}-%{ver}.tar.gz
13 # Source0-md5:  6768d4d2e55c676bc46ef877abaeeb34
14 URL:            https://www.dokuwiki.org/plugin:odt
15 Requires:       dokuwiki >= 20150810
16 Requires:       php(core) >= %{php_min_version}
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         dokuconf        /etc/webapps/dokuwiki
21 %define         dokudir         /usr/share/dokuwiki
22 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
23 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
24
25 %description
26 This plugin allows you to export a page to the OpenDocument format
27 used by OpenOffice.org, LibreOffice.org and other word processors.
28
29 This is especially useful when you need to print or to give a single
30 page to a customer.
31
32 Hint: OpenOffice.org can also export to PDF.
33
34 %description -l pl.UTF-8
35 Ta wtyczka pozwala na eksportowanie strony do formatu OpenDocument,
36 używanego przez Open Office i inne edytory tekstu. Przydatna jest w
37 sytuacji w której musisz dać pojedyńczą stronę klientowi.
38
39 Podpowiedź: Open Office pozwala także na eksportowanie do PDF.
40
41 %prep
42 %setup -q -n %{name}-%{subver}
43
44 %build
45 version=$(awk '/^date/{print $2}' plugin.info.txt)
46 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
47         : %%{version} mismatch
48         exit 1
49 fi
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{plugindir}
54 cp -a . $RPM_BUILD_ROOT%{plugindir}
55 %{__rm} $RPM_BUILD_ROOT%{plugindir}/deleted.files
56 %{__rm} $RPM_BUILD_ROOT%{plugindir}/phpdoc.dist.xml
57 %{__rm} $RPM_BUILD_ROOT%{plugindir}/{ChangeLog,README}.txt
58
59 %find_lang %{name}.lang
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 # force css cache refresh
66 if [ -f %{dokuconf}/local.php ]; then
67         touch %{dokuconf}/local.php
68 fi
69
70 %files -f %{name}.lang
71 %defattr(644,root,root,755)
72 %doc ChangeLog.txt README.txt
73 %defattr(644,root,root,755)
74 %dir %{plugindir}
75 %{plugindir}/*.css
76 %{plugindir}/*.php
77 %{plugindir}/*.png
78 %{plugindir}/*.txt
79 %{plugindir}/*.xml
80 %{plugindir}/ODT
81 %{plugindir}/action
82 %{plugindir}/conf
83 %{plugindir}/helper
84 %{plugindir}/renderer
This page took 0.065288 seconds and 3 git commands to generate.