]> git.pld-linux.org Git - packages/dokuwiki-plugin-markdownextra.git/blob - dokuwiki-plugin-markdownextra.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dokuwiki-plugin-markdownextra.git] / dokuwiki-plugin-markdownextra.spec
1 %define         plugin  markdownextra
2 %define         php_min_version 5.0.0
3 %include        /usr/lib/rpm/macros.php
4 Summary:        DokuWiki Markdown Extra plugin
5 Name:           dokuwiki-plugin-%{plugin}
6 Version:        20101106
7 Release:        2
8 License:        GPL v2
9 Group:          Applications/WWW
10 Source0:        http://madpropellerhead.com/projects/markdownextra.tgz
11 # Source0-md5:  3e703cbfe84108e252c354009a304cd2
12 Patch0:         sys-path.patch
13 URL:            http://www.dokuwiki.org/plugin:markdownextra
14 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
15 BuildRequires:  rpmbuild(macros) >= 1.553
16 Requires:       dokuwiki >= 20091225
17 Requires:       php(core) >= %{php_min_version}
18 Requires:       php(pcre)
19 Requires:       php-markdown-extra >= 1.2.4
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         dokuconf        /etc/webapps/dokuwiki
24 %define         dokudir         /usr/share/dokuwiki
25 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
26 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
27
28 %define         _noautopear     pear
29 %define         _noautoreq      %{?_noautophp} %{?_noautopear}
30
31 %description
32 Parses PHP Markdown Extra blocks.
33
34 %prep
35 %setup -qc
36 mv %{plugin}/* .
37 %undos -f txt,php
38 %patch0 -p1
39
40 version=$(awk '/^date/{print $2}' plugin.info.txt)
41 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
42         : %%{version} mismatch
43         exit 1
44 fi
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{plugindir}
49 cp -a . $RPM_BUILD_ROOT%{plugindir}
50 %{__rm} $RPM_BUILD_ROOT%{plugindir}/License.text
51
52 # php-markdown-extra
53 %{__rm} $RPM_BUILD_ROOT%{plugindir}/markdown.php
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc License.text
61 %dir %{plugindir}
62 %{plugindir}/*.php
63 %{plugindir}/*.txt
This page took 0.289917 seconds and 3 git commands to generate.